Server Management - Remote Server Management

UEFI and Set-HPEiLOOneTimeBootOption - cdrom device name

Occasional Contributor

UEFI and Set-HPEiLOOneTimeBootOption - cdrom device name

Hello HPE community,

I'm starting to build a powershell script to automate the SPP update of our BL460c ESXi hosts.

The idea is to first mount the SPP with the Mount-HPEiLOVirtualMedia cmdlet. Then, use the Set-HPEiLOOneTimeBootOption cmdlet to select the CD and initiate a reboot.

The first challenge I came accross is the boot mode. Some of our blades have the LegacyBios mode, and some have UEFI. I will have to align all blades to one mode. 
I didn't choose yet.

I like LegacyBios because it seems a lot easier to work with with the  HPEiLOOneTimeBootOption cmdlet. Boot options are standard and have static names. But it's ''legacy' and I'm as bit afraid of compatibility issues in the future...

On the other hand, UEFI is newer but looks more complicated to work with. The name of the cdrom device seems to change from one system to another. So this will be more complicated to script.

Basically my question is:
How would you use Set-HPEiLOOneTimeBootOption when the boot mode is set to UEFI and the cdrom name is different from one system to another?


Re: UEFI and Set-HPEiLOOneTimeBootOption - cdrom device name

hi ,

follow the power shell guide

check alt option to use ILO ISO image rather using CDROM Drive

I am a HPE Employee

Re: UEFI and Set-HPEiLOOneTimeBootOption - cdrom device name


You can use below command to set CDROM as boot source when server is set to UEFI mode.

PS C:\> $connection = Connect-HPEiLO -Username admin -Password admin123 -DisableCertificateAuthentication

PS C:\> ,$connection | Set-HPEiLOOneTimeBootOption -BootSourceOverrideEnable Continuous -BootSourceOverrideTarget CD

The CD option should not change in same generation servers like only in Gen10. But if you have combination of different genration servers then also it should work except don't provide -BootSourceOverrideEnable  parameter. and boot option should be all UEFI or all Legacy.

If you have different boot options first thing is you need to set them to one boot option either UEFI or legacy. Later you look into the CRROM options.

Set-HPEiLOBootMode -PendingBootMode UEFI



I am a HPE Employee

Accept or Kudo