Server Management - Remote Server Management
cancel
Showing results for 
Search instead for 
Did you mean: 

hponcfg error

 
SOLVED
Go to solution
BradV
Trusted Contributor

hponcfg error

Has anyone seen this error, and/or know how to rectify?  

# hponcfg -a -w config
HP Lights-Out Online Configuration utitlity
Version 5.4.0 DAte 8/6/2018 (c) 2005,2018 Hewlett Packard Enterprise Development LP
Error: Incompatible SSL library found.
           Upgrade to the latest SSL library to use HPONCFG.

openssl-libs-1.0.2k-16.el7_4.x86_64 is installed.  The same as on our other servers where hponcfg runs without complaint. 

2 REPLIES 2
Jimmy Vance
HPE Pro

Re: hponcfg error

please provide the output of 'ltrace hponcfg -g'

No support by private messages. Please ask the forum! Accept or KudoI work for HPE
BradV
Trusted Contributor
Solution

Re: hponcfg error

Thanks.  That helped lead me to the problem.  Apparently when Centrify was installed it prepended all of its directories to the PATH variable.  So, hponcfg wound up getting an ssl library out of the centrify install instead of from the openssl-libs rpm.  I'll have to modify the PATH variable on all of these servers.

Thanks Again!