Server Management - Remote Server Management

intelligent provisioning broken

 
mistay
Occasional Contributor

intelligent provisioning broken

after buying a brand-new hp proliant microserver gen10 plus i tried to install win2019 essentials server. unfortunatly i could not use "intelligent provisioning" as it seems to be broken.

i tried to enter "intelligent privsioning" by pressing "f10"-key: this brings me to a screen where i can choose between "self update" and "fallback". fallback seems to be a bootloader entry that tries to boot a linux kernel that ends up after 1.1seconds in a kernel panic as it was not able to mount root filesystem and "self update" boots a working linux kernel that tries to install a gaius.3.50-100.x86_64.rpm. i assume it therefore needs network connectivity so i connected (the first) ethernet port to a standard "home-network (dhcp), nat" but it stalls keep saying it installs that rpm file (has been running for days without changing any status).

HPE, first. please provide a better web portal that clearly describes which downloadable files (bios, intelligent provisioning, ...) should be used in order to update the system (have a look at supermicro.com how this could be achieved). and btw, please speed up your webservers....

HPE, please provide driver downloads for customers that do not want to relay on your propritary "intelligent provisioning" (that breaks) in order to still enable classic installs (just by inserting dvd/usb and running a clean install)

HPE, please make your smart controller configurable without the need of "intelligent provisioning" (that breaks)

HPE, please provide more status and esp. progress ouput if you try to download files programatically by your setup scripts. running a download without asking for network connectivity and then trying to downloading a file that is about half gigabyte in size without displaying progress is sooo 1990. we're in 2021 now.

HPE, first, i ordered this server w/o iLO 5 enable pci express card, as it was hard to me (even if we do servers since 1995) to fire out that iLO won't work without this card, so i assumed iLO will work (but will not have a dedicated ethernet port, so shared among others). it's even possible to configure network (ip, subnet, gateway, ...) within iLO bios config but .... the configuration gets lost without a single note that you have to buy that enabler pci express card. HPE, it took me half a day to figure out that it's not that buggy as "intelligent provisioning" but you want me to pay $100 extra to persist my network config within iLO. you can have $200 if you disable iLO option within bios saying "put some more money in to get this feature activated"

HPE, never ever again a microserver. it's my 4th in the last decade and its still pain/ass. why can't you go slimmer? why "intelligent provisioning"? i'd like to run a raid setup within ncurses-like  mode, no embedded web-browser that tries to hide some htpp://localhost services.

have to leave, have to order some supermicro servers and do all that freakin' RMA stuff with HPE. this server really sucks.

 

 

8 REPLIES 8
harald25
New Member

Re: intelligent provisioning broken

I'm having the same experience with brand new out of the box HP DL360 G10 server.

I've tried to update firmware via Intelligent Provisioning. The progress bar was stuck at 20% for 20-30 minutes, just saying "Downloading", and suddenly finished and asked me to reboot. Now I've rebooted, and got the same options as you "Self update" or "Fallback". I chose "Self update", and now I'm waiting for "gaius-3.50-100.x86_64.rpm to install, but I have no progress bar.

It's extremely frustrating to have this experience with a brand new server that cost several thousand dollars. I would expect a more smooth experience than this when buying enterprise level gear...

mistay
Occasional Contributor

Re: intelligent provisioning broken

its a mess that hpe delivers servers, that do not work out-of the box. even a microserver is a cheaper product i'd expect to have all that features tested before they deliver a product as such.

i had expected to quickly install a native version of windows server 2019, as this is the current server os from microsoft but without having a usable version of "intelligent provisioning" one has to run a classic install but cannot use smart array features as raid1, which sucks, of course.

i lost about half a day trying to set an ilo ip address which is actually possible but then looses it's configuration after reboot. after playing some hours i figured out that one has to buy that ilo enabler pci express card, which is totally ok so it's ok to spend some more money to get ilo remote console BUT its totaly inacceptable to provide configuration options to users and tell the users "config saved, please reboot" (or similar) and then do not persist configuration. i spent hours to figure out that this is a (anti) "feature", not a bug.

nevertheless, i resolved that issue today: as linux-only user i created the usb key from the "media recovery usb key" with gnu dd, which actually boots and shows progress bar: so i assumed the stick was created correctly but i then figured out that hpe has it's own tool for creating usb keys from iso files: it's called "hp usb key utility". i could not find a single hint one has to use that tool in order to create that usb key, even it's not mentioned in the download notes.

HPE why don't you link your tool to your downloadable iso files?

and btw: downloading that <10meg file takes minutes to download, the initial download website renders more than 20seconds before delivering content: HPE why don't you speedup your webservers?

HPE, dont you want us users to help ourselves?

and: i had to post this message a couple of times as it was previouly tagged as spam, and later was closed unresolved by HPE staff.

so finally i recovered by using their usb creation tool that is - windows only.

HPE: there's users out there who use other os than windows: there's mac admins, there is linux admins: how should they create their keys?

HPE, please FIX YOUR TOOLS. provide linux tools to create usb key. provide better descriptions in your downloads, provide scripts that work: display progress, display what's goin' on, diplay success or error messages. recovering "intelligent provisioning" does not result in an error or success message: your recovery script just reboots after completing.

after days of trouble i ask myself what's so hard in providing a slim, fast (static?) website that just holds .bin (bios, raid controller, ...) firmware/bios files that can be put on fatXX based usb keys and read by legacy bios or even uefi setups? why would one have to boot a linux kernel to open up a browser that communicates with ilo to configure a raid1 drive? for me it seems that HPE addresses "hobbyists" who "need" support in installing a operating system: i'd like to stay with vendors that allow me vanilla installations of o/s and provide device drivers to provide hardware support: i dislike broken tools that prevent installing o/s or patch files in install media just to speedup o/s installation which is not true for most of the o/s i use. never ever had to use days to setup a plain windows server on a raid1 array.

HPE: i'll now delete my external screenshots so your links  in the above post will break. omg. HPE, provide uploadable screenshots in this forum.

paganig
Occasional Visitor

Re: intelligent provisioning broken

same issue with ML 350 G10 after attempting an update of the intelligent provisioning component

mistay
Occasional Contributor

Re: intelligent provisioning broken

did my fix work?

sudhirsingh
HPE Pro

Re: intelligent provisioning broken

Hi,

Seems like IP is broken, F10/Intelligent Provisioning is not working as expected.

You should open a support case with HPE.

also

Please refer Server quick specs which has some relevant information regarding Legacy BIOS and Software Raid

https://h20195.www2.hpe.com/v2/getdocument.aspx?docname=a00073554enw

 

Software RAID
• HPE Smart Array S100i SR Gen10 Software RAID
Notes:
− HPE Smart Array S100i SR Gen10 SW RAID will operate in UEFI mode only. For legacy support an additional controller will be needed
− The S100i only supports Windows. For Linux users, HPE offers a solution that uses in-distro open-source software to create
a two-disk RAID 1 boot volume. For more information visit: https://downloads.linux.hpe.com/SDR/project/lsrrb/
Essential RAID Controller
• HPE Smart Array E208i-p SR Gen10 Controller

 

If you want to go with Uefi Mode:

Set the Boot mode to Uefi from F9

Enable and configure Raid from from RBSU.

Install OS manually with your OS media.

 

Hope this helps!

 

Regards,

Sudhir

While I am an HPE Employee, all of my comments (whether noted or not), are my own and are not any official representation of the company

>Accept or Kudo

Zaid_Al-Ani
Visitor

Re: intelligent provisioning broken

Just leave it. because it's downloading silently (> 1 GB) and it may take a couple of hours to complete

JVillar
New Member

Re: intelligent provisioning broken

just in case the problem persist

my solution:

Donwload:

Intelligent Provisioning Recovery Media for Gen10 and Gen10 Plus

https://support.hpe.com/hpesc/public/swd/detail?swItemId=MTX_ec13f2a742ed47d4bced3e0521

 

USB Key Utility for Windows

https://support.hpe.com/hpesc/public/swd/detail?swItemId=MTX_360731071b404454b454390208

 

you must create a USB bootable with the USB Key Utility and select the iso, then boot in the server from the usb and let the tool do his job

good luck

 

Anand1202
Advisor

Re: intelligent provisioning broken

You can also mount the ISO file via iLO and boot and update that way.

 

And I suggest that you download the latest version (3.64 as of writing):

Software Details - Intelligent Provisioning Recovery Media for Gen10 and Gen10 Plus | HPE Support