HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Automatic COnfiguration Of a new Server

 
shocko
Honored Contributor

Automatic COnfiguration Of a new Server

Hey guys,
Been using sim for a while now an i've run into this problem:
I would like to be able to auto-config any servers that are discovered. To do this i run an initial config task that establishses a trust relationship based on certificate and sets the read community strings on the server. This task runs when a new object enters the 'All systems' Collection. I then run a job to set the SNMP settings and then a job to set the VCA Support Pack reference based on the objects inclusion in the Server 2003 collection or otherwise. The problem is, sometimes the other jobs kick off before the initil trust relationship job has completed and fail with an error stating that the trust relationship hasnt been established. The initial trust relationship job is a 'Configure or repair Agents' job and will eventually complete after a min or so and the trust relationship will be established. heres what i think is happedning:
- The intial job runs to set the trust relationship. It imports the certficate to the server and kicks off system identification.
-As system identification runs the server gets re-classified as server 2003/server 2000 etc and the other jobs kick off but seem to think that the server is not trusted.
- By the time the intial job has completed and the server is now trusted the other jobs have failed and will not run again becuase they are event driven and the event that triggered them i.e. the object being added to the collection, will not happen again for that server.

the only way i can think of getting arund this is to set up collections for servers that have a trust status of 'true' and link the scheduled tasks to those colections.

Thanks in advance!
If my post was helpful please award me Kudos! or Points :)
5 REPLIES
shocko
Honored Contributor

Re: Automatic COnfiguration Of a new Server

HI! Had anyone any experience of this???
If my post was helpful please award me Kudos! or Points :)
David Claypool
Honored Contributor

Re: Automatic COnfiguration Of a new Server

Best practice is to build them properly in the first place. CRA is only for the occasional system that needs remediation.
shocko
Honored Contributor

Re: Automatic COnfiguration Of a new Server

Thanks for the reply!
When you say 'build them properly' what do you mean?

Do you mean once the build is complete, manually add the CMS SIM server to the trusted management server on the list??

This is what i normally do. The SNMP settings are already there from the build (i'm using scripted installations from HP RDP Altiris suite) but i would like to fully automate the entire process so i can build a server from scratch. This is exactly what i need. Whether or not its possible....

Is there a way to add to do what i need?
If my post was helpful please award me Kudos! or Points :)
David Claypool
Honored Contributor

Re: Automatic COnfiguration Of a new Server

You can pre-configure the PSP in RDP before the deployment to include the trust relationship and the certificate from HP SIM to trust, as well as the trap destination and other things.
shocko
Honored Contributor

Re: Automatic COnfiguration Of a new Server

Hey thanks david! I get it now i.e. setup the share/location that RDP uses for the install and run hpsum_config.exe to pre-configure the components!

That way i can establish a trust relationship from the off and also set the VCA to point back to my CMD. All other first rubn jobs such as that to set the VCA Baseline based on OS version should now run no problem as the server will have the CMS's certficate installed and listed in the trust management servers list!

Thanks so much for that david! Saved me a lot of time and troubleshooting.

Note to self: Read PSP deployment guide right through till the end next time!!! It does mention this here!

;)
If my post was helpful please award me Kudos! or Points :)