Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

CMS ignores trap

SOLVED
Go to solution
MC Murphy
Frequent Advisor

CMS ignores trap

The device is Network Technologies Inc Enviromux-Mini. MIB compiled, registered successfully. I can view it in Trap Settings. I created an event Handler to email and page on all events. In ethereal sniffing a hub with the device plugged in I see the snmp packets - SNMP Version 1, PDU Trap-V1, dst address is the CMS, dst port is 162. But after 6 or so attempts the CMS still says this Task has never run. What might be missing, how can I investigate?
7 REPLIES
Rob Buxton
Honored Contributor

Re: CMS ignores trap

If you click on the device name in HPSIM you can get to an Events tab, that will show all of the events that have been associated with that device. If the snmp trap is getting there and being matched to the device it should be there.

You could also try putting an snmp sniffer on the CMS itself to ensure the trap is getting there.

Check that the community names are as you'd expect at both ends. They do need to match and are case-sensitive.
MC Murphy
Frequent Advisor

Re: CMS ignores trap

It had not been discovered yet. I did a Manual Discovery, got the Discovered Event, have since got Unreachable, Discovery Timeout, and Reachable events. But still no trap. I'll try sniffer on the CMS next.
David Claypool
Honored Contributor
Solution

Re: CMS ignores trap

Select "Accept unregistered traps" in HP SIM to see if it actually is coming in but being discarded (as it would be if the trap didn't match the MIB).
MC Murphy
Frequent Advisor

Re: CMS ignores trap

i found Accept Unregistered Events, set it, and immediately started getting unregistered events associated with the device. I'd already downloaded their current MIB, compiled successfully, registered successfully. Does this mean most likely the trap the device sends does not match the MIB; so I should go back to support for their device to look for a fix? Thanks
MC Murphy
Frequent Advisor

Re: CMS ignores trap

Might this help shed light. I've got a dozen or so Unregistered Events. All show an Enterprise OID string 1.3.6.1.4.1.3699.1.1.3, and MIB information says associated MID File Name for this trap is cpqgen.mib. That's a Compaq mib, this is an NTI device, somethings's real mixed up.
The traps I sniffed contain data:
Trap-V1 SNMPV2-SMI::enterprises.3699.1.1.3.100.100.0
and
Trap-V1 SNMPV2-SMI::enterprises.3699.1.1.3.100.3.0
David Claypool
Honored Contributor

Re: CMS ignores trap

It's saying cpqgen.mib because it's a reference to the unregistered trap. The 3699 enterprise is registered to Network Technologies: http://www.iana.org/assignments/enterprise-numbers

MC Murphy
Frequent Advisor

Re: CMS ignores trap

I unregistered the enviromux-mini mib; recompiled; re-registered; restarted CMS. In the CMS SNMP Trap Settings it shows me the device, and shows me a "humiditySensor1Trap". I do a Simulate Alert at the device. Ethereal Sniffer picks up the SNMP packets, shows me the message that humidity has reached dangerous levels. But at the same time the CMS is showing the unregistered trap. Enterprise OID string 1.3.6.1.4.1.3699.1.1.3. The Sniffer is showing object id 1.3.6.1.4.1.3699.1.1.3.100.100.0.
Is it most likely the CMS is getting data that does not match up with what it expects? Do you know any good documents on correlating a MIS with an OID?