Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

CMS keeps asking me to install JRE

SOLVED
Go to solution
Fredrik Uddin-Backman2
Frequent Advisor

CMS keeps asking me to install JRE

CMS keeps asking me to install JRE although I have it installed. I have tried clearing java cache and even uninstalled Java completely and manually removed all java dirs under my profile and then download and installed the JRE my CMS offering me. Still no luck. All this started after i ran out of disk on my CMS.
7 REPLIES
David Claypool
Honored Contributor

Re: CMS keeps asking me to install JRE

When your browser starts loading up hpSIM initially, one of the things it calls is a Java applet called 'mxtest.' If the script in the browser gets an error code from that call, it assumes that Java didn't load and it is missing, triggering the download.

Do you have multiple versions of Java loaded? If so, go into the Control Panel applet of each of them and make sure that the browsers are un-checked. That will allow the correct version of Java to be called.
giles.hosking
Occasional Contributor

Re: CMS keeps asking me to install JRE

Hi

We are having the same issues, followed the reply, didn't work did you find a solution eventually?

We now have only one install of Java and it still refuses to work
Scott McClelland
Occasional Advisor

Re: CMS keeps asking me to install JRE

I am having similar problems. After the CMS ran out of disk space all of the clients, that could previously connect, are prompted to install JPI again. This is obviously a server problem, as nothing had changed on any of the workstations. Please let us know what to check on the server, none of the workstation fixes do anything to allow the browser to connect.

The first time I had this problem (lack of disk space), I reinstalled, and reimported CIM7 data. We can't continue to do this. I need to find out why the disk is filling up so fast, but it only lasts about a week before it fills up again.
Scott McClelland
Occasional Advisor

Re: CMS keeps asking me to install JRE

I ran mxtest on the CMS to verify that the JRE is installed, and got the following error.

\Program Files\HP\Systems Insight Manager\lib\java mxtest.jar
Exception in thread "main" java.lang.NoClassDefFoundError: mxtest/jar

I am still unable to connect from any client, that previously could connect. No changes were made to the JRE on any clients.

Is there anything else I can test to get the server to work?
So Def
Frequent Advisor
Solution

Re: CMS keeps asking me to install JRE

I had the same problem and solved it by reinstalling. I recently find out my globalsettings.props in the config dir got corrupted and was totally empty. You might want to check your global settings.
Bill Wilhelmi_3
Occasional Visitor

Re: CMS keeps asking me to install JRE

Assuming you are running your browser on a PC, I've found that I if I go to Control Panel -> Add and Remove Programs, remove the JRE, and then reinstall it, things worked fine after that. I don't know why. I downloaded the latest JRE from the SUN Java website.
Fredrik Uddin-Backman2
Frequent Advisor

Re: CMS keeps asking me to install JRE

globalsettings.props is the solution.... It was corrupted and after restoring the file from backup it worked.