HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't view SNMP Webagent link in the System Homepage Setting

 
SOLVED
Go to solution
Lai Siew Yuen
Frequent Advisor

Can't view SNMP Webagent link in the System Homepage Setting

Hi,
I've installed HP System Management Homepage (SMH) v2.1.8 in a Windows 2003 server. When I tried to configure its Management Agents, I'm not able to view the 'SNMP Webagent' link. I've also noticed that the 'Tasks' tab is not available.
The problem still persists after I reinstall the SMH.
Can anyone advice?
Many thanks in advance.
7 REPLIES
Rich Purvis
Honored Contributor

Re: Can't view SNMP Webagent link in the System Homepage Setting

I would suggest that you check your SNMP setup on that system to see if it is the same as the one that is working. It looks like the web agent is not getting any data out of SNMP - which is causing the links to not show up. This is also viewed as an "SMH timeout" - you might search for "SMH timeout" or "System Management Homepage timeout" to see other discussions on this.

-Rich
Why does my tivo keep recording Nickelodeon?
Lai Siew Yuen
Frequent Advisor

Re: Can't view SNMP Webagent link in the System Homepage Setting

Hi,
I've checked the SNMP service is started fine. And browse through some of the threads as your suggest. But I'm still not able to view the 'SNMP Wegagent' link even after I have re-install the SNMP service.
Many thank...
Rich Purvis
Honored Contributor

Re: Can't view SNMP Webagent link in the System Homepage Setting

Do you have the SNMP setup correctly? I would check to see if you have the same community string settings between the the system that works and the one that does not.

-Rich
Why does my tivo keep recording Nickelodeon?
Lai Siew Yuen
Frequent Advisor

Re: Can't view SNMP Webagent link in the System Homepage Setting

Hi,
The SNMP is installed as a Windows service, no configuration is required (as I'm aware).

In the working set, the SNMP service community strings ('Trap') is automatically set after I configured the 'SNMP & Agent configuration' via the SMH Webagent link.

For the set that is not working, even I manaully added the SNMP service ('Trap') community strings to match that as in the working set, I'm still not able to view the 'SNMP Webagent' link in SMH.

Kindly see the attached screenshots between the good & the bad server. Kindly advice if the is the correct configuration.

Many thanks.
Rancher
Honored Contributor
Solution

Re: Can't view SNMP Webagent link in the System Homepage Setting

Also make sure that in the SNMP settings, under the Security tab, that you are acdepting SNMP packets from the localhost and the SIMS server
Rich Purvis
Honored Contributor

Re: Can't view SNMP Webagent link in the System Homepage Setting

This is the guide for the agents - I would suggest you review the requirements for SNMP and getting the agents running:

http://h20000.www2.hp.com/bc/docs/support/SupportManual/c00293377/c00293377.pdf

For instance:

"If a read-only or read/write community string has not been defined, then the
Web Agent is unable to get any SNMP data and the HTML pages do not contain any data. Unless a read/write community string is defined, you do not have write access, even if you log on to the Web Agent as
administrator or operator."


The description you have given so far sounds like the agents not able to successfully communicate with SNMP.

-Rich
Why does my tivo keep recording Nickelodeon?
Lai Siew Yuen
Frequent Advisor

Re: Can't view SNMP Webagent link in the System Homepage Setting

Hi all,
Thank you for your replies. I have re-installed the OS and the problem has gone away. Appreciate all of your kind responses.