Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

DL785 -system model unknown?

Carlsberg
Frequent Advisor

DL785 -system model unknown?

HHi ,
I'm having a few issues with getting DL780G5 servers to be recognized correctly.

OS win2003x64 SP2
PSP 8.10A
SIM 5.2 SP2 with hotfix.

The local SMH on DL785 displays everything corrently.
Send SNMP trap is greyed out in the control panel applet ( HP Management agents)
I can send the snmp test trap via SMH but it never arrives to SIM.

SIM sees the server and I get link up / cold start snmp messages when I restart the agents or the server. Data collection report is OK , system type is unknown.

When I run identify to these servers it says that Foundation agents are not installed. They are installed.

I installed DL580 G5 servers with the same PSP same os , everything. They are ok.

Any ideas?.

Also this PSP throws event ID 770 on all servers:
The Host Remote Alerter detected an error while attempting to retrieve data from key = CompaqHost\OsPerf\Component\Processor in the registry. The data contains the error code.

There's a separate old thread on this issue
11 REPLIES
Rob Buxton
Honored Contributor

Re: DL785 -system model unknown?

Sounds a bit unusual. SNMP should be enough to identify a server. So check that the HPSIM Server is an allowed host as well as localhost on the DL785 along with the correct community name.

Also with the new agents you can either use WBEM or SNMP and there's a setting in the agent. WBEM seems to give more problems so maybe change that
Carlsberg
Frequent Advisor

Re: DL785 -system model unknown?

Hi ,
Yes , definately unusual.

SNMP settings are correct.


The installation part is scripted , and DL580G5 that have the same OS and PSP are fine.

I'm suspecting something wierd to do with the fact that these DL785 have a massive amount of memory.
David Claypool
Honored Contributor

Re: DL785 -system model unknown?

Rather than stating that "SNMP is fine" please use HP SIM's 'Manage Communications' feature to help diagnose and correct the problem.
Carlsberg
Frequent Advisor

Re: DL785 -system model unknown?

Hi ,
Not sure what you mena by Manage communications feature.. The identify task states that system responds to SNMP.

This is what I see under product description in SIM:
Product Number AH233A
System Type Unknown
Hardware Description Hardware: AMD64 Family 16 Model 2 Stepping 3 AT/AT COMPATIBLE - Software: Windows Version 5.2 (Build 3790 Multiprocessor Free)
Management Protocols HTTP:, SMH:2.0, SNMP:1.0

Any idea why the "Send SNMP test" button is greyed out in the control panel applet?

Re: DL785 -system model unknown?

I'm having the same issue with all my DL785's. Both SIM 5.0SP4 and 5.3 are having the problem, both show the 785's as "Unknown".

Again scripted installation, same as our other systems but 785's don't seem to work.

Latest 8.15 MIB installed on both SIM servers. SNMP has been checked and rechecked. This is occuring on all our 785's - currently 8 of them.

If anyone knows of a resolution please let me know!

Thanks,
Scott
Rob Buxton
Honored Contributor

Re: DL785 -system model unknown?

You could try adding a new system type to manage, under Options->Manage System Types, go to New and use the retrieve from system.

This will use snmp to interrogate the server and pull back an snmp response.
If you don't get one then it'll point back to snmp on the host.
If you do get a response then that would indicate that there's something missing in HPSIM that mataches this as a server type.

It's not related to the MIBs that are installed, they're for decoding any snmp traps that are sent.

Re: DL785 -system model unknown?

Thanks for the suggestion! Definitely not a problem with SNMP on the hosts that I can figure out, I can SNMPWalk them with the same community strings. I also verified with "Manage System Types" as you suggested.

If SIM doesn't use SNMP to identify Proliant Server types then how does it do it? And how would someone update that functionality when a new server model gets released? I was always under the impression it was via MIB (my 3 year old installation of SIM 5.0SP4 recognizes 380G5's and 580G5's without issue, even though they weren't in existence when that version of SIM was released). Of course SNMPWalk doesn't show a "system type\model #" identifier for the server so part of me believes you :)

Scott

Carlsberg
Frequent Advisor

Re: DL785 -system model unknown?

Hi Scott ,

You'll need to create a new system type as suggested , at least that's what I ended up doing to get SIM to recognise these models correctly.

Re: DL785 -system model unknown?

I've opened a case with HP #3604976597 to see what they can come up with. I'm running reports right now for the tech. Seems odd that SIM wouldn't be able to recognize them on it's own, the server model has been out for almost a year and the architecture shouldn't be a issue, I wouldn't think.

My other concern is that test traps currently get ignored which has me worried. Would traps be accepted if I create a system type for the 785's?

Thanks,
Scott

Re: DL785 -system model unknown?

I got a response from tech support on the case. "Known issue on the 785's to be addressed in a future BIOS updated".

I'm skeptical but the tech was insistent. The part I don't understand is how it could have anything to do with BIOS (which goes back to question earlier about how does SIM identify a server if not through SNMP or the management agents)?

The 785's are weird, in that the SMH works fine and reports them as 785 G5's. HP SIM 5.3 actually discovers the servers and identifies them partially via the rib, but as Disabled devices. Discovering the servers directly by name or IP results in System Model unknown.

Scott
Rob Buxton
Honored Contributor

Re: DL785 -system model unknown?

Only guessing, but SIM does pull quite a bit of stuff from the BIOS, e.g. if you add the Asset Tag in there it will be pulled out.
Perhaps there's some data in the DL785 BIOS that conflicts with what HPSIM is expecting.
So it will then fail the matching process.