Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Data collection empty after 6.x upgrade from 5.3

Ben Hanson_1
Advisor

Data collection empty after 6.x upgrade from 5.3

After I upgraded from 5.3 to 6.0, and continuing after upgrading 6.0 to 6.1, then 6.1b, I've lost all data collection. I use HP SIM to monitor a bunch of Dell servers.

WBEM/WMI is not functioning and I think this is the cause. WMIMapper is installed on the HP SIM server, and nothing is blocking the required ports.

Any suggestions?
9 REPLIES
Jan Soska
Honored Contributor

Re: Data collection empty after 6.x upgrade from 5.3

Hello, It think 6.1 caused removing all your all data - very unpleasant bug. When have you noticed it?

Jan
Ben Hanson_1
Advisor

Re: Data collection empty after 6.x upgrade from 5.3

We lost data collection after going to 6.0. We lost a year's worth of historical data, plus I am no longer seeing any accumulation of new data.
Rob Buxton
Honored Contributor

Re: Data collection empty after 6.x upgrade from 5.3

If you have backups of the database you can recover the historical information.
If you restore the database to a different location you can access all of the historical information using standard reporting tools.
Ben Hanson_1
Advisor

Re: Data collection empty after 6.x upgrade from 5.3

I do have backups, any idea what tables store the historical data? Any idea why collection would have simply ceased working? Can anyone confirm or deny that WBEM is the primary source for data collection on Windows boxes?
Rob Buxton
Honored Contributor

Re: Data collection empty after 6.x upgrade from 5.3

The tables I've used in the past are:
Devices and DC_HistoricalOutput.

I usually use Excel and Import Data until I find a SQL Query that seems to pull in what I want.

As regards which data source to use. It's up to you. There does seem to be a trend towards wbem, but snmp still seems to provide more info. For a windows only environment I might stick with snmp. But here, with vmware ESXi, wbem is necessary and I'd prefer to only support one protocol.

I don't think the wmimapper is used in this case. It may be that the account being used for wbem does not have the required access on the server.
Ben Hanson_1
Advisor

Re: Data collection empty after 6.x upgrade from 5.3

Thanks for the DB info.

As for WBEM, the account being used is a domain admin, secondary account used is an enterprise admin. All resources are in a single domain. Passwords have been double/triple checked. Certificate on HP SIM server is imported into domain root CA. I've also check the WMI permissions on a few target servers to ensure that they are still set to defaults(Local admin has full access, domain admins are in local admin)
Ben Hanson_1
Advisor

Re: Data collection empty after 6.x upgrade from 5.3

DC_HistoricalOutput does not exist on my 6.1b install. Can anyone else check for this table?
Rob Buxton
Honored Contributor

Re: Data collection empty after 6.x upgrade from 5.3

Ben,
Sorry - not done that recently, but those tables existed on our old 5.x databases. If you recover the database as a separate instance that table may be there.

On the new database have you set up a Historical Data logging task?
Ben Hanson_1
Advisor

Re: Data collection empty after 6.x upgrade from 5.3

I have a daily server data collection task that is set to "Append new data set (for historical trend analysis)"

Is this what you mean?