Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

ESX 3.01 & SIM 5.1 help!

ESX 3.01 & SIM 5.1 help!

Hi,

I need help in resolving this issue that i seem to get always with ESX & SIM.

I installed ESX 3.01 on a Blade server. I then installed the HP Insight Agents (7.70) onto the Blades manually and configured it pointing to the CMS server and also enabling the Firewall ports.

Next, i went into SIM and went to install VMM Agents, but when i select to install, only the Windows install is there, but no Linux VMM agent is available......does anyone know why???

I then installed the VMM manually on the ESX server and the service started, but even after that, no information fed through the SIM server. I went to register the hoss as a VM Host, but that did not even work.

Please can somebody tell me what or where i am going wrong???

I need to do this on customer site and would appreciate all the help i can get.

I posted a message here before and everyone told me to install the latest PSP for ESX, trust me i did and im getting the same issues.

Please can somebody actually give me step guiide in what to do and what order!!

Please!!

Many thanks.
4 REPLIES
Rob Buxton
Honored Contributor

Re: ESX 3.01 & SIM 5.1 help!

Just to clarify a couple of things.
When you go into HPSIM to Deploy->Deploy Drivers, Firware & Agents->Install VMM Agent you're only seeing a Windows option listed? That may indicate a problem with the VMM install itself.

What happened when you tried to Register the VMHost Server - could you provide the error message.

You also need to license the VMHost Server before you'll get the final tie in.

I had to reinstall VMM here as the first install didn't work, I was missing the VM column as well as a number of VMM items.
KPark
Advisor

Re: ESX 3.01 & SIM 5.1 help!

I feel your pain! First, verify that ports 1124,1125 and 1126 are available for VMM. For some reason, I have seen installing the psp manually cause a problem. It looks like you did everything correct, but try this.
First, uninstall the psp and remove the vmm agent. When you manually added the vmm agent, did you get a permission error on the executable? You do not need ssh for this to work. Reboot the ESX server and then install the agents by copying over the file and then extracting it, like you would normally do. Make sure you have the right agents as well, there are 2 separate downloads, one for 2.5.x and the other for 3.0.1. During the agent configuration, pay attention to the snmp setup. By default the installer can set public and private as the default strings. Make sure you set the community strings correctly. Following all of that, you can copy the agent over from the vmm folder on the Sim server. Install the agent and reboot. Typically you shouldn't need to reboot, but it is a good practice. After the host is up, try a discovery in Sim. It should discover ok.
The proper way to add an ESX host is, deploy the agent, register the host then add the license.
Hope this works for you!

Re: ESX 3.01 & SIM 5.1 help!

Many thanks for your reply guys!

Right, firstly, i installed the VMM manually and did not get any permission errors, and i copied this over from the SIM Server.

Secondly, i paid attention to the SNMP settings and made sure they were correct.

When i tried to register the VM Host, it allowed me to select the server, then when you click on to register it, just hangs on the page for absolute ages......so basically it i doing nothing. It seems it cannot communicate with VMM.

I have rebooted the ESX Server, but still no luck.

Do you know how i would uninstall the VMM agents?

I need to perform this on 15 servers on customer site, but i cant even get 1 to work yet, and have been trying for many days!
Ed_178
Advisor

Re: ESX 3.01 & SIM 5.1 help!

What is the build number of the ESX servers you are having the problems on?