Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

ESX snmp config - HP SIM

SOLVED
Go to solution
java_cat33
Occasional Advisor

ESX snmp config - HP SIM

I have incorrectly configured snmp on a ESX host. I should only have one community string of public which is read only however I also have a rw of public too - below is some of the contents of the snmp config file. Can anyone help please??

rwcommunity public 127.0.0.1
rocommunity public localhost
rwcommunity public ip address of HP SIM server
rocommunity public
trapcommunity public
trapsink IP address of HP SIM server

5 REPLIES
Rob Buxton
Honored Contributor
Solution

Re: ESX snmp config - HP SIM

If you know how to use a Unix editor then just add either the IP Address or name after the "rocommunity public" line.
Not sure if it's needed but you can then restart the snmp daemon with
/etc/init.d/snmpd restart

You might want to look at editing the hpmgmt.conf file for use in the silent install of the HP agents. Makes things a lot easier and you get a consistent snmp setting for all of your hosts.
java_cat33
Occasional Advisor

Re: ESX snmp config - HP SIM

Thanks Rob - how about the fact that there is a rocommunity and rwcommunity of public. How should that be rectified?

I'll go make that suggested change now and see how it goes.

Thanks again.
java_cat33
Occasional Advisor

Re: ESX snmp config - HP SIM

I made that change you suggested and pulled the power out of one the PSU's and no traps were sent to HP SIM (I've checked the event logs in HP SIM)
java_cat33
Occasional Advisor

Re: ESX snmp config - HP SIM

I re-installed the HP Insight Agents on the ESX and made the config change as you advised and it now works. Thanks again for your assistance
Janezic Milan
Occasional Advisor

Re: ESX snmp config - HP SIM

sorry guys, i had some other problems to solve. Now i'm back on this one. First thanks for your help. I've found a big mistake made by me.
The Tool snmptrap wasn't installed on the server!
So I've installed it and tried again. Nothing happend. So I made again a hpasm reconfigure, this took me a step farther.
Now when i make a test trap, the trap gets out and gets picked up in the OSEM. I see that also in the /var/log/messages logfile:
May 19 16:34:33 db-prod snmpd[22225]: Received TERM or STOP signal... shutting down...
May 19 16:34:33 db-prod snmpd[27857]: mibII/mta_sendmail.c:open_sendmailst: could not guess version of statistics file "/var/log/mail/statistics"
May 19 16:34:33 db-prod snmpd[27857]: cmaX: listening for subagents on port 25375
May 19 16:34:33 db-prod snmpd[27857]: cmaX: sent ColdStarts on ports 25376 to 25393
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 1 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 2 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 3 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 5 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 6 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 8 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 9 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 10 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 11 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 14 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 15 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 16 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 21 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: NET-SNMP version 5.3.1
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 22 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 23 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 1 will be sent on port 25376 to hp Advanced Server Management_Peer
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 2 will be sent on port 25376 to hp Advanced Server Management_Peer
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 3 will be sent on port 25376 to hp Advanced Server Management_Peer
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 5 will be sent on port 25376 to hp Advanced Server Management_Peer
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 6 will be sent on port 25376 to hp Advanced Server Management_Peer
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 8 will be sent on port 25376 to hp Advanced Server Management_Peer
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 9 will be sent on port 25376 to hp Advanced Server Management_Peer
.....
...

but OSEM gets a problem and stops the delivery (Remote delivery down). When i look under Notifications the status of the GenericTrap is "stalled". So how can i solve this? with a windows server everthing works fine!

Also strange is when i repair the agent with HPSIM (Configure or Repair Agent...under Configure), the System Manamgent Homepage loses all the data and even doesn't recognize the System Model (just NULL). Then when i try a testrap nothing happens. So i have to make a hpasm reconfigure to correct it.