Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

EVA4K in HP SIM v5 SP5

S-tog a s
Frequent Advisor

EVA4K in HP SIM v5 SP5

Hi Forum,

I'd like to see our EVA4K in HP SIM v5 SP5.
The Appliance is running a std. Win2K3 latest eva command view. The appliance Win2K3 appliance boks er added to the 2003 domain.

Is it correct that I need the following to get things to work:

-WEBEM UID and PWD

- "Pegasus CIM Object Manager Service" running on the appliance box

- a XML file need to be placed on the appliance box...but where?

- port 5989 working...how do I verify this?

anything else!?!

best reg,
-Claus Bohm-
8 REPLIES
Rob Buxton
Honored Contributor

Re: EVA4K in HP SIM v5 SP5

What version of CV EVA?
CV EVA 5 comes with SMI-S, you need that installed. Aspat of that install you provide a password for the WBEM Administrator account.

You'll need those details added to the WBEM settings for the server running CV EVA.

Once done do a Discovery of the server running CV EVA. That "should" pick up the EVA.

There's a couple of test scripts you can run from the hpsim server;
From the HPSIM directory;
Wbemdisco cv-eva-server 5989 root/pg_interop administrator password
Should test the wbem access tothe device.

The command
wbemauthcheck cv-eva-server 5989 root/pg_interop administrator password v 5
will just test connectivity.

The XML file you need to check is;
C:\Program Files\HP\Systems Insight Manager\config\identification\wbemportlist.xml,
The line name="root/pg_interop" needs to be the first entry.
I think it's only in older versions of HPSIM that this is an issue.
S-tog a s
Frequent Advisor

Re: EVA4K in HP SIM v5 SP5

Hi Rob,

I've tried both commands and the connectivity check seems to work fine. But the discovery command fail...any suggestions!?!

NB. I've chanced the "UID" "PWD"

C:\Program Files\HP\Systems Insight Manager>wbemauthcheck dsbsanaps1 5989 root/p
g_interop "UID" "PWD" v 5

C:\Program Files\HP\Systems Insight Manager>j2re\bin\java.exe -Dorg.snia.wbem.ci
mom.properties=./WbemTools.properties -classpath .;./lib/dc.jar;./lib/mx.jar;./l
ib/cimclient.jar;./lib/xerces.jar;./lib/wbemutil.jar -mx400m -ms400m WbemAutho
rizationCheck dsbsanaps1 5989 root/pg_interop "UID" "PWD" v
5

TESTING CREDENTINALS VIA MxWBEMConnect::checkAuthorization() ....


Testing with
host: dsbsanaps1
port: 5989
protocol: https
namespce: root/pg_interop
verbosity: 5
user: "UID"
password: *******

Checking authorization in device namespaces for dsbsanaps1 under ns=root/pg_i
nterop for user="UID"
Trying to connect to CIMOM at: dsbsanaps1 under ns=root/pg_interop for user="UID"
SUCCESS


Found the following device namespaces:
root/PG_Internal
root/cimv2
root/eva



Checking Authorization in namespace: CIMNameSpace=root/PG_Internal [host dsbsana
ps1]
CIMException retrieving instance of CIM_ComputerSystem.

Checking Authorization in namespace: CIMNameSpace=root/cimv2 [host dsbsanaps1]
SUCCESS

Checking Authorization in namespace: CIMNameSpace=root/eva [host dsbsanaps1]
CIMException retrieving instance of CIM_ComputerSystem.
Authorization Check Succeeded for: dsbsanaps1 under ns=root/pg_interop for user
="UID"

AUTHORIZATION CHECK PASSED


C:\Program Files\HP\Systems Insight Manager>pause
Press any key to continue . . .

C:\Program Files\HP\Systems Insight Manager>popd

C:\Program Files\HP\Systems Insight Manager>endlocal

C:\Program Files\HP\Systems Insight Manager>wbemdisco dsbsanaps1 5989 root/pg_in
terop "UID" "PWD"
HOST = dsbsanaps1
PORT = 5989
NAMESP = root/pg_interop
USER = "UID"
PASSWD = *****
Connect to dsbsanaps1 in namespace root/pg_interop with SSL=true

Enumerating instances of CIM_RegisteredProfile...

Profile.RegisteredName=Array
Profile.RegisteredVersion=1.1.0
ProviderVersion=5.0
Profile.HPVersion=EVA5.0-Dev28
SubProfile.RegisteredName=SNIA:Software
SubProfile.RegisteredName=SNIA:Pool Manipulation Capabilities and Settings
SubProfile.RegisteredName=SNIA:Job control
SubProfile.RegisteredName=SNIA:Physical Package Package
SubProfile.RegisteredName=SNIA:Backend Ports
SubProfile.RegisteredName=SNIA:Masking and Mapping
SubProfile.RegisteredName=SNIA:Disk Drive Lite
SubProfile.RegisteredName=SNIA:FC Target Port
SubProfile.RegisteredName=SNIA:Fibre Channel Initiator Port
SubProfile.RegisteredName=SNIA:LUN Creation
SubProfile.RegisteredName=SNIA:Copy Services
SubProfile.RegisteredName=SNIA:Access Point
SubProfile.RegisteredName=SNIA:Location
SubProfile.RegisteredName=SNIA:Multiple Computer System
SubProfile.RegisteredName=SNIA:Block Server Performance
*** Error following [RegisteredProfile] --ElementConformsToProfile-> [ComputerSy
stem] - CIM_ERR_FAILED: A general error occurred that is not covered by a more s
pecific error code: "CIM_ERR_FAILED: A general error occurred that is not covere
d by a more specific error code: "ProviderLoadFailure (evaprovider.jar:evaprovid
er.jar:com/hp/EVAProvider/HPEVA_StorageSystem):Cannot load library"" (CIM_ERR_FA
ILED) ***
CIM_ERR_FAILED(CIM_ERR_FAILED: A general error occurred that is not covered by a
more specific error code: "CIM_ERR_FAILED: A general error occurred that is not
covered by a more specific error code: "ProviderLoadFailure (evaprovider.jar:ev
aprovider.jar:com/hp/EVAProvider/HPEVA_StorageSystem):Cannot load library"")
at org.snia.wbemcmd.xml.XMLOperationGeneric.processReturnStream(XMLOpera
tionGeneric.java:362)
at org.snia.wbemcmd.xml.XMLOperationGeneric.intrinsicMethod(XMLOperation
Generic.java:191)
at org.snia.wbemcmd.xml.XMLAssociatorNames.getNames(XMLAssociatorNames.j
ava:211)
at org.snia.wbemcmd.cimom.CIMOMHandleXML.associatorNames(CIMOMHandleXML.
java:671)
at org.snia.wbem.client.CIMClient.associatorNames(CIMClient.java:1320)
at com.hp.wbemutil.CIMUtil.associatorNames(CIMUtil.java:1113)
at WbemDisco.findDevices(WbemDisco.java:166)
at WbemDisco.main(WbemDisco.java:555)
Profile.RegisteredName=Server
Profile.RegisteredVersion=1.1.0
ProviderVersion=
Profile.HPVersion=
Press any key to continue . . .
Rob Buxton
Honored Contributor

Re: EVA4K in HP SIM v5 SP5

That's the same error I'm wrestling with at the moment.
I've uninstalled / reinstalled CV EVA on this server a few times and thought it might be something in the registry or elsewhere that's got corrupted. As we're getting a new management server, I was going to wait until then and try a fresh install

It might be worth raising a call with HP.

What is the version of firmware on the EVA4K?
Rob Buxton
Honored Contributor

Re: EVA4K in HP SIM v5 SP5

Claus,
Could you let me know if you're seeing the following as I've opend a call with HP and if your symptoms are the same we may be able to narrow things down a bit.

Could you check the Event Log on the CV EVA Server? You might find the CIM Object Manager (CIMOM) service is stopping repeatedly, it's set to automatically restart.

Also check the log;
C:\Program Files\Hewlett-Packard\pegasus_home\logs\PegasusStandard.log and see if there's something like;
09/06/06-08:10:16 WARNING cimserver: User passed is administrator
09/06/06-08:10:16 INFO cimserver: JMPIProviderManager::InitJVM - With Option -Xms64m
09/06/06-08:10:16 INFO cimserver: JMPIProviderManager::InitJVM - With Option -Xmx1024m
09/06/06-08:10:16 INFO cimserver: JMPIProviderManager::InitJVM - With Option -Xincgc
09/06/06-08:10:16 INFO cimserver: JMPIProviderManager::InitJVM - With Option -DPegasus.Home=C:\Program Files\Hewlett-Packard\pegasus_home
09/06/06-08:10:16 INFO cimserver: JMPIProviderManager::InitJVM - With Option -Djava.class.path=C:\Program Files\Hewlett-Packard\pegasus_home\lib\wql.jar;C:\Program Files\Hewlett-Packard\pegasus_home\lib\evaprovider.jar;C:\Program Files\Hewlett-Packard\pegasus_home\lib\JMPIImpl.jar;C:\Program Files\Hewlett-Packard\pegasus_home\lib\cim.common.jar;
09/06/06-08:10:26 INFO cimserver: Listening on HTTP port 5988.
09/06/06-08:10:29 INFO cimserver: Listening on HTTPS port 5989.
09/06/06-08:10:29 INFO cimserver: Started CIM Server version 2.5.
09/06/06-08:10:29 WARNING cimserver: User passed is WCC\EVAPR01$
09/06/06-08:10:29 WARNING cimserver: User passed is WCC\EVAPR01$
09/06/06-08:10:42 INFO cimserver: SLP Registration Initiated
S-tog a s
Frequent Advisor

Re: EVA4K in HP SIM v5 SP5

Hi Rob,

I've reinstalled the appliance box cos I wanted to make it a part of the domain anyways...this is the readout now:

C:\Program Files\HP\Systems Insight Manager>wbemauthcheck s-tog-s55 5989 root/pg
_interop UID PWD v 5

C:\Program Files\HP\Systems Insight Manager>j2re\bin\java.exe -Dorg.snia.wbem.ci
mom.properties=./WbemTools.properties -classpath .;./lib/dc.jar;./lib/mx.jar;./l
ib/cimclient.jar;./lib/xerces.jar;./lib/wbemutil.jar -mx400m -ms400m WbemAutho
rizationCheck s-tog-s55 5989 root/pg_interop UID PWD v 5


TESTING CREDENTINALS VIA MxWBEMConnect::checkAuthorization() ....


Testing with
host: s-tog-s55
port: 5989
protocol: https
namespce: root/pg_interop
verbosity: 5
user: UID
password: *******

Checking authorization in device namespaces for s-tog-s55 under ns=root/pg_in
terop for user=UID
Trying to connect to CIMOM at: s-tog-s55 under ns=root/pg_interop for user=UID
SUCCESS


Found the following device namespaces:
root/PG_Internal
root/cimv2
root/eva



Checking Authorization in namespace: CIMNameSpace=root/PG_Internal [host s-tog-s
55]
CIMException retrieving instance of CIM_ComputerSystem.

Checking Authorization in namespace: CIMNameSpace=root/cimv2 [host s-tog-s55]
SUCCESS

Checking Authorization in namespace: CIMNameSpace=root/eva [host s-tog-s55]
CIMException retrieving instance of CIM_ComputerSystem.
Authorization Check Succeeded for: s-tog-s55 under ns=root/pg_interop for user=
UID

AUTHORIZATION CHECK PASSED


C:\Program Files\HP\Systems Insight Manager>pause
Press any key to continue . . .

C:\Program Files\HP\Systems Insight Manager>popd

C:\Program Files\HP\Systems Insight Manager>endlocal

C:\Program Files\HP\Systems Insight Manager>wbemdisco s-tog-s55 5989 root/pg_int
erop UID PWD
HOST = s-tog-s55
PORT = 5989
NAMESP = root/pg_interop
USER = UID
PASSWD = *****
Connect to s-tog-s55 in namespace root/pg_interop with SSL=true

Enumerating instances of CIM_RegisteredProfile...

Profile.RegisteredName=Array
Profile.RegisteredVersion=1.1.0
ProviderVersion=5.0
Profile.HPVersion=EVA5.0-Dev28
SubProfile.RegisteredName=SNIA:Software
SubProfile.RegisteredName=SNIA:Pool Manipulation Capabilities and Settings
SubProfile.RegisteredName=SNIA:Job control
SubProfile.RegisteredName=SNIA:Physical Package Package
SubProfile.RegisteredName=SNIA:Backend Ports
SubProfile.RegisteredName=SNIA:Masking and Mapping
SubProfile.RegisteredName=SNIA:Disk Drive Lite
SubProfile.RegisteredName=SNIA:FC Target Port
SubProfile.RegisteredName=SNIA:Fibre Channel Initiator Port
SubProfile.RegisteredName=SNIA:LUN Creation
SubProfile.RegisteredName=SNIA:Copy Services
SubProfile.RegisteredName=SNIA:Access Point
SubProfile.RegisteredName=SNIA:Location
SubProfile.RegisteredName=SNIA:Multiple Computer System
SubProfile.RegisteredName=SNIA:Block Server Performance
HPEVA_StorageSystem.CreationClassName="HPEVA_StorageSystem",Name="50001FE15003
FDD0"
NameSpace = root/EVA
Vendor=HP
Name=EVA
IdentifyingNumber=50001FE15003FDD0
Profile.RegisteredName=Server
Profile.RegisteredVersion=1.1.0
ProviderVersion=
Profile.HPVersion=
Press any key to continue . . .

After a datacollectin, Identify and SW polling I'm now able to see my SAN ;-)
Rob Buxton
Honored Contributor

Re: EVA4K in HP SIM v5 SP5

Claus,
How much of a reinstall was that?
A complete rebuild of the OS or just a reinstall of the CV EVA stuff?

I've ordered a new server for CV EVA and a couple of other management apps. I'm hoping a new build will resolve the issue.

It would be nice to know the cause though as there's the possibility it could return.
S-tog a s
Frequent Advisor

Re: EVA4K in HP SIM v5 SP5

Hi Rob,

complete reinstall OS included.

Best reg,
-Claus-
S-tog a s
Frequent Advisor

Re: EVA4K in HP SIM v5 SP5

...