Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Error registering VMM agent

Kevin Everts_1
Regular Advisor

Error registering VMM agent

I'm trying to register a new ESX 3.0.1 host. I've run mxagentconfig and also install the VMM sogtware on the ESX server. When I run the "Register VM host" it fails with the following error message:

SSH public key authentication failed.
Target system might not be configured.
Please run mxagentconfig -a from command line window or Configure->Configure or Repair Tool from graphical user interface to configure the target system.

Any idea why this is failing? The ports on the firewall are open on the ESX server.
6 REPLIES
Kevin Everts_1
Regular Advisor

Re: Error registering VMM agent

*bump* Anyone?
Rob Buxton
Honored Contributor

Re: Error registering VMM agent

You might need to run the mxagentconfig command for the HPSIM server itself.

What version of HPSIM?
Kevin Everts_1
Regular Advisor

Re: Error registering VMM agent

5.1 and I did run mxagentconfig -a against my SIM server.
Rob Buxton
Honored Contributor

Re: Error registering VMM agent

Not sure,
I've tried to stay away from SSH here. Caused too many issues.
I removed HPSIM 5.0 and installed 5.1 on the same server.
I didn't use the mxagentconfig at any time and there are some servers that it cannot have been used against.
I use wbem to access the VM Host servers.
All registered okay and I'm pretty sure SSH wasn't involved.
You could try going into the Server Protocol Settings and if SSH is enabled then Disable it and retry.
Do you have the HP Agents installed as well as the VMM Agent?
Kevin Everts_1
Regular Advisor

Re: Error registering VMM agent

Yes the HP agents and VMM agent is installed. The firewall ports are also opened up. How do you do it without SSH?
Gwyndaff Evans
Occasional Contributor

Re: Error registering VMM agent

If you are using 'root' you need to enable it to log in via ssh as it is disabled by default.

To do this, edit the "/etc/ssh/sshd_config" file, find the variable called "PermitRootLogin" and change its value to yes.