Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Error trying to VPM Scan

SCC-Colin
Advisor

Error trying to VPM Scan

I am trying to run a VPM scan and get the following error, has anyone got any ideas what might be causing it? It happens on all servers. Many thanks for any help given.
Exception in thread "main" java.lang.NoClassDefFoundError: com/hp/mx/soap/v5_0_2/client/MxpiMainFactory
at com.hp.mx.portal.VPM.MxTmSIMSOAPWrapper.initialize(Unknown Source)
at com.hp.mx.portal.VPM.MxTmAlert.send(Unknown Source)
at com.hp.mx.portal.VPM.MxTmAlert$ScanSubmitted.send(Unknown Source)
at com.hp.mx.portal.VPM.MxTmCommandTool$ScanAction.execute(Unknown Source)
at com.hp.mx.portal.VPM.MxTmCommandTool.processRequest(Unknown Source)
at com.hp.mx.portal.VPM.MxTmCommandTool.main(Unknown Source)

4 REPLIES
Lucas Medina
Frequent Advisor

Re: Error trying to VPM Scan

Hello,

In order to try to help you, we need to know what are the HPSIM and VPM versions you have installed.
When you say "it happens on all servers" you are saying these servers are the hosts or targets. I mean, the error is happening when you are trying to scan over different targets or VPM is installed over different hosts and the same error happen?

Thanks,
Lucas
SCC-Colin
Advisor

Re: Error trying to VPM Scan

Hi Lucas,
We are running SIM 5 with SP5 for windows, with VPM 2.03. VPM is installed on the same server as SIM.
When we scan for vulnerabilities on either the SIM server or any target system we get the error message mentioned come up in the Task Results stderr.
Regards,
Colin.
Bernardo Tagariello
Frequent Advisor

Re: Error trying to VPM Scan

Could you tell me if you have files in this directory?

C:\Program Files\HP\Systems Insight Manager\hpwebadmin\webapps\ROOT\mxportal\VPM

How many installs did it take to install this?

Is this from an upgrade?

tag
SCC-Colin
Advisor

Re: Error trying to VPM Scan

Hi,

Yes, there are files and folders in this folder.
This was the first install, after uninstalling version 2.0.0 as we were having other problems with that version.

Which were when any of the servers running the agent were rebooted, it would take hours for the server to come up. In the end we had to boot in safe-mode disable the radia management agent and then the server would come up normally.