Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Getting Insight power management reports working.

SOLVED
Go to solution
mscarrick
Occasional Advisor

Getting Insight power management reports working.

I’m struggling to get insight power management working on my management server and I think I’m just misunderstanding something. Client servers are a mix of DL380 G5’s, G6’s and G7’s.  I’m trying to generate a report to show power usage over time (e.g Reports – Power management – display power/thermal data…) and the message I get is:

“Verify that all unmonitored power consumers have maximum power settings or refer to the troubleshooting section of the Insight Control power management user guide for additional guidance.”.

 

When I edit systems properties (under system and event collections – All power delivery devices – tick server – edit) by adding a ‘maximum possible power consumption (Watts)’, I get a different message when running the report:

“Verify that the system is powered by a power delivery device that provides power consumption history. The system's history is currently represented by its maximum power value”

 

One final thing I’m doubtful of is that when I run discovery on the ILO I get a critical error stating “the management server cannot communicate with the SNMP service on the system”

And a major error stating:  “The system cannot be identified properly for HP SIM to manage; unable to get one or more of the following model, …    check if WMIMapper is configured correctly on the CMS and  verify the sign-in credential.”

It has always done this in the past and I expected this to be normal as surely ILO doesn’t have SNMP onboard, and I have checked all credentials.

 

Other things I have done include:

 

I’ve applied an HP insight control license to the server (in Deploy – License Manager - …).

I have applied some settings in options – power management.

I’ve set permissions (Options – security – credentials – system credentials) to use SNMP with the

public path that I set on all servers.

I can ping various ILO’s from the management server.

I’ve logged onto the servers ILO and set the HP SIM SSO security to be ‘Trust All’, and the HPSIM trusted servers to the management server.

 

Any suggestions??

 

Thank you in advance.

5 REPLIES
BPE
Esteemed Contributor

Re: Getting Insight power management reports working.

Most of the messages are explainable.

Newer HW will support power consumption read out if you have the right ILO License installed.

Once it was called ilo Advanced license. For older systems you can define the max power value instead.

To check if your managed system has the correct license or is able to collect power and temperature information go to the system page inside SIM and you should see a Power/Thermal tab. Minimum requirement is that you have the Insight Control Power Management part installed. If you selected the tab you should get a list with open points to solve or a graph with the current power consumption

mscarrick
Occasional Advisor

Re: Getting Insight power management reports working.

Thank you for the reply.

 

Focussing on 1 server in particular - a DL380 G7 with ILO3, Windows server 2008 R2 with no firewall tunred on:

 

I have applied a demo HP Insight control license in SIM:  Deply - License manager

I have applied a paid for ILO license from the ILO console.

 

When doing as you say above (system page - power/thermal tab) unfortunaly I do not get a graph but instead I get a message with some pointers which I dont understand:  shown attached.

Any ideas are much appreciated.

BPE
Esteemed Contributor

Re: Getting Insight power management reports working.

If you login to the ILO will you see the power regulator tab. Sorry it was once a power regulator tab under ILO2

I never seen the power regulator under ilo3. But I remember that it takes a moment until you get the graph after you enabled the ILO advanced license. The Graph inside SIm is only displayed if the system has already som history data. I do not remember how many hour it will take until you get the display but I know that the ILO should show you some values or a message about the availability of the functionality.

mscarrick
Occasional Advisor

Re: Getting Insight power management reports working.

Ok. In ILO there is a pretty graph showing power usage over the past 24 hours and another for the past 20 minutes.  That data is great.  I had just hoped to get this information into SIM so we could quickly pull up reports for a group of servers.

 

Each time I try to generate a report (or even view an individual  systems power management)in SIM I'm prompted by the message in the previous attachment. It has also been installed or more than 5 days now so should have had enough time to gather information.

 

My current thoughts are that it must be a communication issue between SIM and the ILO (Providing insight power management gets its information from ILO) and probably due to user credentials, ports or SNMP/SSL protocols - whatever else it requires to communicate...

mscarrick
Occasional Advisor
Solution

Re: Getting Insight power management reports working.

I OK - I feel I should admit responsability and apologise, particulalr to BPE...

 

The issue was down to our network using different VLANs for ILO and normal traffic.

Once and exception was made on the ILO VLAN for my management server I was able to re-discover all ILO systems and get some graphs in SIM.

 

Many thanks to all of those who looked and took the time to reply.