Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

HP SIM 7.4 & ILO2 error

 
MBSJ
Occasional Advisor

Re: HP SIM 7.4 & ILO2 error

You are correct that selecting the system, choosing the "Tools & Links" tab and then "System Credentials" i only have two; SSH and Sign-In and no SNMP credentials. However the SNMP credentials are configured in the discory rule with "Public" as the read community. Also, i dont seem to have SNMP credentials on any of the iLO3 servers either.

Andrew_Haak
Honored Contributor

Re: HP SIM 7.4 & ILO2 error

That is strange indeed, do you have any ILO with SNMP working? If you look at the credentials you can edit these and add credentials. Please try to add Public at the SNMP, this will trigger a discovery job. Look at the log of this job to see if the SNMP works. Wich protocols do see when selecting tho ILO?

 

Believe me i know this can be frustating. .....

Kind regards,

Andrew
MBSJ
Occasional Advisor

Re: HP SIM 7.4 & ILO2 error

I have checked the other ILOs and none of them have SNMP credentials enabled, even though the Public community string is entered in the discovery rule. I have checked and readded the Public community to both the system discovery and the global credentials and still it states that the system cant be identified.

I have attached the full discovery log for one ILO2.

The following lines however seem to indicate that SNMP is not enable on the ILO2.

        * Checking for SNMP protocol support on system...
Normal:   The system did not respond to SNMP. Verify security settings and
          community strings in Options->Security->Credentials->System
          Credentials
        * Checking for SNMPv3 protocol support on system...
Normal:   The system did not respond to SNMPv3. Verify security settings and
          v3 credentials in Options->Security->Credentials->System
          Credentials
        * Running HP ProLiant management agent identification...
Normal:   The system does not support SNMP.
        * Running SNMP base cluster identification using common cluster
          MIB...
Normal:   SNMP is not supported or globally disabled, skipping SNMP cluster
          identification.

Am i missing some configuration on the ILO? On the ILO3 servers only SNMPv3 fails.

Andrew_Haak
Honored Contributor

Re: HP SIM 7.4 & ILO2 error

I will run a identification of an ILO2 and paste the log tomorrow.

Kind regards,

Andrew
Andrew_Haak
Honored Contributor

Re: HP SIM 7.4 & ILO2 error

Hello again,

 

I've attached the ILO2 log for one of my discovery of an ILO.

 

If you open the log you can see the following :

 

Normal:   The system responded to an SNMP request; it supports SNMP Protocol 
          and has a valid read community string.

 

And soon after that it logs the following :

 

Normal:   This system is a management processor; attempting to get associated 
          server information.

 

So the SNMP discovery told the SIM discovery that this is an ILO. I've disabled the SSH because i don't have SSH credentials. When i look at the recorded credentials i see Public from the Global source. When i look at the discovered Management Protocols i see HTTPS:1.0 and SNMP: 1.0.

 

The SIm version is 7.4 and the november fix is installed. You could try to increase the SNMP timeout just to be sure.

 

The ILO is of version 2.25, if you type https://ipadres/xmldata?item=All do you get the XML reply ?

 

Kind regards,

Andrew
MBSJ
Occasional Advisor

Re: HP SIM 7.4 & ILO2 error

I have checked again and run a new discovery with SNMP timeout increased to 30 seconds and it still fails.

Ive tried running an SNMP walk on the ILO but it doesnt respond.

Is it possible that the community isnt public? Or that i need to activate something on the ilo?

When i check https://ipadres/xmldata?item=All  i do get an XML reply.

For good measure in can confirm that the ILO version is also 2.25 and i am running SIM 7.4 with the November patch.

Andrew_Haak
Honored Contributor

Re: HP SIM 7.4 & ILO2 error

I'm running out of options, is the firewall of the SIM  server active? If so try to disable it just to test that's not the problem. 

You could check if the traps directory under the SIM  installation has files in it, SIM uses this directory to buffer it's snmp traffic. This directorg thojld have files comming and going all the time. You could also set a Windows server to accept SNMP queries just to see if SNMP is eorking from scans of the SIM server. Just set if not already configered the SNMP  to Public and allow SNMP from the name or IP of your SIM server, set ghe datasource to SNMP and look if the System Management Homepage still shows system info.

 

This is all just for finding out what's wrong you can revert these setti gs when you find out the source of the problem.

 

Good luck.

Kind regards,

Andrew
MBSJ
Occasional Advisor

Re: HP SIM 7.4 & ILO2 error

I have already tried disabling the firewall on the SIM server. I didn't see much activity in the traps folder. I didnt have an HP server to test SNMP againt but i setup SNMP on a VMWare server and tried to descover it in SIM. The log states the following:

        * Checking for SNMP protocol support on system...
Normal:   The system responded to an SNMP request; it supports SNMP Protocol
          and has a valid read community string.

 

- so im assuming there are no general problems using SNMP.

 

I am considering factory resetting the iLO controllers on the two servers just to make sure nothing is configured incorrectly, even though I can't see what that would be.

Andrew_Haak
Honored Contributor

Re: HP SIM 7.4 & ILO2 error

Indeed if this discovery worked SNMP seems just fine.

one thing you could try is load the MIB update. You are already running the last mibs but perhaps that there's a problem eith the existing MIBs.

 

Kind regards,

Andrew