Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

HP SIM 7.4 doesn't detect agent software status

MC Murphy
Frequent Advisor

HP SIM 7.4 doesn't detect agent software status

New SIM 7.4 installation, I retired the 6.3 CMS.  On each managed server I updated SNMP targets, replaced the old server's Trusted Management server's certificate with the new.  I replaced and authenticated the VCA with username/passwor to th e new VCRM, on the new CMS.  The VCA authenticates, saves the settings of the new CMS, and updates its inventory, and I can run updates.  So the VCA is communicating.  But the CMS still shows a question mark on Software Status for all the managed servers.  When I run Configure/Repair on a managed server I get this:

 Configure Version Control Agent ..................................... [FAILED]
Either VCA agent is not installed in target node or Check the credentials you en
tered for the VCA to use to access the VCRM. For security reasons, the VCA canno
t connect to the VCRM using the default 'Administrator' user. For more informati
on, refer to the Version Control Agent documentation.

What does the CMS need to be able to run the VCA on the managed server?

31 REPLIES
Andrew_Haak
Honored Contributor

Re: HP SIM 7.4 doesn't detect agent software status

Hello,

 

You have to configure your baselines from SIM internal. This is one of the major changes in SIM 7.x. HP is moving away from the VCA and uses HP SUM for deployment. But for this moment we still use the VCA but you have to configure the baselines in SIM. Here is how. Log into SIM choose Deploy > Software/ Firmware Baselines > Manage Software/Firmware Baselines. If you get a red screen saying that you have to configure a default Version Control Repository select the right option on the same screen to select the VCRM server (most of the time the SIM server). You do need a trust with the VCRM server but that should not be a problem. Now that you have a VCRM selected you should see the Baselines toy uploaded to the VCRM. Now you can choose to add Systems to the baselines that you have.

 

You can use collections to set the servers to the baselines as long as you selected the servers in the baseline you selected. Click on save, wait one minute to see that the Assigned Systems field gets filled.

 

Kind regards,

Andrew
MC Murphy
Frequent Advisor

Re: HP SIM 7.4 doesn't detect agent software status

I got into Manager Software/FIrmware Baselines; selected the Proliant Support pack 8.70, which my 2003 servers are using now in VCA; then Add Systems; selected All Servers and view Contents.  I selected the 2003 servers, then Apply.  I don't see the View Assigned Systems button turn from grey to blue, like it is active.  But I do see the servers under "Assigned Systems" in the Known Baselines line for my selected support pack.  But still, when I go back to All Servers in the System and Event Collections frame I get question mark in the SW column for evey server, including those 2003 servers I included in the Baseline. I press one's question mark and it brings up the Track Software and Firmware Version frame, but it has no info in it. Is the VCRM still not geting some info it should from the managed servers?    

Andrew_Haak
Honored Contributor

Re: HP SIM 7.4 doesn't detect agent software status

If you look at the server and select the baseline tab does it say that there is a baseline assigned?

 

if you can can you paste a screenshot of the server baseline tab and of the baselines where you added the servers to a baseline?

Kind regards,

Andrew
MC Murphy
Frequent Advisor

Re: HP SIM 7.4 doesn't detect agent software status

It shows me now the servers with that baseline, and installed versions, but still quetion marks for status.  I haven't manaaged to do a paste, but I'll attach a pcture of the Manage Software/Firmware Baselines and the Isntalled Software and Firmware on one server.

Right now the SIM seems to be hung.  I can get the hand to show up over any tab and press, but nothing happens.

 

 

 

 

 

 

Andrew_Haak
Honored Contributor

Re: HP SIM 7.4 doesn't detect agent software status

If you select one server and click on report>new report, now click on general do you see software information for your server? It looks like you don't have firmware/software info for your server(s). Also do you have credentials for your discovered servers.if you look at the System Management Homepage of one of your servers does this page show server info like software and or type?

Kind regards,

Andrew
MC Murphy
Frequent Advisor

Re: HP SIM 7.4 doesn't detect agent software status

In System Insight manager on the CMS I can list all servers.  I see a variety of status symbols for HS, MP, ES, but under SW it's all question marks.  I can select one of the servers, its Software Status has the question mark.  But i can open its System management Homepage successfully (from the CMS console), including the Version Control Agent Showing all its details - repository, Installed / Support pack / Latest Version - just as if I was at the managed server console opening System Management Homepage.  So it looks like for the most part the communication is happening between managed server and CMS, just whatever it is to keep the CMS current on software status isn't happening.

I don't have the 2008 servers assigned to a baseline yet they are using SPP 2014.06 I think.  I'll get them assigned.   

Andrew_Haak
Honored Contributor

Re: HP SIM 7.4 doesn't detect agent software status

There is no link between the baseline configured in the VCA on the monitored servers and the Software status in SIM. The software status in SIM  has to be configured from within SIM itself. HP is stopping it's VCA support so the baseline is not configured in the Monitored server though it still works. SIM's deployment is going to be done using HP SUM in favour of VCA. This is a change since the 7.x version of SIM. 

Kind regards,

Andrew
MC Murphy
Frequent Advisor

Re: HP SIM 7.4 doesn't detect agent software status

I get into Deploy \ Software/Firmware Baselines \ manage Baselines and track Versions.  I assign servers to a baseline.  I View Assigned Systems, and see my assigned servers listed.  I found a World of Insight article "HPSIM7:Setting Baselines and Software Status" which says " Select your baseline and save it. Once you Save it you’ll be presented with a Software Status indicated by the tradition HPSIM icons. It is possible that you may have to run a Data Collection and/or Software Status Poll if you don’t get the status from the refresh. Data Collection collects the inventory and the status poll inventories, compares and calculates against the data collected and the designated baseline in the HPSIM database."  I ran both Data Collection and Software Status Poll on a server, both tasks said they ran successfully.  I still get the Question Mark "Unknown" under its Software Status. 

MC Murphy
Frequent Advisor

Re: HP SIM 7.4 doesn't detect agent software status

I have seen that in VCRM I have several "invalid support packs", including one I have assigned systems to.  Could this be causing the Softwre Status problem, so that I should clean it up first.  I've now removed system assignments to that support pack, reassigned to a good support pack, rerun Data Collection and Software Status Poll and still see question mark on the Track Software and Firmware Versions page.

Andrew_Haak
Honored Contributor

Re: HP SIM 7.4 doesn't detect agent software status

Where did you assign the baseline in SIM or the VCA on the servers. If the VCRM looked good, did it also update to SIM  under the baselines? Menu option Deploy> Software firmware baselines> Manage Software/firmware baselines.

Kind regards,

Andrew
MC Murphy
Frequent Advisor

Re: HP SIM 7.4 doesn't detect agent software status

I originally slected the support pack in the VCA.  But I have since used Deploy Software/Firmware Baselines / both Manage Baselines and Track Versions - assigned, unassigned, reassigned, Options / Data Collection and Software Status polling.  In VCRM I deleted the "invalid support packs", and assigned servers to the good remaining support packs.  That's PSP 8.70 for the 2003 servers, and SPP 2014.09 for the 2008 servers.

 

Do these servers need a current SSH running?  They mostly have what I think is an old version, maybe from the old SIM, some have it listed in the VCA, some don't; some don't have it installed.

Andrew_Haak
Honored Contributor

Re: HP SIM 7.4 doesn't detect agent software status

Hello again,

 

No SSH  is not mandetory, recent snmp agent and template would be a a good idea. That is if the hardware also is recent.

Kind regards,

Andrew
MC Murphy
Frequent Advisor

Re: HP SIM 7.4 doesn't detect agent software status

The SNMP agent is the Windows Install Feature SNMP, and then whatever updates the Windows System Update Server puts on it. What do you mean "template"?  The servers are a range of Proliant DL320's and 350's, mostly G5 and some G6, 7, and 8.

Andrew_Haak
Honored Contributor

Re: HP SIM 7.4 doesn't detect agent software status

The template is a unix package, if you only have Windows servers you need the snmp managent agents and the Windows SNMP. The SNMP needs to be configuredfor the localhost and SIM server. Also configure the SNMP  trap desgination as the sim servernaam or IP.

Kind regards,

Andrew
MC Murphy
Frequent Advisor

Re: HP SIM 7.4 doesn't detect agent software status

The managed server has a HP Insight Management Agent and a HP Insight Management WBEM Provider.  SNMP Service has the CMS name or IP in trap destination and security.  These are all working quite well still for the VCA to be communicating with the VCRM.  I understand the VCA will be going away, so I'm trying to get SIM working with its baselines, and so far it's just a puzzle thatj's not together.   

MC Murphy
Frequent Advisor

Re: HP SIM 7.4 doesn't detect agent software status

The problem seems to be SIM in version 7.4 is supposed to replace VCA, but whatever it is doing different is not working.  It gives me a "? - Unknown" for Software Status for every server.  But I run the Version Control Agent, either directly on the managed server, or within System Management Homepage run from the CMS.  The installation guide says you must configure the Baselines.  I've done that.   I can assign and unassign and reassign servers to the Baseline.  The guide says run Configure and Repair Agents.  For the VCA installation that fails.  But what then?  What is SIM doing now different from prefious versions, where the same Configure and Repair VCA installation would succeed?  I'll attach a document of screenshots and further notes.    

Andrew_Haak
Honored Contributor

Re: HP SIM 7.4 doesn't detect agent software status

When i look at the VCA the SPP does not look complete. Does the VCRM Look good? You seem to be missing parts. Also the Datasource on the System Management Homepage is WBEM, you could try to set it to SNMP. You can set this in setting in the SMH under settings and then choose the datasource. The system you show is a G5 server. Depending on your OS you should not use the latest wbem provider. But one of the most strange things that i see is that the VCA does not show all components contained in the SPP.

Could you post a screenshot of your baselines in the VCRM?
Kind regards,

Andrew
Andrew_Haak
Honored Contributor

Re: HP SIM 7.4 doesn't detect agent software status

When i look at the last past of the attached doc, i see an error replicating settings. Where the logs says that the destination can not be the same or CMS server. Please set one server with the right settings by hand. Then let this be your source server and select the same OS server types be the destination. So configure a 2003 32bits server to be the source for all 2003 32bits servers and 2008 for all Windows 2008 servers etc...
Kind regards,

Andrew
MC Murphy
Frequent Advisor

Re: HP SIM 7.4 doesn't detect agent software status

In SIM now Manage Baselines gives me the error in the attached doc; event though the SMH on the SIM/VCRM server, and SMH on other ervers, seem to be communicating with the VCRM.  More puzzlilng by the day.

Andrew_Haak
Honored Contributor

Re: HP SIM 7.4 doesn't detect agent software status

In the screen you got the error you can select the repository in the right corner. This seems strsnge but seems to help sometimes. The config in SIM has no link with the VCA. The VCA connects to the VCRM the baselines in SIM are collected from the VCRM. That's the only link they have.

Kind regards,

Andrew
MC Murphy
Frequent Advisor

Re: HP SIM 7.4 doesn't detect agent software status

I've selected and OK'd several times the one repository.  I've "configured" several times to check the trust certificate.  i still get "Error retrieving repository.  Ensure the Version Control Repository Manager (VCRM) is installed and running, etc, etc."  This while within the SMH on the CMS/VCRM server I see and can manage the repository; and while the VCA on every managed server can acces the repository, select a baseline, update its contents; just like the old days.  So it seems to me not a problem with the Repository, but a problem with the method the SIM uses to access the repository.  Soemthing is confiugred badly or not at all, but I've no clue what that is.  Everything I try (Deploy \ manage Baseline; Configure \ repair Agents; Options \ Software/Firmware \ Version Control Repository) tell s me something is wrong with the repository.  There is one repository, is that correct?  Should SIM be finding the one repository that the SMH and VCA find?

MC Murphy
Frequent Advisor

Re: HP SIM 7.4 doesn't detect agent software status

I've selected and OK'd several times the one repository.  I've "configured" several times to check the trust certificate.  i still get "Error retrieving repository.  Ensure the Version Control Repository Manager (VCRM) is installed and running, etc, etc."  This while within the SMH on the CMS/VCRM server I see and can manage the repository; and while the VCA on every managed server can acces the repository, select a baseline, update its contents; just like the old days.  So it seems to me not a problem with the Repository, but a problem with the method the SIM uses to access the repository.  Soemthing is confiugred badly or not at all, but I've no clue what that is.  Everything I try (Deploy \ manage Baseline; Configure \ repair Agents; Options \ Software/Firmware \ Version Control Repository) tell s me something is wrong with the repository.  There is one repository, is that correct?  Should SIM be finding the one repository that the SMH and VCA find?

 

This is I see a step backwards.  At the beginning of this thread I was seeing and configuring the baselines, but failing to get Software Status at the SIM.  Now no software status, no baseilnes.

Server-Support
Super Advisor

Re: HP SIM 7.4 doesn't detect agent software status

ok, so is this a well known bug or just a misconfiguration error ?

MC Murphy
Frequent Advisor

Re: HP SIM 7.4 doesn't detect agent software status

I thought I had progress.  I had the CMS run an install/configure VCA on a new server, and got HP SUM claiming to run:

 

Waiting for the required components to be located and copied..
Installing  HP Version Control Agent for Windows ( 7.3.3.0) using component  cp0
23743.exe.
Installing  HP System Management Homepage for Windows ( 7.4.0.12) using componen
t  cp022466.exe.
Install Return Status: [SKIPPED, HP SUM did not proceed with the installation ei
ther because one or more components are already up-to-date or are not valid for
the selected system]


////////////////////////////////////////////////////////////////////////////////
//  HP Smart Update Manager for Node 10.1.5.51 Started: Tue Jan 13 2015 13:33:58
//  HPSUM Version: 7.1.0."18".25197.x64
////////////////////////////////////////////////////////////////////////////////
Inventory started
Inventory completed

Analysis started
Analysis completed

Analysis started
Analysis completed

Deployment started
Deployment completed

Deployed Components:


Node 10.1.5.51 is up to date, no updates were needed or nothing was installed be
fore exiting.

////////////////////////////////////////////////////////////////////////////////
//  Exit Code for Node 10.1.5.51: 3
//  HP Smart Update Manager for Node 10.1.5.51 Finished Tue Jan 13 2015 13:34:30
////////////////////////////////////////////////////////////////////////////////
WINDOWS_HPSUM_INSTALL_NOTE,C:\cpqsystem\hp\log\10.1.5.51
1) hpsum_log.txt for brief summary of the installation activity.
2) hpsum_detail_log.txt for installation details, including errors, for each com
ponent installed.

Install Agent .......................................................[SUCCESS]

 

 

like it was finally communicating.  in Deploy \ Manage Softare/FIrmware Baselines it shows me the baselines I've defined, and which systems are in which baseline.   But I pick that server that just got good results from HP SUM and do Deploy \ Track Software and Firmware Versions, I get a question mark and a column of installed Version of all installed stuff, but the Support pack Version and Latest Version columns are empty.  So I'm still stuck at the beginning, which is:

The VCA on the managed server connects to the VCRM on he CMS, shows me the updates, lets me run them, as always;

But the VCRM with its baselines, that is supposed to be taking over the tracking and installing, doesn't show me what's on the managed server.