Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

HPSIM 5.3 - Configure or Repair Agents Failing on "Configuring SSH authentication"

kschafer
Advisor

HPSIM 5.3 - Configure or Repair Agents Failing on "Configuring SSH authentication"

Okay, I'm trying to Add and Configure some Linux servers in SIM 5.3;

OS is SLES 10 SP1. I think the PSP is an older version (7.9 or an earlier 8.*)... I'm not sure how to check that from the OS.

Some other servers with the same PSP worked; ESX hosts with newer agents worked fine too.

Here's the error as displayed in SIM:

Windows configuration command (START)...
Running the Windows based repair tool (DONE).......................... [ERROR]
Could not create repair directory on the target system. Check username/password,
user's privileges and whether administrative share is enabled on the target syst
em.

Configuring SSH authentication (START)...
Configure SSH for host based authentication (DONE).................. [FAILED]
Configuration failed to complete due to the following exception:
Ssh Operati
on failed for node:fruxp615.geico.net. SSH_BAD_API_USAGEYou must supply a valid
username! [Unknown cause]


8 REPLIES
kschafer
Advisor

Re: HPSIM 5.3 - Configure or Repair Agents Failing on "Configuring SSH authentication"

And here's output from the stdout tab:

Running the Windows based repair tool (DONE).......................... [ERROR]
Could not create repair directory on the target system. Check username/password,
user's privileges and whether administrative share is enabled on the target syst
em.
java.io.IOException: /usr/bin/smbclient: not found

kschafer
Advisor

Re: HPSIM 5.3 - Configure or Repair Agents Failing on "Configuring SSH authentication"

I hate replying to myself so much but here's an update - I installed the newest PSP and updated firmware, but still no help. Same problem when trying to run Configure or Repair Agents.

Any ideas?
Change_happens
Honored Contributor

Re: HPSIM 5.3 - Configure or Repair Agents Failing on "Configuring SSH authentication"

the error looks like configuration issue on that box. is there smbclient installed?
kschafer
Advisor

Re: HPSIM 5.3 - Configure or Repair Agents Failing on "Configuring SSH authentication"

I've installed the samba-client package to resolve the smbclient error, but that didn't help - I think that it's only used to configure windows boxes anyway.

I'm still getting the ssh errors. The other thing I noticed is that on the client, I'm getting this in it's messages log when I attempt to Configure/Repair:

sshd[17494]: Did not receive identification string from 10.240.16.75 <- That's the IP of my SIM sever.

Since installing the new PSP and setting up snmp manually, I can see the status of the server, but I can't configure/repair the agent so I get prompted for credentials when accessing the SMH.



kschafer
Advisor

Re: HPSIM 5.3 - Configure or Repair Agents Failing on "Configuring SSH authentication"

I hate responding to myself... but I still can't figure this out.

How can I troubleshoot SSH on the SIM side? There doesn't seem to be any issue with the managed system's SSH.
Tomislav P.
Regular Advisor

Re: HPSIM 5.3 - Configure or Repair Agents Failing on "Configuring SSH authentication"

Hi,...

...same problem,..

please help.

Regards,
Tom
Tomislav P.
Regular Advisor

Re: HPSIM 5.3 - Configure or Repair Agents Failing on "Configuring SSH authentication"

http://docs.hp.com/en/418811-004/ch07s01.html



vi /etc/snmp/snmpd.conf

Remove the comment symbol (#) from the trapsink line, and add the IP address of the CMS:

trapsink IPaddress

where IPaddress is the IP address of the CMS.

Add the CMS to the read only community by adding the line:

rocommunity CommunityName IPaddress

where CommunityName is the SNMP community string used by the CMS and IPaddress is the IP address of the CMS.



Regards,
Tom
Tomislav P.
Regular Advisor

Re: HPSIM 5.3 - Configure or Repair Agents Failing on "Configuring SSH authentication"

and more important:

# vi /etc/sshsshd_config

replace:
PasswordAuthentication no

to:
PasswordAuthentication yes

and restart snmp daemon.

Regards,
Tom