Online Expert Day - HPE Data Storage - Live Now
April 24/25 - Online Expert Day - HPE Data Storage - Live Now
Read more
Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

HPSIM 7.3 fresh install : trust relationship fail after some time

Pascal Schirrmann
Occasional Advisor

HPSIM 7.3 fresh install : trust relationship fail after some time

Hi,

 

We installed last week a brand new installtion of HPSIM 7.3 (latest updates).

 

installation is :

server : Windows 2008 R2 US on a VM on a (HP, of course :) ) ESXi 5.1, 12 Gb RAM, 8 core.

HPSIM 7.3 with hotfix up to 034

Insight control : modules performance and power control (not really in use).

HP Oneview for VMware 7.4.1

HP Remote Support 7.1.0.46

The two SQL databases are on an exteernal Windows 2008 R2 SQL cluster.

We had the same installtion before on a 7.2 HPSIM.

Due to some older database corruption, we didn't migrate the data. I'm currently working on manualy repopulate the database. So far, I have around 60 HP ProLiant server and 4 VM in the system. No performance issues :)

 

On another VM, I run a HP VCRM 7.3.4.0

 

More or less, the complete set seems to fit together :)

 

But I have a strange behaviour.

 

When I start the HP Insigth service, the trust relationship for any discovered server is OK (if it did work before !)

After a short while (less than one day, I would say), the relationship is no longer working.

It doesn' seem to be related to the daily System identification : yesterday evening, I restarted the HPSIM service, and get the trusted relationship to work. This morning (long before de daily job, the relationship was broken again.

 

This is very annoying, as the (stable) trust relationship is mandatory to use my vcrm !

 

Any suggestions ? 

 

TIA,

 

Pascal

 

7 REPLIES
Andrew_Haak
Honored Contributor

Re: HPSIM 7.3 fresh install : trust relationship fail after some time

Hello there,

 

There seems to be a trust issue with the latest SMH see other messages from N0kia in the post :

http://h30499.www3.hp.com/t5/ITRC-HP-Systems-Insight-Manager/VCRM-7-3-4-and-HP-SPP-2014-06-baseline-is-not-suitable-for-all/td-p/6568768

 

Kind regards,

Andrew
Pascal Schirrmann
Occasional Advisor

Re: HPSIM 7.3 fresh install : trust relationship fail after some time

Hi Andrew,

 

Thanks for your answer.

 

However, as I also have some troubles establishing the trust relationship, in my case, the trouble is slighly different as once established, the trust doesn't remain active.

 

Following your link, I didn't find a track to follow.

 

Thanks anyway :)

 

Pascal.

Andrew_Haak
Honored Contributor

Re: HPSIM 7.3 fresh install : trust relationship fail after some time

Hello Pascal,

 

if you look at the server that has a trust, do you have one or more trusts with the same SIM server?

You can find this under settings, SMH, security and trust mode and click trusted certificate.(see screen shot).

 

If you have more than one trust let me know. Is the certificate 1048 or 2048 bits?

If you look at the trusts on the SMH of the SIM servef it self find the 1024 and 2048 cetificates and copy the lower certificate information. You can import the certificates one at a time and see if either works. If you logon with Windows credentials you first have to logoff from the SMH the you imported the certificate. Now you can check if the trust works.

 

if you encounter any other problem please reply to this message.

 

Kind regards,

Andrew
Pascal Schirrmann
Occasional Advisor

Re: HPSIM 7.3 fresh install : trust relationship fail after some time

Hi Andrew,

 

Sorry for this long time before an answer I was al little busy...

 

Back to the problem : As the Insight server is brand new, I had to push the certificate on each and every server. Ans I pushed the 1024 bytes certifice, this i got from :

http://{HP SIM Server}:280/GetCertificate?certtype=sso

 

Moreover, as I have this trouble on around 80 servers now, and just by restarting the HPSIm service, everythings is OK again, I don't think that the trouble is a second certificate ?

 

Still following your idea, i'll remove on some serveurs all other hpsim certificates (from older HPSim servers) I never had to do that, but at least, this is something I can do :)

 

Thanks,

 

Pascal

Pascal Schirrmann
Occasional Advisor

Re: HPSIM 7.3 fresh install : trust relationship fail after some time

Hi,

 

alas, this doesn't work.

 

What I did :

 

On each classical server, I only have one certificate, the 1024 bits one.

On the VCRM, I have of course a long list of certificates (as I use the Certificate trust relationship), but I also removed the certificate of the old hpsim server.

 

I restarted the hpsim service, and one hour later, no trust relaship again. I restarted the hpsim server, and again, this morning (I don't know how long it did work) no trust relationship.

 

What really buzz me is that for ilo cards, the relationship is still operational, with the same certificate !

 

My HPSIM server is a VMware VM, Windows 2008 R2, my reference servers are :

A Windows 2000 server on a ML370 G3 (here i cannot test the trust relationship for ilo, as this is an ilo1)

A windows 2003 server on a DL 580 G4 (iLO 2 OK)

A windows 2008R2 server on a dl380 G5 (iLO2 OK)

A windows 2012R2 server on a DL380G7 (iLO3 OK)

A Windows 2008R2 server on a DL360p Gen8 (iLO 4 OK)

A RedHat 6 server on a DL380 G5 (iLO2 OK)

And of course the VCRM, a Windows 2008 R2 VM (so no iLO :) )

 

Any new idea very welcome !

 

Thanks,

Pascal

 

 

n0kia
Valued Contributor

Re: HPSIM 7.3 fresh install : trust relationship fail after some time

Looks like the issue is not fixed in 7.4 but will be in SMH 7.4.1

Pascal Schirrmann
Occasional Advisor

Re: HPSIM 7.3 fresh install : trust relationship fail after some time

Hi nOkia,

 

Thanks for your answer. Does it mean that "my" case is well known ?

 

From inside HP, I got this information :

Customer Advisory c04433991

 

But this is not the case I encounter.

 

In between, I did a billion tests, and still don't see any logic. Just after a while, I lost trust relationship on my servers.

 

Thanks,

Pascal