Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

HPSIM 7.3 with HP agents 9.41 for xenserver 6.1

navsangha
Occasional Advisor

HPSIM 7.3 with HP agents 9.41 for xenserver 6.1

Hi,

 

I am running a HP DL360 G6 server with Xenserver 6.1 which i would like to add into HP SIM 7.3 monitoring.

 

Originally i had HP insight agents 9.2 installed and these worked fine, if i pulled the power from one of the PSUs or removed a network cable from a NIC, HP SIM received a trap, added the events to aggregated event status and change the Health Status to Major or Minor. However installing agents 9.2 resulted in xen not shutting down or rebooting, gets stuck on a  cmanicd error.

 

Anyway i removed agents 9.2 and then installed the latest 9.41 agents including reboots inbetween just in case it mattered (no reboot issues with these agents by the way). Now when i pull the power or NIC, HP SIM receives the traps and marks the fault under the aggregated event status, for e.g.

 

(SNMP) Power Redundancy Lost (6032) severity Major
(SNMP) Power Supply Failed (6050) severity Critical
Health Status Array Change occurred (11020) severity informational

or

NIC Connectivity Lost Trap (18012) severity Major
Health Status Array Change occurred (11020) severity informational

 

but the system health is still markied as Normal and green and doesnt change. Am i missing something here, i kind of know my way around HP SIM but would not describe myself as an expert in any way.

 

Can anyone help as this is driving me mad.

 

Thanks

14 REPLIES
navsangha
Occasional Advisor

Re: HPSIM 7.3 with HP agents 9.41 for xenserver 6.1

Just to add i have installed SIM 7.3 hot fixes up to hotfix 35 which is the latest one to date
navsangha
Occasional Advisor

Re: HPSIM 7.3 with HP agents 9.41 for xenserver 6.1

Also should have mentioned that the SMH on the server reports health as degraded and a big orange triangle.
Andrew_Haak
Honored Contributor

Re: HPSIM 7.3 with HP agents 9.41 for xenserver 6.1

Hello,

 

What protocol do you use to discover the server? Could it be that you only have wbem discovery?

 

Wbem and SNMP should be enabled, the traps you receive are SNMP so if you don't have SNMP credentials to discover the server you could be missing some info. If you logon to the SMH of ghr server you mention does it have SNMP or WBEM  as a dataprovider? (You can see this at the top of the SMH of the target server)

Kind regards,

Andrew
n0kia
Valued Contributor

Re: HPSIM 7.3 with HP agents 9.41 for xenserver 6.1

If you were to run HW status polling manually  while in that state. Does the status change?

navsangha
Occasional Advisor

Re: HPSIM 7.3 with HP agents 9.41 for xenserver 6.1

HI Andrew, SMH data source is showing SNMP, i have configured the SNMP config file with the correct community strings and i can discover the system fine, usually if there is an snmp issue the discovery task on SIM fails to pick up the system model and hardware, but SIM picks all this up fine.

navsangha
Occasional Advisor

Re: HPSIM 7.3 with HP agents 9.41 for xenserver 6.1

hi n0kia, 

 

I Just ran the HW status polling against the client and let it poll using all the protocols listed and it says its complete, only thing is the duration was 141ms. HEalth status still shows up Normal

Andrew_Haak
Honored Contributor

Re: HPSIM 7.3 with HP agents 9.41 for xenserver 6.1

Could you past a screenshot of the status in SIM?

Kind regards,

Andrew
navsangha
Occasional Advisor

Re: HPSIM 7.3 with HP agents 9.41 for xenserver 6.1

HI Andrew, please see screenshots that show events received but Health status OK

Andrew_Haak
Honored Contributor

Re: HPSIM 7.3 with HP agents 9.41 for xenserver 6.1

Hello back,

If you click on the system name check if the ok status is a WBEM or SNMP status. If possible attach a screenshot of the screen when you clicked on the systemname and a screenshot of the SMH of the server that send these events.
Kind regards,

Andrew
navsangha
Occasional Advisor

Re: HPSIM 7.3 with HP agents 9.41 for xenserver 6.1

HI Andrew, screenshots attached

Andrew_Haak
Honored Contributor

Re: HPSIM 7.3 with HP agents 9.41 for xenserver 6.1

Hello again,

 

It seems that the remote SNMP can't read the power status. I looked at a DL 380 server as it has it's own power and when i look at the Health Status i also see a Power Status green. But then agai nthat's a Windows 2008 server with WBEM agent.

 

I even checked there is no WBEM agent for your platform. Perhaps you can get your event from your ILO then.(that's also an option) Do you know how ? If not let me know.

Kind regards,

Andrew
navsangha
Occasional Advisor

Re: HPSIM 7.3 with HP agents 9.41 for xenserver 6.1

HI Andrew

 

Does appear to be agent version related because agents 8.6 and 9.2 appear to function as expected and i get the correct health status displaying in SIM but agents 9.3, 9.4 and 9.41 dont.

 

If you could let me know how i  would i go about getting the health events via the iLO.

 

 

Thanks

Andrew_Haak
Honored Contributor

Re: HPSIM 7.3 with HP agents 9.41 for xenserver 6.1

You would almost think they forgot to support the G6 server type. The server is not the latest but still in support so...

I'll get back to you on monday..have a good weekend.

Kind regards,

Andrew
navsangha
Occasional Advisor

Re: HPSIM 7.3 with HP agents 9.41 for xenserver 6.1

Hi Andrew

 

Yes i thought it was a g6 issue only, but i tried of it a Gen8 server and the same thing, i need to look into Agentless manbagement on the Gen8 but thats for another thread.