Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

HPSIM SNMP problem

sdb_2
Regular Advisor

HPSIM SNMP problem

Hi,

I have this problem with SNMP communication between HPSIM and a w2k3 ISA server:
- SNMP request from HPSIM are arriving at ISA server, ISA answers with "authenticationFailure" snmp trap.

I tried to disable te "send authentication trap" option from the SNMP service of the ISA server. (This is also disabled on the HPSIM server). This resulted in the ISA completely not answering SNMP requests from HPSIM server.

In the Security tab of the SNMP service "Accept snmp packets from any host" is checked.

Can anyone help me with this?
4 REPLIES
David Claypool
Honored Contributor

Re: HPSIM SNMP problem

The best practice configuration is always to disable 'Send authentication trap' so what you observe is not normal.

The reason for the authentication trap in the first place is that something is tickling your system using SNMP but with the wrong community string. This could be your HP SIM CMS (if you have configured multiple community strings in Global Protocol Settings for instance) or a completely different system.
sdb_2
Regular Advisor

Re: HPSIM SNMP problem

Thanks. I already disabled the "send authentication trap" option.

Now, the ISA server completely not answers any SNMP request from the HPSIM.

Any idea what can be the cause of this?
Rancher
Honored Contributor

Re: HPSIM SNMP problem

We are not having any trouble with SIMS and our ISA server. We have our SMNP set up like this:
Traps tab:
The private string community name with the IP of our SIMS server in Trap destinations. We also have the public sting in community names but with no destination.
Security tab:
We have both public and private strings in the community names, with the private string set as read create.
We have "Accept SNMP packets from these hosts" and have localhost and the IP address of our SIMS server in there.
I am not sure if this is the correct way to do it, but it has worked for us.
sdb_2
Regular Advisor

Re: HPSIM SNMP problem

Our setup looks like this:
ISA servers:
- "send authentication trap" disabled
- "Accept SNMP packets from any host"
- community string "hpsim" = read-only (for HPSIM server)
- community string private = read-write (for HP agents)

HPSIM server:
- "send authentication trap" disabled
- "Accept SNMP packets from any host"
- community string "hpsim" read-write
- community string "private" read-write

Firewall config is setup this way:
- allow udp port 161 from hpsim to isa's
- allow udp port 161 from isa's to hpsim
- allow udp port 162 from isa's to hpsim
- allow tcp ports 2301 & 2381 from hpsim to isa's

This setup works fine with the rest of our servers.
What we have here is our ISA's completely not reacting on snmp requests. TCP connections are working fine.

Has anyone seen this behaviour before?