Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

HPSIM & Warranty

SOLVED
Go to solution
Steve_576
Frequent Advisor

HPSIM & Warranty

I am confused by the contract and warranty data collection and remote support pack.

I installed, configured and enabled the remote support pack. It seems to function fine.

In my HPSIM my list of devices showed a "?" that contract & warranty data was not available. I ran the Options - Discover Contract & Warranty data and various systems generate various errors.

However, when I choose Options - Remote Support & Config - Remote Support Services - several of my devices show a valid warranty / contract.

I've read the various posts about insuring product number and serial number are entered. I have several like machines and I've made sure these fields are populated. Yet, even on like machines - with the same info. I get different errors. For example, here are (3) messages.

1) I get this message on my servers - even though they reflect active warranties in Option - Remote Support Config. Product ID and SN are populated.

"There was a problem processing the request. Verify the Remote Support Client service is running, properly configured and that the HP SIM server has access to the internet."

2) I get this error on a desktop PC, even though the product number seems ok. I say seems ok because I have a different model unit with a product ID of 2405 and its my only client that collected contract/warranty data.

"Received error from the contract and warranty service, additional details are below.
Product number was not found: 2408"

3) Various clients get this.

"Could not obtain contract and/or warranty data for the system. Additional information regarding the problem is shown below.
no valid credentials key pair was found - could not apply any precedence rule - please check the incident/request properties for valid credentials key pair."

I think I've managed to wildly confuse myself trying to get the contract/warranty running. Can anyone help me out?
20 REPLIES
grvnetteam
Advisor

Re: HPSIM & Warranty

I have had similiar issues with this myself.

Here is what I do when I get a new server to ensure the proper Remote Support registration:

1) We receive the email with our Care Pack information - Save that Number!!!
2) Deploy the Server w/RDP, and let HPSIM discover the system
3) HP SIM will add it to the Remote Support Eligible Systems Collection
4) Edit the System Properties for the Server in question
5) Under Contract and Warranty Information - Enter, if not filled out, Serial Number/Product Number/Country/Entitlement Type(from Drop down)/the saved care Pack number from Step 1/Oblilgation ID (if you have one)
6) Ensure that all the other information in this section is filled out (I have this set for all servers by default, upon discovery)
7) Click OK to save this
8) Go to Remote Support Configuration and Services - find the server - Click on the Status Circle - at the bottom issue an Entitlement Check and let it refresh - you should see all of the information you entered
9) close this out, and click on the Refresh List button, find your server again, and it should be Green!

I have found that the ITRC is my friend as far as keeping registered Care Pack information for systems, as well as HP SIM. I always enter the new Care Packs into the ITRC before deploying the server.

If I do not have the Care Pack, due to a HP error in the ordering process, i register the Product ID and Serial Number in ITRC, and it gives me the Care Pack info, which I then enter into HpSIM!

I hope this helps!
grvnetteam
Advisor

Re: HPSIM & Warranty

I should have mentioned that the comments I posted can be modified for existing servers as well. HP gives you a lot for free, you just have to use them.
Steve_576
Frequent Advisor

Re: HPSIM & Warranty

Thanks for the info.

In Insight Manager if I choose Options -> Remote Support Config -> Remote Support Services, I see my servers with Remote Support enabled, product Ids, serial #'s, and contracts filled in and they show the proper warranty status.

However, if I go into Insight Manager and choose Options -> Contract and Warranty Data Collection then these same devices that show fine warranty info in the other screen generate one of the errors I indicated. The CW column in Insight Manger is a blue question mark - though again, on the Remote Support Services tab I do see proper warranty info.

Also, none of my printers, PCs etc collect warranty info even though serial numbers and product IDs are populated.

Oddly, I have 2 PCs out of 100 that collected warranty info and I do not see any difference between them or the other devices that won't collect.

What I'm trying to do is get the Contract and Warranty Data Collection task to gather the info for all my devices, especially the ones that already show valid warranties & contracts in the other screen. The majority of my devices are reporting serial numbers and product IDs which seemed to be a common problem, but even those are not collecting.
grvnetteam
Advisor

Re: HPSIM & Warranty

I hear ya. Remote Support is a good thing, but like I said, there is some up front leg work to keep it running. I have Collection problems as well, but only for servers, as we do not keep our pc's/Printers in SIM.

Have you tried to do the Warranty Collection BEFORE going to the Remote Support section? In other words, ensure all data is in the System Properties and run the Warranty and Data Collection afterwards, for this system.

i have found that the Warranty Collection does not work as it is supposed to, therefore, I have to gather the data from ITRC, email, and other sources first before it runs fine. Once the Collection runs through, I have not had to run the Entitlement checks through the Remote Support section, since this updates it.

I know I am missing something for you, and I am sorry if I appear to be giving you answers you already know....just trying to give you what works for me.
Steve_576
Frequent Advisor

Re: HPSIM & Warranty

Thanks again for the reply.

Yes, the product id, serial number, etc type data was and is in the system properties before and after running either Remote Support or Warranty collection.

I seem like one of the lucky few where serial numbers and product IDs were generally all filled in.

Can I ask you this - when you go into Insight Manager and look at your All Systems View (I view it in table form) - I see columns for HEalth Status, Management Processor, Software Version, etc and one of those columns is Contract and Warranty - all of mine are blue question marks. Do yours show a real status?
grvnetteam
Advisor
Solution

Re: HPSIM & Warranty

Check out the doc I just attached. It will show you the status 'CW' for my servers.

I had an issue with RSP when I first installed, which forced me to un-install and follow the docs carefully to get it re-installed. once that happened, everything works as I have described. Not perfect, but at least we get automated cases generated when things break. Like I said, there is some manual work to do to make the automated stuff function....frustrating.

Let me know if I can do anything else.
Steve_576
Frequent Advisor

Re: HPSIM & Warranty

Great, thanks for the attachment. That's what I'm trying to accomplish.

I get through your steps 1 - 8 with perfect results.

Your step 9 is the only part that doesn't work for me.

Step 9 seems like as long as steps 1-8 worked that it is a no-brainer. However, steps 1-8 are good for me but not #9.
grvnetteam
Advisor

Re: HPSIM & Warranty

That sounds like what was happening to me when i first went through the install of RSP.

Unfortunately, my resolution was to un-install RSP and OSEM, and go through the whole process again, but using their docs as the guide, and the User guide for HP SIM. That seemed to work for me.

On Step 9, what color is the circle next to your servers? And when you click on the circle, what does it say? can you attach a screen shot of it? I may be able to assist further.
Steve_576
Frequent Advisor

Re: HPSIM & Warranty

Attached show the same screen shot as the one you attached and a second screen shot that shows the accepted warranty/contract data for the remote assistance.

In Insight Manager, my CW column is all blue question marks. In the Remote Assistance screen of Insight Manager is shows those with warranties or contracts as appropriately green, red, or yellow.
grvnetteam
Advisor

Re: HPSIM & Warranty

From looking at your screen shots, this is exactly what happened to me the first time around. RSP has not been integrated with SIM correctly. the install was very, very picky with the order of events.

You are getting errors when you run the Warranty Collection as well, and this is exactly the issue I had.

i found that I had messed up the steps when installing, and re-installed. After that, all was well.

I can try and re-hash the install process i went through, so let me know if you need that.
Steve_576
Frequent Advisor

Re: HPSIM & Warranty

If you don't mind, I would appreciate it. I thought we followed it to a "T".
grvnetteam
Advisor

Re: HPSIM & Warranty

If you don't mind, give me a day to get this to you, but I will get it to you.
Steve_576
Frequent Advisor

Re: HPSIM & Warranty

Thanks! I'll take any info I can get, whenever I can get it :)
Andy Stubbings
Frequent Advisor

Re: HPSIM & Warranty

I am having the same problem, CW column not displaying the status shown in Remote Software config tab.

did you ever get a fix for this?
Steve_576
Frequent Advisor

Re: HPSIM & Warranty

nope, I'm still in the same boat though I've not gotten back to it. I have also run into a few others with the same issue.
U. Rasmussen
Occasional Visitor

Re: HPSIM & Warranty

I've also seen the same issue on several installs I've done. I have yet to find a good solution for this one. Any help appreciated on this one, it seems to be quite a widespread issue.
grvnetteam
Advisor

Re: HPSIM & Warranty

I am sorry for not getting my reply back to you sooner.....been busy.

Here is what I did, since I did not follow the directions completely to get Remote Support enabled.

1) I un-installed HPSIM, and all components
2) Deleted all databases, and created empty ones
3) I then followed the HPSIM 5.1 install guide to the letter...allowing a day or so for collection and identification
4) I then followed the Remote Support install guide to the letter

Once this was done, I was able to see the warranty status and Remote Support information was correct...for some systems.

I then had the tedious task of filling in Prod/Serial/Entitlement info for every system, using our ITRC as a baseline.

the end result - A fully funtional Remote Support and auto-case generation system!! We have had a lot of use thanks to hard drive/memory/power supply failures, and this works great!

Not to mention the warranty reports for all of our Proliant systems.

I hope this helps.
Steve_576
Frequent Advisor

Re: HPSIM & Warranty

Thanks for the reply.

Unfortunately this process did not work for me.

Thought the latest remote support software upgrades that were released recently seem to have fixed the issue.

My battle at this point is why Insight Manager produces a product number that is seemingly incorrect for most of my systems.

For example, a d530 workstations is discovered as product number 2140.

Warranty lookup fails as invalid product

SIM says in product description it is a d530 CMT (DC577AV)

If I change the autodiscovered 2140 to DC577AV then warranty lookup is successful.

So, in one spot SIM seems to have the product number needed for warranty lookup to succeed but in the product number field its putting in numbers like 2140, 2698, 2150, etc forms.

If I manually correct, all seems well. SIM reports the apparently incorrect product number in 85% of my cases so I can't manually change all of these.

Anyone with similar issues?
grvnetteam
Advisor

Re: HPSIM & Warranty

I have not seen any issues with incorrect Product Id's.

We only use HPSIM for our servers/network gear, and we do not keep any workstations in SIM.

The only suggestion I have is to make sure your Asset and Contact information is filled out, because it needs this information to work correctly.

Sorry I haven't ben more help.
Steve_576
Frequent Advisor

Re: HPSIM & Warranty

Thanks again for taking the time to reply.

It happens to us on servers too - a DL100 reports as a product number SN6T which fails warranty check, but when I manually input the product number 368989-B21 (just an example) that is sitting in parenthesis at the end of the product description and re-do the warranty check it passes and collects it.

Same deal with some DL380G4's. SIM plops some odd product # in the product # field, but has the seemingly correct product number in parenthesis at the end of the product description field.

Glad you aren't having the issue!