Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

HPSIM and PostgreSQL

SOLVED
Go to solution
Neeq
Occasional Advisor

HPSIM and PostgreSQL

Hi there, I've spent all night trying to figure this out, been searching for hours and have tried everything I can see.

The problem is when I try to install HPSIM it gets about 50 failed dependencies errors, all of them sprouting from the postgresql .deb files.

Instead of posting all the errors here, they are attached as a .txt file.

Any help is appreciated.
13 REPLIES
Change_happens
Honored Contributor

Re: HPSIM and PostgreSQL

really strange!! why you are trying to install SIM 4.2? it was launched early 2006.
Currently version is 5.2.1.
Anyways your errors are because you have already Postgresql (higher version) installed and SIM is unable to overwrite it. so first remove ur postgresql {all three packages(lib,serverand postgresql)} and then run SIM again.

Note: My sugestion is if you r trying first time better you try latest SIM 5.2.1.
Neeq
Occasional Advisor

Re: HPSIM and PostgreSQL

Thanks for the reply.

I was told by a friend that I should use this version; it is a rather old server and I guess he didn't know if the newer versions ran on it.

Back to the problem, from what I can see, PostgreSQL isn't installed on the system.
Aptitude says there is nothing to do with it on there and that it has 0 modules to remove.

I do know my way around a linux system, but am no means an expert, any ideas how to kill whatever records of it exist?
Neeq
Occasional Advisor

Re: HPSIM and PostgreSQL

Ok, I just downloaded HPSIM 5.2.1, it tells me I have an unsupported operating system.

My redhat-realase says: Red Hat Enterprise Linux Server release 5 (Tikanga)

Any help on either front will be loved.
Neeq
Occasional Advisor

Re: HPSIM and PostgreSQL

I find it hard to believe that there is nobody that can help.
My questions are not that hard and all I need is a little direction, please..
Change_happens
Honored Contributor

Re: HPSIM and PostgreSQL

Hi,
Sorry for late reply as it was holiday.. and i was not online.
Yeah you can straight away go and run that SIM5.2.1. just run that .bin file.
i don't think you will see any error in this version.
if you see any error i am here.
Neeq
Occasional Advisor

Re: HPSIM and PostgreSQL

As I said in a couple of posts up, 5.2.1 says I have an unsupported OS.

/etc/redhat-release: Red Hat Enterprise Linux Server release 5 (Tikanga)
Change_happens
Honored Contributor
Solution

Re: HPSIM and PostgreSQL

looks like u have latest RHEL.
ok you can extract SIM and HPSMDB from that bin.

./.bin --keep --noexec -mxserver

It will extract all rpms to mxserver directory. now install HPSMDB first which has 3 packages.
hpsmdb , server and lib ( install rhel5 one)

then install. hpsim config and server (2 RPMs)
and then after installtion run mxinitconfig -a .

hopw u will get it working soon. post reply soon..
Neeq
Occasional Advisor

Re: HPSIM and PostgreSQL

Sorry to be such a burden, but doing that got past the OS problem, but now brings more errors.

# rpm -i hpsmdb-rhel5-8.2.1-1HPSIM.i386.rpm
error: Failed dependencies:
/sbin/ldconfig is needed by hpsmdb-8.2.1-1HPSIM.i386
initscripts is needed by hpsmdb-8.2.1-1HPSIM.i386
openssl is needed by hpsmdb-8.2.1-1HPSIM.i386

# rpm -i hpsmdb-rhel5-libs-8.2.1-1HPSIM.i386.rpm
error: Failed dependencies:
/sbin/ldconfig is needed by hpsmdb-libs-8.2.1-1HPSIM.i386

# rpm -i hpsmdb-rhel5-server-8.2.1-1HPSIM.i386.rpm
error: Failed dependencies:
/usr/sbin/useradd is needed by hpsmdb-server-8.2.1-1HPSIM.i386
/sbin/chkconfig is needed by hpsmdb-server-8.2.1-1HPSIM.i386
hpsmdb = 8.2.1 is needed by hpsmdb-server-8.2.1-1HPSIM.i386
libpq.so is needed by hpsmdb-server-8.2.1-1HPSIM.i386
/bin/sh is needed by hpsmdb-server-8.2.1-1HPSIM.i386

Change_happens
Honored Contributor

Re: HPSIM and PostgreSQL

are u not a root?
dependencies shows either u r not root or u dont have sufficient packages installed on system. yeah its required simple command like adduser and chkconfig which are absent there.
can u check it?
Neeq
Occasional Advisor

Re: HPSIM and PostgreSQL

useradd and chkconfig are both in sbin, and they can both be used. I don't get why this is happening, I'm tempted to just give up and throw it in the trash -.-
Change_happens
Honored Contributor

Re: HPSIM and PostgreSQL

ok try.. --nodeps flag while installing.
and sure u r root user?
Neeq
Occasional Advisor

Re: HPSIM and PostgreSQL

Yes, I am logged in as root.

Using --nodeps seemed to work on the first rpm, but the rest just get more errors.

Since it's nothing important I will reinstall RHEL5 tomorrow and I'll get back to you then.

Thanks for the constant replies.
Change_happens
Honored Contributor

Re: HPSIM and PostgreSQL

Sure. you can try installing update 1 or simple RHEL5. try full install.