Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Help needed Configuring HP SIM

 
DavidinLongford
Occasional Visitor

Help needed Configuring HP SIM

Apologies for being a newbie to HP SIM

I installed HP SIM 5.3 on a server called SERVER1. I went through the First Time Setup Wizard and more or less took all the defaults.

I then went to the other 15 servers here and made sure the SNMP Service and SNMP Trap Service were running.

I configured the SNMP Service as follows
a) I ticked everything under the tab Agent
b) I created a Community name of HPSIM and set the Trap Destination to SERVER1 on the Traps tab
c) Under Accepted community names I have HPSIMR and HPSIMRW with the Accept SNMP packets from these hosts set to SERVER1

Back on SERVER1, when I open HP SIM I can see all the serves listed under All Servers.

My problem is the only Events being recorded are when I kill the power to a server, and that's probably just because it can't ping it anymore. I get an email telling me SERVER2 is unreachable.
If a server has a faulty hard drive , or a bad fan, or whatever then nothing gets recorded in the Events on HP SIM and thus I do not get emailed about it.

Help Please...
10 REPLIES
Steven Baillie
Trusted Contributor

Re: Help needed Configuring HP SIM

on you HP SIM server in HP SIM
try going to
options
security
credentials
then Global Credentials
and putting in your SNMP string there.


also on you other servers try setting you SNMP server to accept SNMP packets from any host.


steven
DavidinLongford
Occasional Visitor

Re: Help needed Configuring HP SIM

I checked the Global Credentials and everything seems OK. As well as the community names I entered it also has the very first one down as public.

I'll try changing that setting on a couple of servers to Accept Traps from any host and I'll pull a power supply to see if anything gets recorded in HP SIM
David Claypool
Honored Contributor

Re: Help needed Configuring HP SIM

Use 'Manage Communications' in HP SIM to analyze what's going on.
Ralph Frampton
Frequent Advisor

Re: Help needed Configuring HP SIM

RE SNMP Service check boxes:
- I don't think you need to have all of them checked, the System Mgmt Homepage (SMH) help for that shows only Application, Internet, & End to end ticked.
- Based on my interpretation of the help tooltip for those check boxes while configuring them in SNMP service, I believe the appropriate ones to check are Physical, Application & End to end. I don't check the Internet one as our servers typically don't host IP router functionality.

RE SNMP Trap Service:
- I don't believe you need that running on all monitored servers & it only needs to be running on the server hosting HPSIM, in your case make sure that service is running on SERVER1
- your description does not mention this as running on SERVER1 & that is likely reason why your HPSIM isn't seeing traps from monitored servers

If you want Single Sign On to work properly from you HPSIM to the monitored server's SMH:
- open SMH, Settings » SMH » Security » Trusted Management Servers & add certificate from SERVER1
- make sure Trust Mode is by certificate (should be as it's default unless you've changed it).

Additionally, if you have any firewalls in place (router or server based), then make sure they are configured to allow your SNMP traffic to/from the managed servers & the HPSIM host.
Timothy Cusson
Valued Contributor

Re: Help needed Configuring HP SIM



I then went to the other 15 servers here and made sure the SNMP Service and SNMP Trap Service were running.
>>> as already stated the other 15 only SNMP service, NOT SNMP trap service.

I configured the SNMP Service as follows
a) I ticked everything under the tab Agent
>>> as already stated...

b) I created a Community name of HPSIM and set the Trap Destination to SERVER1 on the Traps tab
>>>the Traps travel on the Read Only community. HP SIM and the other 15 MUST have identical Read Only community string of HPSIMR, the write community adds features, it must be identical on HP SIM and the other 15
>>>also, on HP SIM and other 15, Trap Destination MUST include 127.0.0.1

c) Under Accepted community names I have HPSIMR and HPSIMRW with the Accept SNMP packets from these hosts set to SERVER1
>>> to trouble shoot set it to accept from all hosts, later try FQDN ot IP address

Back on SERVER1, when I open HP SIM I can see all the serves listed under All Servers.

My problem is the only Events being recorded are when I kill the power to a server, and that's probably just because it can't ping it anymore. I get an email telling me SERVER2 is unreachable.
If a server has a faulty hard drive , or a bad fan, or whatever then nothing gets recorded in the Events on HP SIM and thus I do not get emailed about it.
>>> to test communication between other 15 and HP SIM, web into one of 15 agents at https://server12:2381, settings, SNMP Settings, Agents, click Send Test Trap
Go to HP SIM, click on All Events, you should see a "Generic cpqhost trap"


Help Please...
Dzmitryj Jakavuk
Super Advisor

Re: Help needed Configuring HP SIM

As I can see you can get only messages like "Server is unreachable". Make sure you have checked all the settings the colleagues wrote in previous post.
Also make sure than network equipment allows SNMP traffic in both directions from CMS to server udp/161 and from server to CMS udp/162

Best Regards
DavidinLongford
Occasional Visitor

Re: Help needed Configuring HP SIM

Guys,

Thanks for the suggestions so far but it still not working the way I need it.

I made all the changes suggested and checked ports 161/udp and ports 162/udp, and then tried sending the Generic Test Trap. Unfortunately no events were recorded on the HP SIM server and I did not receive the email notification.

So, I grabbed an old Dell PC that was lying around here and installed HP SIM 5.3 on it and low and behold it starts recording the Events and I start getting the email alerts.

At least this proves that the servers are now configured correctly, it has to be some issue on the server that I have HP SIM installed. I can't keep using the old Dell PC because it is on its last legs, and I would prefer to get this working on the server we have assigned to it.

Thanks again for any help.
Dzmitryj Jakavuk
Super Advisor

Re: Help needed Configuring HP SIM

try to figure out if the SNMP service is up and running on your server.
Try to use sniffer on the server where you generate trap and on the server that should recieve trap
DavidinLongford
Occasional Visitor

Re: Help needed Configuring HP SIM

It's fixed.
On each server, I went into the System Management Homepage, and then to Settings and then to Select SMH Data Source and changed it from WBEM to SNMP.

Also, on our HP SIM server I ran the portqry command and it looked like it wasn't LISTENING . I then ran it a few times with different switches (I was just gathering information really) but after a while I noticed that port 161/UDP was LISTENING.

Next thing I noticed that it was working.

Thanks for your help
DavidinLongford
Occasional Visitor

Re: Help needed Configuring HP SIM

Please see my last post ;-)