Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

How to change the criticity of a PSP component ?

OlivierV
Trusted Contributor

How to change the criticity of a PSP component ?

Hello.
I have downloaded the PSP 7.51 in my VCR but now the servers send an alert about a critical update. In the case of the PSP 7.51, it is the SMH CP006486.EXE.
I don't consider this update as critical (no security issue) and I want to change it's status so the servers don't complain about it.
I did not find anything in the XML file.
I found in the MNF file a type_of_change paramater that changes the component criticity when I look at the component history but when I check the VCA on one server, this update is still in Orange.
Is it possible to change that and how ?
Thank you.
6 REPLIES

Re: How to change the criticity of a PSP component ?

I haven't seen a way to change that level as you are suggesting.

However, I would ask what version of the SMH the server that is generating the alert is currently running.

You are right that CP006489.EXE doesn't contain any new security fixes. However the two previous versions to that did include security updates. The second one prior (2.1.4.143 released as CP005763.EXE) addressed a long laundry list of candidates for common vulnerabilities and exposures.

I've had a couple servers that were several versions out of date send the alert about critical updates you are describing. Some of my servers sent alerts related to a particular package while others didn't (and none had the latest version yet). I was never able to verify 100%, however for the servers that were sending the alerts one of the previous updates they hadn't received yet did include a critical fix (in my case data loss related stability fix). It could have been coincedence that only those servers sent the pages, yet it seems like a solid correlation when I looked at the differences between the servers. So you might want to look at that.
OlivierV
Trusted Contributor

Re: How to change the criticity of a PSP component ?

All the servers having the VCA enabled have sent the alert. They are using PSP 7.10 to 7.40.
The XML and MNF files contain a tag named type_of_change that seems to act on this parameter.
I keep on searching.

Thanks

Re: How to change the criticity of a PSP component ?

If all of the servers giving the alert are running PSP7.4 or older, and you have not updated the System Management Homepage to a version newer then what was included in PSP7.4, then they are running versions of the System Management Homepage 2.1.2.127 and older.

In that case CP006489.EXE *IS* a critical update for those servers. Look at the version history for the System Management Homepage. There are several security fixes between 2.1.2.127 and the version included in CP006489.

So even if you do figure out how to change it, you should reconsider your stance that CP006489.EXE is not a critical update for you.
OlivierV
Trusted Contributor

Re: How to change the criticity of a PSP component ?

Hello Robert.

You are right, the 6489 contains a critical update. But it is not the ..146 version, the fixes are in the 143. The documentation you have when clicking on the component in the VCA shows the 146 version with a critical flag, not the 143.

Anyway, I had a deeper look in the VCR and this is how I think it works :
The .EXE (cp006489.EXE in that case) is a compressed file containing a XML file with the criticity of the versions (type_of_change flag, value = 2 means critical, 0 is ehancement)
When the VCR builds the catalog, it creates a MNF file for each component which is in fact a copy of the XML file. It contains also the type_of_change flag.
The catalog is in c:\hp\hpsmh\data\cgi-bin\vcrepository and named cpqsrcatalog.xml. It contains also the flag.

I changed the flag from 2 to 1 in both files but no change for the moment. I suppose that I must wait for the Software polling task to run before to see a change.

However, if I change the flag value in the MNF file, then go to a VCA and click on the link to the description of the component, the icons of the version are changed accordingly.

Regards.


Rich Purvis
Honored Contributor

Re: How to change the criticity of a PSP component ?

CP006486.EXE is considered to have a critical update in that it fixes an issue that prevented adding groups with domain identifiers during install. This was a loss of functionality and caused customers that needed to do fresh installs of SMH using groups and their domains to have issues during install. As such this was marked as a critical update. The problem with this is that people that already have SMH installed and properly configured will not see this as an issue because updates deployed as default installs do not change existing settings of the SMH, thus don't need to try and configure groups with domains. It is unfortunate that this is causing a problem for you. I believe this release was marked as a "b" release of the previous version. As such Version Control does not check against the "b" revision and the rest of the version is the same as the previous release.

You can get past the issue for now, if you like, by removing the SMH from the baseline comparison. The problem with this is that you will no longer see a status based on the SMH versions. If you decide to deploy a later version (future release) of SMH and set it to the new baseline this should go away.

-Rich
Why does my tivo keep recording Nickelodeon?
Rich Purvis
Honored Contributor

Re: How to change the criticity of a PSP component ?

Sorry, I meant to say CP006489.EXE. Good luck, I hope you get a usable work around for your issue.

-Rich
Why does my tivo keep recording Nickelodeon?