Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

How to disable "link up" events?

SOLVED
Go to solution
NJK-Work
Honored Contributor

How to disable "link up" events?

I am getting hundreds of link up events in HP SIM 7.1.  According to the event message, it is RFC1215.  However, this MIB is not available in the list of SNMP traps.  There is an RFC-1215 but it is completely blank.  In fact, all of the RFCx MIBs are blank.  I can't change any of them.  So I guess my real problem is how do I fix the blank MIBs in SIM so that I can turn off these events.

 

Also, is there a way in SIM to prevent it form un-disabling all the noisely SNMP traps that I spent hours disabling everytime I install a SIM patch?  I had over 50000 events in one day after installing the latest patch bundle yesterday. 99% of them were informational SNMP traps for Authentication Error, RAID controller something or another, Link Up, etc.  I mean really - 50000 events...seriously?

 

Nelson

11 REPLIES
Tushar Bajpai
Trusted Contributor

Re: How to disable "link up" events?

Use SNMP Trap Setings to disable the trap.

Option -> Events -> SNMP Trap Settings
if it helped, award me Kudos or Points. Thanks :)

\T Bajpai
HP Employee

NJK-Work
Honored Contributor

Re: How to disable "link up" events?

That does not work because all the RFC MIBS are blank in SIM.  See image below.

 

NoMIBs.png

Tushar Bajpai
Trusted Contributor

Re: How to disable "link up" events?

Yes, that is part of IF-MIB.mib.

if it helped, award me Kudos or Points. Thanks :)

\T Bajpai
HP Employee

NJK-Work
Honored Contributor

Re: How to disable "link up" events?

IF-MIB is blank too.  I cannot see anything in it.

 

Nelson

Tushar Bajpai
Trusted Contributor

Re: How to disable "link up" events?

Can you check in the Trap Details to which mib the linkUp trap is getting mapped, use that name and disable the trap.

if it helped, award me Kudos or Points. Thanks :)

\T Bajpai
HP Employee

NJK-Work
Honored Contributor

Re: How to disable "link up" events?

The MIB name from the event is "RFC1215".  When I go to edit the settings of that MIB in SIM, I cannot.  The MIB is blank - there is no data in it.

Tushar Bajpai
Trusted Contributor
Solution

Re: How to disable "link up" events?

unregister 2 mib: rfc-1215 and if-mib and register them back. Looks like there is some issue. I have checked the same in my setup it is working fine.

 

mxmib -d mib-name and add using mxmib -a cfg-name. Hope this will / should resolve the issue.

if it helped, award me Kudos or Points. Thanks :)

\T Bajpai
HP Employee

NJK-Work
Honored Contributor

Re: How to disable "link up" events?

OK - that sort of worked.  There is no -r option in the version I am using (7.1).  But I was able to re-register (-a option) the IF-MIB mib.  But the RFC-1215 MIB still is blank.  It says it registered successfully, but when I open in SIM, there is no data.  The IF mib shows data now - so I am not sure why one works and not the other.

 

mxmib -r rfc-1215.mib

The following is an invalid argument value: rfc-1215.mib
Usage:
       mxmib -a <mymib.cfg>
       mxmib -f <cfglist.list>
       mxmib -l
       mxmib -t <mymib.mib>
       mxmib -d <mymib.mib>

 

mxmib -a rfc-1215.cfg

IMPORTING CFG  rfc-1215.cfg
COMMAND COMPLETED SUCCESSFULLY

NJK-Work
Honored Contributor

Re: How to disable "link up" events?

I think I solved my problem - but I still don't understand why it is failing in the first place.  I used the -d option to remove the RFC-1215 MIB (the previous suggestion of using -r was wrong; that option does not exist).  When I tried to add the RFC-1215 MIB back in, it told me everything in that MIB was redundant.

 

mxmib -a rfc-1215.cfg

IMPORTING CFG  rfc-1215.cfg
Trap: authenticationFailure is redundant.
Trap: coldStart is redundant.
Trap: egpNeighborLoss is redundant.
Trap: warmStart is redundant.
Trap: linkDown is redundant.
Trap: linkUp is redundant.

Please delete the old MIB and then add the current MIB.

COMMAND COMPLETED SUCCESSFULLY

 

So - I just deleted the MIB again because I am assuming I don't need it anyways and all it is doing is generating a bunch of meaningless alerts.

Tushar Bajpai
Trusted Contributor

Re: How to disable "link up" events?

It was a typo -r from my side. "Trap: warmStart is redundant " msg here means that this trap is registered with some other mib. But it will be good to know with which one.
if it helped, award me Kudos or Points. Thanks :)

\T Bajpai
HP Employee

NJK-Work
Honored Contributor

Re: How to disable "link up" events?

Yes - there is something still wrong.  Even though I removed that MIB from the system, I am still getting alerts referencing it:

 

Mib Information
The associated MIB File Name for this trap is rfc1215.mib and the MIB identifier RFC1215-MIB

 

So how do I find what the correct MIB is that is causing these alerts?  It can't be RFC1215, because I deleted it.  Yet they still appears but are incorrectly mentioning that MIB.

 

Nelson