HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Install a PSP onto an ESX server?

 
SOLVED
Go to solution

Install a PSP onto an ESX server?

I have an ML570 with VMware ESX server installed. I have installed the Insight Manager agents on the server and my CMS console is able to see the Health Status and Management Processor status. However, the Software Status and Virtual Machine Management Status have the 'i' icon.

I've registered the VM ESX host, and the license manager is showing that it has a VMM license key, however when I go to VM Host Performance Tab, it says that the server has not been licensed.

I did not install any PSP's or Essentials software from the HP disk. Am I supposed to install a Support Pack, and if so, which version?
15 REPLIES
Rob Buxton
Honored Contributor
Solution

Re: Install a PSP onto an ESX server?

On the ESX Host you install the Agents, there's no PSP as such.

See the VMM Installation guide, you also need to deploy the VMM Agent which is different from the Management Agents.

http://h20000.www2.hp.com/bizsupport/TechSupport/DocumentIndex.jsp?contentType=SupportManual〈=en&cc=us&docIndexId=179111&taskId=101&prodTypeId=18964&prodSeriesId=1113762

I see you no longer need SSH as there's a new guide for that. It was previously a requirement.

Re: Install a PSP onto an ESX server?

Thanks for the help.

The VMM Agent 2.0 installed succesfully on the ESX box. However, I'm still running into this licensing problem. When I go to register the VM Host, it tells me it is already registered. So I go to the VM Performance tab of the host and it shows that 'the virtual machine has not been licensed'. Okay, then I run the license key manager. And it tells me that 0 of 5 Virtual Management seats are used, but when I select my ESX server, it replies that the 'key already present at this system'.

I've also run a Data Collection and Identify System since the install of the Agent.
Rob Buxton
Honored Contributor

Re: Install a PSP onto an ESX server?

From memory you need to go to the Deploy -> License Manager -> Deploy Keys.
Highlight the VM Host Server first. Thn highlight the key to deploy.

The VMM Registration just makes the Server visible to VMM, it's not the actual license process

Re: Install a PSP onto an ESX server?

It doesn't matter if I highlight the server first, then go to deploy. Or if I go to Deploy and then highlight the server then the key. Same problem. Attached is the screenshot of the output per your suggestion.
Rob Buxton
Honored Contributor

Re: Install a PSP onto an ESX server?

Andrew,
Did you install with SSH or have you gone for the non-ssh option?
Not sure if there's an issue there. I've only installed it with SSH, so whether there's some kind of conenctivity issue I'm not sure.

Also, you can check the status of the vmm agent on the ESX Server:
/etc/rc.d/init.d/hpvmmcntsvc status

You can you the same script to restart the service.
You may want to verify SNMP, there's a few things that rely on this being correct in order to communicate (PMP being one). But I'd be surprised if it was there.

If you click on the HW icon for the Server, do you get right in?

The other thing I have for my ESX Servers is they're set to use System specific properties not the global for access. So I have the root and its password in the WBEM settings for my ESX Servers.

But, I can't think of anything else you've missed. It seems to be some kind of communication issue, which makes me wonder about SSH.

Re: Install a PSP onto an ESX server?

Thanks for the suggestions Rob, but the VMM still isn't working.

It seems the vmm agent, "is running..." according to the command you gave me to type in.

When I click on the green checked HS box or HWStatus icon, I go straight to the System Management Homepage. No errors are showing anywhere, hardware or otherwise.

I ran a Configure or Repair agents task with the following settings:

- Configure SNMP, set read community string (to my read community), set traps to HP SIM
- Trust relationship Set to "Trust by Certificate (which is how all of my other systems are set)
- Configure secure shell SSH access: root, host based authentication
- Create subscriptions for WBEM events

The following are the results:

--------------------------------------------------------------------------------
Server:servername
Status: Minor
Details:
Successfully configured SSH for host based authentication
Failed to create indication subscription
--------------------------------------------------------------------------------
--------------------------------------------------------------------------------
Report Summary
--------------------------------------------------------------------------------
Total: 1
Normal: 0
Minor: 1
Major: 0
--------------------------------------------------------------------------------
Task ID of task configuring Linux systems: 20265
Rob Buxton
Honored Contributor

Re: Install a PSP onto an ESX server?

Have you run the mxagentconfig command for this Server?

You run it from the SIM Server.

Re: Install a PSP onto an ESX server?

Thanks again Rob for the suggestion, but I'm afraid that didn't work either.

I ran 'mxagentconfig -a -n -
u -p ' from my SIM server and I received back 'Successfully registered as an agent to: .'.

I then ran a Data Collection and Identify System on the VMware ESX box, but I still have the 'i' icon under VM and when I go to the System Page, under Virtual Machines I still see, "VM host has not been licensed. For more information about licensing refer to Virtualization Management Software User Guide."

Once again, if I try to deploy the VMM license, it tells me the server already has the license.
Rob Buxton
Honored Contributor

Re: Install a PSP onto an ESX server?

Andrew, I'm out of suggestions really.
The only other time I've seen similar was when I was using the temporary license. I then realised the date was wrong on the ESX Server, moved it forward and it took me longer than it should to figure out why it had expired!
You get a situation there where it says it's licensed but the license is inactive. But I seem to recall it was quite clear that it had expired.

Re: Install a PSP onto an ESX server?

Here is a screenshot from the command watch ntpq -p.

I'm not sure how to read it, but it looks like the offset is less than one second. If that is correct, I don't think it is a time issue. I've run through VMware's 'Installing and Configuring NTP on VMware' and the server seems to be talking to my NTP server.

I appreciate all of your help Rob, but I might just need to get it over with and open a trouble ticket!?
Rob Buxton
Honored Contributor

Re: Install a PSP onto an ESX server?

Yep, I agree, opening a call is the only way to go.
Are you on VMM 2.0.1 or still on 2.0?

As a final shot you can try pulling down VMM 2.0.1 and installing that.
You'll need to remove VMM 2.0 first.
See:
http://h18004.www1.hp.com/products/servers/proliantessentials/valuepack/vms/downloads.html
Phillip Brown
Frequent Advisor

Re: Install a PSP onto an ESX server?

You might try the Configure or Repair Agents option to setup the proper SNMP and trust relationships.

More detail here:

http://h10018.www1.hp.com/wwsolutions/misc/hpsim-helpfiles/repairAgents_5.pdf

Go down to Overview and the "Configure or Repair Agents" section.

Re: Install a PSP onto an ESX server?

I've contacted HP Support, and so far, they've been unable to resolve this problem. I'm not sure what is specific to anything that I have going on that not even HP Support can figure out what is wrong.

I was looking forward to using the VM Management tools. Too bad for me and HP (I obviously won't be purchasing any licenses).

Re: Install a PSP onto an ESX server?

Finally!!!!

After getting this all the way up to Software Escalation, it was as simple as running a Software Status Polling. Next thing I new, my VM host was licensed and registered and all of my guests started showing up.

Re: Install a PSP onto an ESX server?

See above...