HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Insufficient Rights to Database for Use SQL/MSDE installation

 
afointWPI
Frequent Advisor

Insufficient Rights to Database for Use SQL/MSDE installation

During install of HP SIM 5.0 SP5, we receive this error on the database configuration page.
The host specified is a SQL server 2005 SP1, and the account I am using is a domain admin for which the SQL server is a member of. The database name of SIM was created within SQL.
Any ideas, or other things to check?
5 REPLIES
Joel Rubenstein
Honored Contributor

Re: Insufficient Rights to Database for Use SQL/MSDE installation

Check the server role for the domain account you are trying to use. It should be either database creator or system administrator. Also check that the default database for that user is master.
Matthew Hoffman
Occasional Advisor

Re: Insufficient Rights to Database for Use SQL/MSDE installation

This is driving me nutz!

I am installing SIMv5 on my XP workstation. I have installed a new MSDE database on my system per the HP SIM install. I created a database named "SIMv5" on my MSDE instance and I want to use THAT database instead of 'master' because I want to seperate my database files from my OS. I have tried every possible permutation of permissions on my MSDE database and still am recieving, "Insufficient rights to database."

What is driving me nuts is that I can delete all references and permissions to my user account in MSDE and still I have access to 'master'. I don't understand how I can have access to a database I have no permissions to, and a database I create I with DBOwner permissions and 'System Administrators' server role I am denied access (in the SIMv5 installation)

My thought here is that perhaps the installer is hard coded to use 'master' if the MSDE installation is on the local computer. If that's true, I want HP to rewrite their code. This won't be the first time I've ran into an app that defaults to 'master' when installing MSDE on the local computer.

Please advise.

Joel Rubenstein
Honored Contributor

Re: Insufficient Rights to Database for Use SQL/MSDE installation

You do not create the SIM database prior to running the installer. The SIM installer will create a database during the install named insight_v5_0_xxxxxx where xxxxxx is a time stamp. You can not specify the name of the SIM database. During the install you must specify the database name as master. The installer will not actually create any tables in the master database.
Michael Harszlak
Occasional Visitor

Re: Insufficient Rights to Database for Use SQL/MSDE installation

Check the setting for "Data Execution Prevention" - it's under My Computer properties - Advanced Tab - Performance options - last tab - try selecting the first option for essential Windows Programs and services only - instead of the second option. This only applies to 64bit processors - but it worked for me on getting past this error on my server. You have to reboot for the change to be effective though. Good luck!
Matthew Hoffman
Occasional Advisor

Re: Insufficient Rights to Database for Use SQL/MSDE installation

Thank you both for adding this information. I was hoping to have more control over the database location/setup, but I can deal with the defaults if I have to.

Regards, Matthew