HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Issue with CIM_ERR_INVALID_NAMESPACE

 
HP_Storage_Team
Occasional Contributor

Issue with CIM_ERR_INVALID_NAMESPACE

Hello,

 

I tried to discover the EVAs by HP SMI, but I received an error: CIM_ERR_INVALID_NAMESPACE:

 

#########################

C:\Program Files (x86)\Hewlett-Packard\SMI-S\EVAProvider\bin>discoverer.bat

===========================WELCOME TO THE DISCOVERER==========================

Enter the SMIS host [default: http://localhost:5988] :
Enter the SMIS username :SANadmin
Enter the SMIS password :

Connecting to EVA SMIS in http://localhost... Please wait....


ERROR: Received CIM_ERR_INVALID_NAMESPACE... CIMOM maynot have loaded the provider namespace root/eva... Please try after some time



C:\Program Files (x86)\Hewlett-Packard\SMI-S\EVAProvider\bin>

#########################

 

I started wbemdisco and after that restarted the services HP CIM Object Manager and HP SIM, but without success.

I also tried without restart, but the result was same. 

 

Here is the wbemdisco's output:

#########################

C:\Program Files\HP\Systems Insight Manager>wbemdisco

C:\Program Files\HP\Systems Insight Manager>echo Mon 12/10/2012 13:43:32.75
Mon 12/10/2012 13:43:32.75

C:\Program Files\HP\Systems Insight Manager>echo off
WbemDisco 01.01.00
------------------
Gui: Gui starting
Gui: Creating frame...
HOST = localhost
PORT = 5989
NAMESP = interop
USER = SANadmin
PASSWD = *****
Connect to localhost in namespace interop with SSL=true

ObjectManager.Name=HP:CxwsCimom_10.250.32.42
ElementName=HP Cxws Server
CimomVersion=<missing>
Description=HP Cxws Server

Enumerating instances of CIM_RegisteredProfile...

Profile.RegisteredName=Server
RegisteredVersion=1.5.0
ProviderVersion=<missing>
SubProfile.RegisteredName=Profile Registration
Profile.RegisteredName=SMI-S
RegisteredVersion=1.3.0
ProviderVersion=<missing>
Profile.RegisteredName=SMI-S
RegisteredVersion=1.4.0
ProviderVersion=<missing>
Profile.RegisteredName=SMI-S
RegisteredVersion=1.5.0
ProviderVersion=<missing>

C:\Program Files\HP\Systems Insight Manager>

#########################

 

And the wbemport list:

 

#########################

<?xml version="1.0" encoding="UTF-8"?>
<wbemportlist>
<port id="5989" protocol="https">
<cimnamespacelist>
<cimnamespace name="root/cimv2"/>
<cimnamespace name="vmware/esxv2"/>
<cimnamespace name="root/hpq"/>
</cimnamespacelist>
<interopnamespacelist>
<interopnamespace name="interop"/>
<interopnamespace name="root/pg_interop"/>
<interopnamespace name="root"/>
<interopnamespace name="root/emulex"/>
<interopnamespace name="root/qlogic"/>
<interopnamespace name="root/ibm"/>
<interopnamespace name="root/emc"/>
<interopnamespace name="root/smis/current"/>
<interopnamespace name="root/hitachi/dm51"/>
<interopnamespace name="root/interop"/>
<interopnamespace name="root/switch"/>
<interopnamespace name="root/cimv2"/>
</interopnamespacelist>
</port>
</wbemportlist>

#########################

 

Could you please advise me where can be the reason for this error?

 

Thank you in advance.

3 REPLIES
Tushar Bajpai
Trusted Contributor

Re: Issue with CIM_ERR_INVALID_NAMESPACE

Try changing URL: http://localhost:5988 to https://localhost:5989

 

interop is correct.

if it helped, award me Kudos or Points. Thanks :)

\T Bajpai
HP Employee

HP_Storage_Team
Occasional Contributor

Re: Issue with CIM_ERR_INVALID_NAMESPACE

Hello Tushar,

 

Thank you for your help, but the result was the same.

 

Do you have any other ideas?

 

Thank you in advance.

BPE
Esteemed Contributor

Re: Issue with CIM_ERR_INVALID_NAMESPACE

Your output looks like your SANadmin has no rights to read the Storage information or the CIMMON Storage provider has a problem.  Try to login with SANadmin inside  CommandView to see that your account is able to access the storage information.  If you can see the storage inside CV EVA  you should check the log of the SMI-S provider  or the cimmon log to get a hint what's the real problem could be. If you changed once the IP address of the cv eva server this could be also a reason.