Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

New HPSIM install fails... error with DB??

SOLVED
Go to solution

New HPSIM install fails... error with DB??

Hi there

I am trying to install HPSIM on a different server, but when I do so the installation fails with the following detail in the c:\Program Files\hp\Systems Insight Manager\logs\initconfig.log

7. Database Configuration
Connecting to database...
Database initialization failed for URL: jdbc:jtds:sqlserver://EM1:1433/Insight_v50_0_164521976;domain=CORPORATE;instance= Ex: java.sql.SQLException: Cannot open database requested in login 'Insight_v50_0_164521976'. Login fails.



Creating database 'Insight_v50_0_164521976'...
Creating schema 'schema40.sql' ...

Can someone please assist to determine what the cause of this failure may be? I have verified my Admin rights on the server, as well as within SQL. The actual Insight database is created just fine, so I cannot understand why the above errors occurred.

After the above errors, I then get a lot of warnings such as:
*** WARNING: FAILED the following SQL command:
====
CREATE index notice_st_dev_sv_index on notices(State, deviceKey, noticeseverity)
====
java.sql.SQLException: Column name 'deviceKey' does not exist in the target table.

Any help to try and clear this problem would be appreciated,
Regards
William R.
3 REPLIES
Joel Rubenstein
Honored Contributor
Solution

Re: New HPSIM install fails... error with DB??

You will get those errors if you install SQL with a non default collation sequence. I would suggest creating a new SQL instance with the default collation sequence and installing SIM into that new instance.

Re: New HPSIM install fails... error with DB??

Brilliant Joel, absolutely brilliant!!!!

Now that you mention it, this is coincidentally the only SQL Server I have that has to have a different SQL Collation for another application I run...

I will try to install to another SQL Server and see how that goes.

Thanks again!!

Cheers
William R.

Re: New HPSIM install fails... error with DB??

Problem related to SQL Collation which was "non-standard" on my HP SIM Server. Installed HP SIM with SQL on alternative server, problem solved.