Online Expert Day - HPE Data Storage - Live Now
April 24/25 - Online Expert Day - HPE Data Storage - Live Now
Read more
Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

New installation HPSIM 7.3 on Windows 2012

bouma09
Frequent Visitor

New installation HPSIM 7.3 on Windows 2012

Hello,

 

I got a new VM Windows 2012 with HPSIM 7.3. I make a discovery on my lab and see my server HP or IBM but all of them is unmanaged. I have try to remotely install "OpenSSH" on my HP to with deploy menu, but it's still on 0%.

 

Some in my log i see an error with SSH Google say try this command :

ssh-keygen -t ecdsa -f /etc/ssh_host_ecdsa_key -N ""

 

But after reboot still no progress on the new install for OpenSSH still on 0%.

 

I think install OpenSSH remotely on my HP server is the first to get model serial number and everything else.

 

Thanx for any help

9 REPLIES
Andrew_Haak
Honored Contributor

Re: New installation HPSIM 7.3 on Windows 2012

Hello there,

 

If you want to discover a system you need snmp credentials on a unix server. You need snmp or wbem credentials on an ESX servef depending on the version.

 

On Windows servers you need either SNMP or WBRM credentials. If you open the System Managrment Homepage, do you see any information regarding sydtrm model etc.. ?

Kind regards,

Andrew
bouma09
Frequent Visitor

Re: New installation HPSIM 7.3 on Windows 2012

Hi Andrew,

 

I have enter my credentials for WBEM protocol, but when i try Configure or repair Agents i got a fail with this message :

 

Configuring SSH authentication (START)...
SSH is not installed on the target server. In order to install SSH, use a web br
owser to browse to HP Systems Insight Manager, select Deploy from the menu, sele
ct Install OpenSSH, and follow instructions."

 

This is why i try to install OpenSSH before the agent, my HP server are older G5 model i think an agent is necessary to see model, serial number and other information. Right now for my HP Server on "Product Description" section on System Type line i have Unmanaged and that all, no other information.

 

 

 

Andrew_Haak
Honored Contributor

Re: New installation HPSIM 7.3 on Windows 2012

Hello again,

 

You don't need open ssh for system information, look at the https://servername:2381 and make a screenshot of the page once you hase loged in with admin rights. You should see the model. If the page also shown unknown, the managrment agents are not running or the credentials for SNMP or WBEM are incorrect. So if you coild attach a screenshot of the logged-in System Managed Homepage and a complete log of the identify of a server wich is an unknown type.

 

That would realy help.

Kind regards,

Andrew
bouma09
Frequent Visitor

Re: New installation HPSIM 7.3 on Windows 2012

Hello Again,

 

Sorry for the late come back vacantion and other trouble reach me. A make some modfication on my system and rebuild on Windows 2008 R2. But still got same issue here is the Full log is on attachement.

 


 

 

 

And the screenshoot

 

hpsim error.JPG

Andrew_Haak
Honored Contributor

Re: New installation HPSIM 7.3 on Windows 2012

Hello again,

 

it seems you don't have snmp or wbem configured on the SIM server and/or on the system(s) you want to discover.

 

Do you have a user configured in SIM wich is admin on the server(s) you to discover?

if you need more help in configuring the credentials or any other question. Let me know.

Kind regards,

Andrew
bouma09
Frequent Visitor

Re: New installation HPSIM 7.3 on Windows 2012

Hello,

 

I know it's sound like an unconfigure SNMP, but on my discovery server i got the functionnaly SNMP freshly installed. I install the HP SmartStart on my discovery server. I also configure my credential account in HPSIM with my personal logon who got  an admin on the servers and HPSIM, i also try with a a generic account specialy create to use an admin account for this kind of job.

 

For WBEM except for my credential in HPSIM, does it take any prerequis on my discovery server to be unable to run and communicate ? My OS for the discovery server is a fresh install of Windows 2008 R2 with the lastest HP SmartStart CD install.

 

Do you know some HP tools to make a diagnostic between my two servers maybe a i could get an error more specific ?

 

Thanks for your time Andrew

Andrew_Haak
Honored Contributor

Re: New installation HPSIM 7.3 on Windows 2012

 Hello again,

 

Could you try to disable the Windows firewall, perhaps that's what's blocking the scan.

 

Wbem only needs an user with admin right, that is if you have a wbem agent installed. snmp is easier to configure.

This can be done by hand or run a repair a repair for the server selected.

Kind regards,

Andrew
jim goodman
Trusted Contributor

Re: New installation HPSIM 7.3 on Windows 2012

I agree it's either a blocked identification protocol (typically firewall) or mis-configured agent if you are using HP Management Agents.

 

If you run a Identify Systems task and watch the output you'll see if it is detecting any of the management conventions. That may help narrow it down.

 

Any detected protocols will be displayed in Management Protocols... SNMP is the only one that requires proper 2-way communication in Windows to be discovered. Community strings in SIM and the target managed node need to match and you need to add the CMS ip address to accept packets from or set accept packets from any host (not recommended but good for testing) in the security tab of SNMP.

 

 

discov_proto.JPG

 

bouma09
Frequent Visitor

Re: New installation HPSIM 7.3 on Windows 2012

Hi Jim,

 

My firewall are disable on both servers. But you give a clue with your SNMP 2 ways, we have create a Community strings named hpsimlab, i remember in my firts initial test i was keep public by default. When i set the Community strings to public my "Identify sysyem" Pass! After that everthing seen to be normal.

 

Now my task is to get through a another domain, I think i'll have to talk a lot with the network guy in my organization.

 

Thanks a lot for your help guys.