Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

PMP 4.0 in SIM 5.0 Service Starts then Stops

Todd Schelin
Valued Contributor

PMP 4.0 in SIM 5.0 Service Starts then Stops

I am running SIM 5.0 and have PMP 4.0 installed as well as part of the SIM 5.0 install. The PMP service starts then immediately stops. Has anyone seen this issue? Additionally, is there a way I can log what is happening when PMP starts?
Specific error is below.
The HP Performance Management Pack service terminated unexpectedly.
22 REPLIES
Rob Buxton
Honored Contributor

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

I don't know of any additional logs that will help.
Check the PMP Database is accessible.

Has it ever worked?
You might want to check the hppmp.log file in C: on the HPSIM Server.
Todd Schelin
Valued Contributor

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

Yes it was working after it was installed.

Here are contents of hppmplog:

Starting HP Performance Management Pack Installation...
Is earlier versions of PMP found? No
Is the Operating System and Service Pack Valid? Yes
Is the screen resolution valid? Yes
Is HP SIM installed? Yes
Is PMP 4.0 already installed? No
Successfully retrieved HP SIM installation path.
Is Disk space sufficient for PMP installation? Yes
Applying PMP schema to the database.
Performing initial database population
Creating PMP Services
Stopping HP SIM service to update GlobalSettings.props file to integrate PF Column
Initializing and configuring menu structure
Updating GlobalSettings.props file...
Starting HP SIM service...
Starting PMP service...
Starting PMP Tools service...
Successfully installed PMP.
Edward Latzko_1
Occasional Advisor

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

Did you receive an error simular to this when starting the server "193 0cx1"? I had the same issue with my install. The resolution is this go to regedit and enclose the PathImage key in Double Quotes. The keys are as follows:

servername\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HP Performance Management Pack\
Edit the "ImagePath" key and add the double quotes at the begining and end of the path. e.g. "C:\Program Files\HP\Performance Management Pack 4\pmp.exe"

servername\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HP PMP Tools\
Edit the "ImagePath" key and add the double quotes at the begining and end of the path. e.g. "C:\Program Files\HP\Performance Management Pack 4\PMPTools\pmptools.exe"

The services will now start. It seems the path statement sometimes doesn't like spaces in the path. Hope this helps....
Todd Schelin
Valued Contributor

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

Thanks for the feedback on this Edward. I did as you describe and still the service will not start.

I uninstalled and re-installed PMP and still have the same problem. Is there anyway to capture what the service is doing when it is trying to start?
FrankW
Frequent Advisor

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

Todd did you have any further luck with this issue? I have the same problem, same messages, and have tried the same things to resolve it as you have, still no luck.
Todd Schelin
Valued Contributor

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

Frank, I am still having issues with PMP the services starts and now I am getting a proxy error. It is not very stable and have been getting frustrated with it.
Rob Buxton
Honored Contributor

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

I was having problems with the PMP Service stopping after an update to the SQL Server backend (upgraded to SQL 2000 SP4).

You can get more info by creating a file pmplog.txt in the PMP Installation directory and then restarting PMP.

A suggestion by HP was to update my PSP on the HPSIM / PMP Server, as we were at the latest level all that was left was to update the HP SMH to the latest version. Once done , the PMP Service started okay.
Todd Schelin
Valued Contributor

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

I updated my server with the latest SupportPaq and am still having the same issue.

The problem I have is that the service is starting now, but after I launch PMP for Admin or Licensing it hangs and I cannot access any of the server performance analysis information. The service is running, but isn't doing much.
Todd Schelin
Valued Contributor

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

This is the error I get now. Anyone know or seen this error, when trying to use PMP?
Rob Buxton
Honored Contributor

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

Has the Server been rebooted since the PSP update?

Try stopping PMP and then restarting SNMP and all the dependent services and then restarting PMP.
It takes a while for PMP to come back on line after restarting the services.
FrankW
Frequent Advisor

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

That error message (Proxy) is the same one that I get, and it appears when the PMP service is not running. I have applied the latest support pack, then the latest SMH on top of that. I even went to the trouble of deleting HP SIM 5SP4, and re-installing it from scratch. I have rebooted the server more than once. I still have the same problem where PMP service starts, then stops. I still have the same error message in the PMP.log. This thing is not worth the money we paid for it.
Todd Schelin
Valued Contributor

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

I have rebooted the server and have waited a couple of days since the SupportPaq and still get the error.

The service shows as running when I get the error, however, when I stop and restart it I get to go to the licensing page once, but if I select anything else in the PMP admin or licensing areas, then the error shows up.

I agree with you Frank I have tried all the recommended updates and fixes and still have had no luck.
pkrai
Trusted Contributor

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

You can log the information from PMP service. You just have to create an empty pmplog.txt in PMP installation path, that'll be populated by PMP.

Thanks,
Pravesh
blackhawk_1
Advisor

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

Hey todd..any luck on the issue ?

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

I had the same problem today, before PMP work very well 3 month. So, i'm manually purge log, set delete records older than 7 days and when job is complete it start work normaly. I'm also note that PMP DB space was used 100%, autoincremental was set.

try my solution.
dr.hubato
Occasional Visitor

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

Hi,

We just npticed on our 2003 Server SQL Database on the backend, that it is running pmpservice.exe at atleast 50% cpu usage. It has been running like this for a week now and we dont know what it is.

It says it is associated with Intel Server Management. Another process that is running is pmapservice.exe - I have been un-seccessful in finding out what their purpose is.

ANY information will help me and my team.

Thank You!
dr.hubato
Occasional Visitor

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

Can I shut off PMPService.exe? will it effect anything?
JarekM
Occasional Advisor

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

We are running the latest software:
Version: Systems Insight Manager 5.1 with SP1 - Windows
Build version: C.05.01.00.02
Build date: 2007-04-11 17:26
HP Performance Management Pack 4.4

And experience exactly the same errors.
"The HP Performance Management Pack" service crashes with - "The HP Performance Management Pack service terminated unexpectedly." when we try to access PMP information / page on monitored server which previously worked fine.
To fix you have to restart two services - "The HP Performance Management Pack" and "HP PMP Tools" which gets things going but not for long.
After restart monitored server status is reported as "Unreachable Licensed Servers : 25" and their "monitoring status" is "blank" instead of "Started"


We found PMP software the most troublesome component of HP SIM platform. Although it can be very useful in server performance tuning / bottleneck finding it cases to much troubles since we started using it over a year ago.

Jarek
Todd Schelin
Valued Contributor

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

Jarek,
I have to agree PMP is the most troublesome service in HP SIM. I have the service running etc. and it doesn't stop immediately like it did before. However, I currently have a case open with HP now regarding not being able to see licensed systems in PMP. I am currently running HP SIM 5.1 SP1 and PMP 4.4. As with you I do use it for trouble-shooting and monitoring troublesome servers.
JarekM
Occasional Advisor

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

in HP SIM console, click on the icon "Question mark" in column PF, next to server which is licensed and should be running PMP,
Click on Admin button on the PMP "Unknown Performance Status"
On page PMP "Monitoring Administration" select server where monitoring status is "blank", select desired PMP parameters and click Apply.
After that, server is back in PMP monitoring and its status for Monitoring will be equal to "started".
Notice that also that number of "Unreachable Licensed Servers" on PMP "Monitoring Administration" page is lower as well.


This procedure works for me, however after every time "HP PMP service" crashes, I had to reapte it on more then one server. This isn't acceptable when you have to do over 70 servers...
Lucas Banuelos
Occasional Contributor

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

hi Dmitri Manushin, how do you for purge the pmp logs in data base, thanks for you help. I have the same problem with pmp

LBA

Re: PMP 4.0 in SIM 5.0 Service Starts then Stops

choose options > Perfomance management pack options > manual log purge

delete data older than 30 days for all servers. Also, check how much free space do you have for PMP database on SQL server.