HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

PMP and 7.50 & 7.51 Agents

 
Rob Buxton
Honored Contributor

PMP and 7.50 & 7.51 Agents

Hi All,
Kind of a repost, and I'm looking to see if anyone else is seeing this.
Environment; HPSIM 5.0 SP4, PMP 4.0.2, HP Agents either 7.50 or 7.51.
When the agents get updated and the server reboots, PMP works okay, but in a number of cases we still have the Remote Lights Out Agent enabled. As we do not use LO this gives a Major Status. So we remove the remote Lights Out Agent and restart the agents.
PMP then will not start and just goes to critical.
All attempts to restart PMP,short of rebooting the target server fail. Including re-restarting the agents, stopping / starting PMP monitoring, rebooting the HPSIM Server.
This seems to have started happening after the 7.50 PSP release and remains with the 7.51 PSP release.
So has anyone seen this and even better, anyone solved it?
11 REPLIES
Rob Buxton
Honored Contributor

Re: PMP and 7.50 & 7.51 Agents

Updated to HPSIM 5.0 SP5 and PMP 4.1. After rebooting the HPSIM server, those servers that had a critical PMP status are still showing a critical status.

An it is consistently triggered when we remove the Remote Insight Agent and restart the agents.
The info. in the pmplog.txt file doesn't indicate much:

2006-06-23 14:25:28: sqldv1 - State changed from 0 to 5
2006-06-23 14:25:28: sqldv1 - Reschedule in 60 seconds
2006-06-23 14:25:28: sqldv1 - Critical Error
2006-06-23 14:25:28: sqldv1 sample failed

pkrai
Trusted Contributor

Re: PMP and 7.50 & 7.51 Agents

Hi Rob,

We've tried to reproduce the issue (by removing 'Remote Insight Information' agent from 'Active Agents' of 'HP Management Agents' in Control Panel) and found that PMP faced some initial problem in loading new configuration of the target server & show 'Critical' status, but status became 'Unknown' after some time. And finally we'd restarted the target server to make it 'Normal' again.

Can you provide some more statements, related to effected server, from your log file ?

Thanks
Rob Buxton
Honored Contributor

Re: PMP and 7.50 & 7.51 Agents

I would except things are going from bad to worse for PMP and HPSIM in general after the SP5 update.
HPSIM is now using around 500MB of memory, with PMP using 180MB!
I was going to use the PMP configuration screen to stop monitoring on a couple of servers, stop PMP, create a log file and then reverse the process.
The PMP Configuraton screen times out with an "Upstream Proxy" error, the PMP License screen fails with an HTTP 404.

When PMP was restarted the PMP Config page does come up, but it takes a significant amount of time (2 minutes plus).
I then tried to stop / restart PMP for two servers, again this took several minutes to achieve.
The log doesn't really say much, here's an extract for a couple of servers;

2006-06-26 11:47:25: sqldbdv1 - State changed from 0 to 5
2006-06-26 11:47:25: sqldbdv1 - Reschedule in 60 seconds
2006-06-26 11:47:25: sqldbdv1 - Critical Error
2006-06-26 11:47:25: sqldbdv1 sample failed
2006-06-26 11:47:26: sqldbpr1 - State changed from 0 to 5
2006-06-26 11:47:26: sqldbpr1 - Reschedule in 60 seconds
2006-06-26 11:47:26: sqldbpr1 - Critical Error
2006-06-26 11:47:26: sqldbpr1 sample failed
pkrai
Trusted Contributor

Re: PMP and 7.50 & 7.51 Agents

Hi Rob,

We'd faced the same problem & found that the restart of the target system is the only solution available, till now. Removing specific agent from the system, makes it unstable w.r.t Management Agent's operation.

Thanks.
pkrai
Trusted Contributor

Re: PMP and 7.50 & 7.51 Agents

Hi Rob,

We've also observed this behaviour of taking long time in Monitoring Administration Page & have fixed this in PMP 4.1.1, which will be available for web download after 6/29.

Thanks
Rob Buxton
Honored Contributor

Re: PMP and 7.50 & 7.51 Agents

Thanks, I'll keep an eye out for PMP 4.1.1.
Do you know if anyone is looking at why the agents are now so unstable as regards PMP.

Having to reboot a server because you've removed an agent is a tad excessive.
We typically remove the Remote Lights Agent as a large number of our servers in the local computer room don't have their ILO's connected and as such report a Major alert condition.
pkrai
Trusted Contributor

Re: PMP and 7.50 & 7.51 Agents

Found the problem with Agent 7.50. Have you tried 7.60, I think it has addressed various issues.
Rob Buxton
Honored Contributor

Re: PMP and 7.50 & 7.51 Agents

7.60!?! I've not yet finished implementing 7.51...
I cannot see 7.60 on the normal software / driver web pages. But I'll certainly keep an eye out for that as well.
But, nice to know something has been found.
Trung Hua
Occasional Advisor

Re: PMP and 7.50 & 7.51 Agents

I just experienced a similar issue and after updating to PMP 4.1.1 it appears to have resolved it.
Trung Hua
Occasional Advisor

Re: PMP and 7.50 & 7.51 Agents

I've just experienced a similar issue and after updating to PMP 4.1.1 it appears to have resolved it.
Rob Buxton
Honored Contributor

Re: PMP and 7.50 & 7.51 Agents

4.1.1. did not solve the problem here.

It seems you need to restart the Server that has the problem before the agent will work.