Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with upgrade from HPSIM5.3 to HPSIM5.3 uprade-1

 
Mark Sobolewski
Occasional Contributor

Problem with upgrade from HPSIM5.3 to HPSIM5.3 uprade-1

Hello, I've successfully used HPSIM for about 3 years and have upgraded from SLES9 64 bit to SLES10 64 bit without problems.

Recently, I tried to upgrade from HPSIM5.3 to the new update to see if it would help me with a new problem where healthy machines were coming on and offline and continuous informational messages were flooding the queue.

The updater is: "HPSIM-Linux-C.05.03.01.00_575369-001.bin"

During install, mxinitconfig failed at the last stage of database population with the message: "Configuration failed to complete due to the following exception: Cannot start HP Systems Insight Manager service."

I tried to fix it myself by a variety of methods: Adding a hpsmdb account (that was a mistake because mxinitconfig then wanted to START hpsmdb when before I was just using raw postgres). I'm in a real pickle, help!

I tried to downgrade to hpsim5.0.1 and that didn't help (I backed up all the files) and then tried an upgrade again and that's where I'm at.

If this is an easy fix (something like tweaking a config file) or running a database check, that would be super. At this point, I would be happy with just finding out how to backup my HPSIM server's certificate and keys and then doing a rebuild and discovery. (No biggie, I don't care about historicals).

I'm attaching my initconfiglog and mxdomain file in a compressed tar file with all the messages. I have an mx.log that's 2 mb in size but I didn't attach it for now.
2 REPLIES
Mark Sobolewski
Occasional Contributor

Re: Problem with upgrade from HPSIM5.3 to HPSIM5.3 uprade-1

Update: I just did a full reinstall from scratch. Can someone tell me if they know how to get the HPSIM server certificate and ssh keys out of a distribution directory (that I backed up) and re-import them into another instance?

I don't mind doing a rediscovery of my objects.

Thanks to anyone who can help!
Mark Sobolewski
Occasional Contributor

Re: Problem with upgrade from HPSIM5.3 to HPSIM5.3 uprade-1

I fixed it myself. For anyone else who encounters this problem, here's the info:

Running the HPSIM-Linux-C.05.03.01.00_575369-001.bin script to update a legacy HPSIM installation can be dangerous. The newest version of the installer prefers to run HPSIM using the hpsmdb database. This would then break Insight Manager trying to connect to an empty database. In addition, I prefer to not run HPSIM with this database because it requires the installation of a new ID and GROUP (hpsmdb) and I then have to explain that to management. Yadda yadda yadda.

To update, do this:

Run the installer to extract the rpms and NOT run the installer script: ./HPSIM-Linux-C.05.03.01.00_575369-001.bin --keep --noexec --target /var/tmp/sim/target

Get into target and do a manual rpm update: rpm -U hpsim-*

And you'll have a nice, clean install.

If, on the other hand, you break HPSIM like me and need to reinstall and rediscover (but don't want to lose your certificate authentication which was so painful to set up), after installation, make sure that database.* files in /etc/opt/mx/config have the port set to 5432 (for postgres, if you prefer) and NOT port 50001 as per hpsmdb. Then backup/tar your whole directory /etc/opt/mx and /opt/mx for good measure and backup your postgres database to boot (as postgres, run pg_dumpall) and run mxinitconfig -r to wipe everything clean (note that wiping everything clean is really doing just that).

Now you have a fresh slate. Restore the backed up /etc/opt/mx/config/certstor directory and then do an mxinitconfig -a. This will burn in the server with the previous keys so you can do rediscovery.

You also have the option to take the postgres dump above and get out all kinds of info (I'm grepping out all my hostnames and then making one big discovery job out of them).