Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with WBEM & reporting data

 
SOLVED
Go to solution
Dave Behler
Frequent Advisor

Problems with WBEM & reporting data

We've been using HPSIM for quite some time with few problems. Recently I just enabled the use of the WBEM protocol in order to retrieve data from our virtual machines.

In doing so, it seems that the data being collect via WBEM has a higher priority then that through the HP Mgmt Agents (example now when I run the canned report "Operating System Information - Servers" I only get the brief OS description of Microsoft(R) Windows(R) Server 2003, Standard Edition and no info in the additional description column and now neither column lists the Service Pack version.)

As a test I disabled WBEM, removed & rediscovered a server and the all of the data that I'm use to was back in the report for that single server.

Is there a way to fix this? I like collecting the data through WBEM on the VM, but now the data in the reports for the majority of my servers has been seriously degraded.
12 REPLIES
Dave Behler
Frequent Advisor

Re: Problems with WBEM & reporting data

Forgot to mention that we are running SIM 5.0 with SP4 and all Mgmt agents are at least at v7.40
NJK-Work
Honored Contributor

Re: Problems with WBEM & reporting data

Hi David,

I dont have a great solution for you, but what I do is just set a WBEM password for the VMs and thus WBEM fails for all other physical machines (leaving the normal SIM data collection to work for those).

We have a custom server database that pulls in hardware information from SIM. As soon as I enabled WBEM (when we rolled out VMware) it blew up all the data (like you are seeing). The only solution I could find was to enable WBEM, but only set passwords for the VMs. Its ugly, but it does work.

Hope this helps
Nelson
Dave Behler
Frequent Advisor

Re: Problems with WBEM & reporting data

Nelson,

Your suggestion worked perfectly. I agree this solution isn't ideal, at least the data that I need for my reports is as expected.

Now my only problem is that the devices (VM's and non-HP servers) that I discover with WBEM change status to unknown every night. If I recycle the wmi mapper and re-identify these systems they report correctly. I found some other posts with similar issues, but no definitive solution. Any idea?

Thanks,
Dave
Rob Buxton
Honored Contributor
Solution

Re: Problems with WBEM & reporting data

One of the issues I had seemed to be related to the Daily Device Identification task.
I found that when I stopped this task running I didn't lose servers to the Unknown status.

Since I went to SP5 I've not seen the problem, but I also made sure that I didn't have any tasks that might conflict with each other running at the same time.

I also spent time looking at the HPSIM logs as I could generally find the approximate time that the server seemed to change its status.
Dave Behler
Frequent Advisor

Re: Problems with WBEM & reporting data

I've actually been thinking about applying SP5, but haven't had a compelling reason. I'll give that a try and see how it goes.
fishmn
Regular Advisor

Re: Problems with WBEM & reporting data

I can tell that the problem still exists with SP5. Disabling the daily device ID will help but only up until your next discovery runs. If you have both turned off you will not lose your VM id's.

I have ongoing ticket with HP on troubleshooting the pegasus wmi mapper which is the component service that WBEM uses. I have also been bit by using "overwrite" when performing Data Collection's against servers. If the job fails you lose all your report data on the server.. not a feature.

Ron
Rob Buxton
Honored Contributor

Re: Problems with WBEM & reporting data

Ron,
I've reduced the frequency of the Discovery task and again made sure there's no conflict.

I'm not losing the VM's so my guess is still that it is a combination of things rather than an individual issue.

I've made sure that things like Discovery and Daily Device ID etc. were scheduled for quite different times of the day.
Dave Behler
Frequent Advisor

Re: Problems with WBEM & reporting data

I've upgraded to SP5 and things are somewhat better. I also spread out the discovery process and the daily device identification process. Like I said things are better, but not perfect. Now after discovery runs I lose only some of my vm's and it is always the same ones. After they change to unknown, I reidentify just these and they go back into known server status.

As I posted in another thread, I've found that I must use an account (either domain or local) with admin access in my wbem/wmi protocol settings in order to get wbem to work at all. Several HP docs that I found state that the wbem account shouldn't need any special priviledges. Could this have something to do with my problems?
dospavlos
Frequent Advisor

Re: Problems with WBEM & reporting data

I've also found that the only solution is a local admin user specified in the wbem protocol settings. Can anyone link me to the docs describing the priviledges that wbem needs/doesn't need.
Rob Buxton
Honored Contributor

Re: Problems with WBEM & reporting data

I'm now back to having data collection issues.
I've retried using a global WBEM setting with domain account and credentials.
After restarting HPSIM and a number of WMI Services I then successfully used the new settings to re-identify some VM's that had gone unknown/unmanaged.
But, I'm now getting a massive number of failures for a Historical Data collection task I run.
So, I think I'm going to revert to the WBEM enabled globally but with no credentials and then individual credentials for each of the VM's.
Which is quite a pain in the A.... (spelling as appropriate to country!)
dospavlos
Frequent Advisor

Re: Problems with WBEM & reporting data

Found this on page 10 of doc titled 'Understanding HP Systems Insight Manager security'. Tried the steps listed and still can't get the CMS to communicate over wbem. Only way I can get it to work is to put the user in the local admin group (trying to avoid this). Anyone else tried these wmi security settings?

EXCERPT:
The CMS requires a user name and password to access WMI data on Windows systems. By default, a domain administrator account can be used for this, but you should use an account with limited privileges for WMI access. You can configure the accounts accepted by each Windows managed system by using the Computer Management tool:
1. First select the WMI Control item
2. Right-click WMI Control and select Properties
3. Select the Security tab, select Root namespace, and click Security.
4. Add a user to access WMI data along with their access rights. The enable account and remote enable permissions must be enabled for correct operation of HP Systems Insight Manager.
5. The user name and password specified here must be configured in the CMS.

dospavlos
Frequent Advisor

Re: Problems with WBEM & reporting data

Here's my fix. Can someone else see if this works for them. HP engineer said the 'Distributed COM Users' step is not necessary.

ON TARGET SERVER:
Computer Management\WMI Control:
Highlight WMI Control, click Properties
Security/Root/Security/Add
Add domain user and enable 'Enable
Account' & 'Remote Enable'
Advanced, highlight account, Edit
Apply onto: Namespace and subnamespaces

Local Users and Groups/Groups:
Add domain user to 'Distributed COM Users'

CMS CONSOLE:
Protocol Settings/Global Protocol Settings:
Check box for 'Enable WBEM'
Specify domain user & password (domain\user)