Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

SAN connected storage arrays isn't detected

Phorward
Occasional Advisor

SAN connected storage arrays isn't detected

We are using HP SIM to monitor our hardware.
We have a SAN consisting of two FC Switches and two EVA 4400 and one EVA 3000 storage arrays.
The EVA's are managed through an appliance server with Command View 9.3 installed.
The appliance server is detected in SIM as a storage host but the EVA's is not present in SIM. We want to monitor the EVA's with SIM. How do I proceed?
I have tried to run Discovery and Identify on the appliance server and everything looks good except maybe this:
Minor: The Central Management System (CMS) cannot communicate with the
CIMOM locally installed on the managed system using the WBEM
protocol, Identification will try to identify Windows systems using
the WMI Mapper as proxy

but I haven't found a way to resolve this.
6 REPLIES
BPE
Esteemed Contributor

Re: SAN connected storage arrays isn't detected

The credential for the CommandView Eva server should be of an account which you can use to access command view EVA.
To see the Storage in SIM the CV EVA SMI-S must be installed and active on the CV EVA server/appliance.
You can the the connection with the wbemdisco command on the CMS server. For more information use help in the SIM and search for troubleshooting.

As soon as you can see your EVA Storage in the wbemdisco command you can identify your CV EVA server again and you will see the storage after some time. If you do not see the details you can force a data collection of your CV EVA server.

Phorward
Occasional Advisor

Re: SAN connected storage arrays isn't detected

Thanks for your reply.

This is the output I get from wbemDisco:

WbemDisco 01.01.00
------------------
HOST = x.x.x.x
PORT = 5989
NAMESP = interop
USER = administrator
PASSWD = *****
Connect to x.x.x.x in namespace interop with SSL=true

ObjectManager.Name=HP:CxwsCimom_x.x.x.x
ElementName=HP Cxws Server
CimomVersion=
Description=HP Cxws Server

Enumerating instances of CIM_RegisteredProfile...

Profile.RegisteredName=Server
RegisteredVersion=1.4.0
ProviderVersion=
SubProfile.RegisteredName=Profile Registration
Profile.RegisteredName=SMI-S
RegisteredVersion=1.3.0
ProviderVersion=
Profile.RegisteredName=SMI-S
RegisteredVersion=1.4.0
ProviderVersion=
Profile.RegisteredName=Array
RegisteredVersion=1.4.0
ProviderVersion=9.3.0
HPVersion=EVA9.3-Dev27
SubProfile.RegisteredName=Software
SubProfile.RegisteredName=Masking and Mapping
SubProfile.RegisteredName=Copy Services
SubProfile.RegisteredName=Block Services
SubProfile.RegisteredName=Disk Drive Lite
SubProfile.RegisteredName=FC Target Ports
SubProfile.RegisteredName=FC Initiator Ports
SubProfile.RegisteredName=Job control
SubProfile.RegisteredName=Access Points
SubProfile.RegisteredName=Physical Package
SubProfile.RegisteredName=Multiple Computer System
SubProfile.RegisteredName=Block Server Performance
SubProfile.RegisteredName=SAS Initiator Ports
SubProfile.RegisteredName=Thin Provisioning

===========================

Looks to me like the storage arrays isn't detected in some way.

This is from the troubleshooting help in HP SIM:
"The output from wbemdisco lists information about the CIMOM and provider, but no storage devices are listed.

Cause: Most storage device CIMOMs require additional management software. This error usually means the management software is not configured to manage any storage devices.

HP EVA arrays use the Command View EVA management software. In Command View EVA, click [Discover] to discover all EVAs on the SAN that are visible. By default, Command View EVA tries to manage all of the discovered arrays."

The storage arrays appear in Command View so that works.
BPE
Esteemed Contributor

Re: SAN connected storage arrays isn't detected

Did you change the IP address of your commandview server after the installation of your CV EVA software?

If it takes some seconds until you get the CMD prompt back after the last line of your wbemdisco output this could be the case.

You can also check in the EVAprovider\config\IPaddress.cfg which includes the IP of the original CV EVA server IP address.

You should ask HP for the official way to fix the address change problem or you can fix it on your own risk.
BPE
Esteemed Contributor

Re: SAN connected storage arrays isn't detected

Sorry I forgotten to mention, that you will
see for each EVA an entry at the end of the wbemdisco output you already posted. If this is the case you can identify the CV EVA Server again an you should see the EVA in the HP SIM.




Phorward
Occasional Advisor

Re: SAN connected storage arrays isn't detected

Thanks for your help.
The problem have actually already been fixed, unfortunately I don't know what fixed it since the guy who fixed it works other days than me. I will ask him the next time I meet him what he did and post the result here.

Re: SAN connected storage arrays isn't detected

Hi I have the same problem now. Wbemdisco stops after Thin Provisioning.

 

What solved the problem??

 

Please answer...

 

Best Regards

/Mikael Christenson

Micke_Christenson