Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

SIM 5.1 Configure/Deploy Agents SSH Error

SOLVED
Go to solution
mr1885
Occasional Visitor

SIM 5.1 Configure/Deploy Agents SSH Error

We retired our old 5.1 server and did a clean install of a brand new 5.1 server. When I try and do a configure/deploy to push out the new trusted cert to our managed systems, I get the following error when the task runs: "Error when trying to establish SSH connection. Check username/password."

All the firewall rules match the old system. I'm using the same admin account that I did in the old system. I know the username/password is correct because I can do this on the old system. I've looked through everything and I cannot find what would be causing this error.
7 REPLIES
Rob Buxton
Honored Contributor
Solution

Re: SIM 5.1 Configure/Deploy Agents SSH Error

You could try the approach I take which avoids SSH.
From the VCRM create a new baseline that just comprises the SMH.
Configure the SMH with the new certificate etc.
Use the deploy PSP option from HPSIM and select the newly created baseline. This way you just use a domain admin account for the deploy. SSH is not involved.
mr1885
Occasional Visitor

Re: SIM 5.1 Configure/Deploy Agents SSH Error

Rob - I took your advice and create a new baseline that only included the SMH. I then configure the SMH with the new certificate.
I ran into an issue trying to use the deploy PSP function from HPSIM. When I would try to deploy the baseline, I would get a trust error on the system I was trying to push it out to.

As a test, I was able to use the HP Remote Deployment Utility to push out the configure SMH. The only issue is, it does it 1 server at a time. Any thoughts on how to get the PSP deployment working so I can do more than 1 at a time?
Rob Buxton
Honored Contributor

Re: SIM 5.1 Configure/Deploy Agents SSH Error

At home just now so can't give you the precise path in HPSIM.
But you need to select the Deploy software, firmware and drivers or something like that.

It should ask you for login credentials.
You're effectively installing a PSP, but it just contains the one element.

You can deploy this to a number of servers.
I create a Baseline each for the W2000 and W2003 servers and then select all of that type of server for the deploy.
mr1885
Occasional Visitor

Re: SIM 5.1 Configure/Deploy Agents SSH Error

Rob - Here's what I'm trying:

In HPSIM I go to Deploy-->Deploy Drivers, Firmware and Agents-->Install Software and Firmware. I choose a target, select my software bundle I created earlier and click run now. It fails with a status "Agent trust error" :HTTP status 403: Establish a trust relationship with this system.
Rob Buxton
Honored Contributor

Re: SIM 5.1 Configure/Deploy Agents SSH Error

Back at work.
Try the Install Proliant Support pack Install option.
You'll then select the Baseline PSP containing just the SMH.
Mazda
Regular Advisor

Re: SIM 5.1 Configure/Deploy Agents SSH Error

I am having the same issue. I have followed what you have advised Rob but can not select my custom baseline to deploy. I can only select the PSP from HP, for example, v7.70, v7.60 etc.
Rob Buxton
Honored Contributor

Re: SIM 5.1 Configure/Deploy Agents SSH Error

Access the VCRM from the link in the options tab in HPSIM, from memory there's a way of refreshing the VCRM info. It relies on some task - can't remember the exact details as I'm not at work.