Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

SIM 5.1 discovery fails with custom SNMP values

Joshua Hirsh
Occasional Advisor

SIM 5.1 discovery fails with custom SNMP values

Hey folks,

I recently updated my SIM to 5.1. Since the "upgrade", I can no longer do manual discovery of hosts if I select the 'use custom' fields for the SNMP RO and RW communities. If I select these fields, I instantly get an error back saying:

"The system could not be added for the following reasons:
The system could not be added. (HOSTNAME)"

If I remove the custom SNMP fields and select 'use default', it goes through fine. The same process fails if I specify a hosts file with custom SNMP strings.

I use random SNMP strings on all servers, so at the moment I can't add any new hosts for monitoring without manually changing the default string every time.

Any ideas? And before you ask, I already checked. The HP SIM server makes NO attempt to contact the remote host before generating the error (I verified with a sniffer).

Cheers,
-Joshua
7 REPLIES
Rob Buxton
Honored Contributor

Re: SIM 5.1 discovery fails with custom SNMP values

You should be able to add the host, if it can be pinged, it just won't recognise it.
You can then go into the server settings and then override the default and re-identify it.
If it's not visible it may be that you've filtered out unknown devices.

That doesn't address the root issue where HPSIM seems to be broken though.
Joshua Hirsh
Occasional Advisor

Re: SIM 5.1 discovery fails with custom SNMP values

It's been a few months since this post and an upgrade to 5.1 SP1. However, this problem has never gone away for me.

Any suggestions? Has anyone run into (and FIXED) this issue?
H.Y. Yiu
Frequent Advisor

Re: SIM 5.1 discovery fails with custom SNMP values

I have exactly the same problem back in May but still no solutions. see
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1111063
I use this workaround:
options-protocol settings-system protocol settings
but I suppose this won't work for you since you have random community strings.
Joshua Hirsh
Occasional Advisor

Re: SIM 5.1 discovery fails with custom SNMP values

My workaround to date has been to add the read-only key to the global protocol settings for every server I'm about to add (and remove it afterwards).

It's a PITA, but atleast I can add my servers. For the Windows machines, it detects them all properly due to WBEM, but all my Linux hosts have to be done with the work around..

-Joshua
David Claypool
Honored Contributor

Re: SIM 5.1 discovery fails with custom SNMP values

I just tried it with an HP SIM 5.1 demo system and it worked flawlessly...
Joshua Hirsh
Occasional Advisor

Re: SIM 5.1 discovery fails with custom SNMP values

My issues only started after upgrading from 5.0. Prior to that upgrade, I was able to manually add systems without any problems.

Is there something that I can look at to try and debug why my installation (and the others with the same issue) error out on the manual discovery?

Thanks,
-Joshua
H.Y. Yiu
Frequent Advisor

Re: SIM 5.1 discovery fails with custom SNMP values

my problem also started after a 5.0 upgrade.