Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

SIM 5.5 and CVXPAE 5.6 - integration

 
Dwyane Everts_1
Honored Contributor

SIM 5.5 and CVXPAE 5.6 - integration

All,

When I was using CVXP, the integration with SIM was easy to configure. CVXP uses the standard http port 80. However, we had to upgrade to CVXPAE, and it uses non-standard ports 23015 and 23016. Now I can't get the integration to work at all.

Any ideas how to correct this?

Dwyane
12 REPLIES
Dwyane Everts_1
Honored Contributor

Re: SIM 5.5 and CVXPAE 5.6 - integration

sorry for the typo...

SIM 5.1

Dwyane
David Claypool
Honored Contributor

Re: SIM 5.5 and CVXPAE 5.6 - integration

You can add the additional ports for discovery to the additionalwsdisc.props file.
Dwyane Everts_1
Honored Contributor

Re: SIM 5.5 and CVXPAE 5.6 - integration

David,

I appreciate your response. I've found that SIM and CVXPAE are trying to use 5989 (default), but I'm getting denied access for an unknown reason.

Any troubleshooting tips are very welcome.

Dwyane
David Claypool
Honored Contributor

Re: SIM 5.5 and CVXPAE 5.6 - integration

5989 is the standard port for WBEM and SMI-S. HP SIM uses both of those and presumably CommandView XP uses SMI-S. Are you trying to get the two product to co-exist on the same unit?
Dwyane Everts_1
Honored Contributor

Re: SIM 5.5 and CVXPAE 5.6 - integration

No co-existing...I'm just trying to get these products to talk. Using the "wbemdisco" command, I get a denial message from CVXPAE.

Dwyane
David Claypool
Honored Contributor

Re: SIM 5.5 and CVXPAE 5.6 - integration

What's the exact message you are getting from 'wbemdisco' and see what happens (and the output) from using 'wbemauthcheck.cmd' as well...
Dwyane Everts_1
Honored Contributor

Re: SIM 5.5 and CVXPAE 5.6 - integration

wbemdisco:

C:\Program Files\HP\Systems Insight Manager>wbemdisco amtirexp1.atd-us.icd 5989
root/hitachi/dm56 system manager

C:\Program Files\HP\Systems Insight Manager>echo Tue 04/17/2007 15:42:41.98
Tue 04/17/2007 15:42:41.98

C:\Program Files\HP\Systems Insight Manager>echo off
WbemDisco 01.00.01
------------------
HOST = amtirexp1.atd-us.icd
PORT = 5989
NAMESP = root/hitachi/dm56
USER = system
PASSWD = *****
Connect to amtirexp1.atd-us.icd in namespace root/hitachi/dm56 with SSL=true
*** Error connecting with SSL=true - (CIM_ERR_ACCESS_DENIED) ***

wbemauthcheck.cmd:
C:\Program Files\HP\Systems Insight Manager>WbemAuthCheck.cmd

C:\Program Files\HP\Systems Insight Manager>C:\Program Files\HP\Systems Insight
Manager\j2re\bin\java.exe -Dorg.snia.wbem.cimom.properties=./WbemTools.propertie
s -classpath .;./lib/dc.jar;./lib/mx.jar;./lib/cimclient.jar;./lib/xerces.jar;./
lib/wbemutil.jar -mx400m -ms400m WbemAuthorizationCheck
'C:\Program' is not recognized as an internal or external command,
operable program or batch file.

I've never used the second command, so I don't know if I did it correctly.

Dwyane
Rob Buxton
Honored Contributor

Re: SIM 5.5 and CVXPAE 5.6 - integration

The wwebmdisc command indicates the SMI-S account / password is wrong. Note the account password to use is the wbem one, it's not a local or domain account.
I'm not too sure what the acc /pwd defaults is for CV XP, for CV EVA it's administrator / administrator
And yes, not too sure what's happened but wbemauthcheck.cmd seems to have got broken. It fails here with the same error and I have used it successfully in the past. Possibly an issue with changes in HPSIM 5.1
Dwyane Everts_1
Honored Contributor

Re: SIM 5.5 and CVXPAE 5.6 - integration

Rob,

Based on the readings and troubleshooting tips that I found, I don't disagree with you. The default CVXP account is also "Administrator/Administrator." The CVXPAE account is "system/manager."

I have tried the following accounts:
system/manager
Administrator/Administrator
Administrator/administrator
administrator/administrator

Nothing seems to work. Could the wbemauthcheck problem be a symptom or even the cause, of problem?

The wbemauthcheck problem seems to be related to a missing environment variable or the code is missing some quotes somewhere.

Dwyane
Rob Buxton
Honored Contributor

Re: SIM 5.5 and CVXPAE 5.6 - integration

wbemdisco.cmd works here for our EVA but wbemauthcheck.cmd fails with exactly the same message you get. So the error you're seeing in wbemauthcheck is not necessarily an indication of wider problems. I'd still focus on the credentials.

You might want to look at the utilities like cimauth & cimuser which should be on the CV Host. They are on the CV EVA Host here. cimuser --help shows the options available. cimuser -l should list the SMI-S users.

Just a thought, but has the SMI-S port changed as well or is that still the default 5989?
Dwyane Everts_1
Honored Contributor

Re: SIM 5.5 and CVXPAE 5.6 - integration

Rob,

I've also been working with HP Response on this.

What we are finding is that this may not work for me...because the CVXPAE server is on a VMWare machine. Something to do with how the virtual interface. I'm going to investigate further tomorrow.

Does anyone have CVXPAE installed on a VMWare server integrated with SIM (installed on a standalone server)?

Dwyane
Dwyane Everts_1
Honored Contributor

Re: SIM 5.5 and CVXPAE 5.6 - integration

We bought Storage Essentials and the new SIM install corrected the issue.