Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

SIM 6.0 : Error : Snmp trap Service not started

OlivierV
Trusted Contributor

SIM 6.0 : Error : Snmp trap Service not started

Hello.

I have a problem with my Sim 6.0 server.
Since 4 days, most of the traps are not managed by the CMS.

In Mxdomainmgr.0.log I see the following event logged every minutes :
09 Nov 15:34:11,308 INFO [HPSIM_DEBUG] [Panic Logger-0] (ConstructionWrapper:TrapRequester) Trap service not functioning, enable or start it

In winsnmpadapter.log, there's a lot of events : Adding trap of size: xxx from 10.x.x.x to queue

So the snmp traps are received (confirmed with netmon) but don't seem handled by the server.

I have stopped and restarted the HP sim and SNMP services, the snmptrap service is running and I have restarted the server. No change.

Can some of you tell me some guidelines for solving this issue ?

It's a 2003R2 server (esx VM) with SQL 2005 SP3.

Thank you.
7 REPLIES
OlivierV
Trusted Contributor

Re: SIM 6.0 : Error : Snmp trap Service not started

I also see this event in mx.log :
09 Nov 15:50:59,812 INFO [HPSIM_DEBUG] [Panic Logger-0] (ConstructionWrapper:TrapHandler) SNMP_TRAP Error processing traps, likely the SNMP Trap service is not running or installed

The SNMP Trap service is installed and running. HP Sim starts the Snmp Trap service when it starts.
OlivierV
Trusted Contributor

Re: SIM 6.0 : Error : Snmp trap Service not started

Update :
SNMP service uninstalled and reinstalled. Seems to work a -very- litle bit better (a few more trap are managed) but the snmp service error message is still present.

Is there a way to have more detailled logs about what is happening with SIM ?

Regards.
OlivierV
Trusted Contributor

Re: SIM 6.0 : Error : Snmp trap Service not started

Hi.

My test SIM 6.0 is behaving the same !!
In the file "winSnmpAdapter.log" of the SIM test server I can see events like "GRAVE: Could not put trap into write Queue" and "Trap queue is full".

No error messages in SQL logs and in the events logs. Procmon.exe isn't showing any explicit message also.

After the restart these messages have disappeared but the "trap service not functionning" is still here

What is the mess with these servers ?
OlivierV
Trusted Contributor

Re: SIM 6.0 : Error : Snmp trap Service not started

Updated to SIM 6.1b, no improvement.
Rob Buxton
Honored Contributor

Re: SIM 6.0 : Error : Snmp trap Service not started

You should have 2 SNMP Services running:
SNMP Service and SNMP Trap
SNMP Service is common and handles sending traps.
In addition HPSIM will need the SNMP Trap service to handle incoming traps.

You can try reinstalling SNMP, ensuring both services are installed. But usually the installation verifies that these are there before proceeding.
On my HPSIM Server SNMP Service is set to Automatic while SNMP Trap is set to manual but is running.
Perhaps the SNMP Trap service is not running and HPSIM cannot start it?
OlivierV
Trusted Contributor

Re: SIM 6.0 : Error : Snmp trap Service not started

Hi Rob.

Thank you for the response.

Both services are installed and running. I have reinstalled the SNMP service without success.
I also have set the snmp trap service starting mode to automatic, but no success.

The server is running since last June and was working fine until the beginning of this month. It started having troubles an afternoon without any clear reason.

Regards.
OlivierV
Trusted Contributor

Re: SIM 6.0 : Error : Snmp trap Service not started

Sorry for closing this thread so late.

After installing Sim 6.1b and two fixes provided by HP support, the issue on the test server was solved.

On the production server, the issue disappeared by itself. However, I upgraded it yesterday to the same version/patch level as the test server.

Thanks to the HP support engineer (Outaiel Marzouki)