Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

SIM Host without IP

SOLVED
Go to solution
Lisandro Dugarte
Frequent Advisor

SIM Host without IP

Hi all.
I have SIM 5.0 SP2
Last week I saw a linux server under state Unmanaged. I deleted both the server and ilo processor from System Table and ran discovery.
SIM found the server (Serv_####) and ilo processor (ilo in Server Serv_####) but the server has no IP.
How can I solve this problem?
Thanks in advance.
11 REPLIES
Rob Buxton
Honored Contributor

Re: SIM Host without IP

Not sure what you mean by server has no IP.

HPSIM uses dns for IP address to name resolution.
If it can resolve any address it will display the name not the IP Address.
It does need to be able to resolve it using forward and reverse lookups in order to display the name.
Unmanaged would imply HPSIM cannot get access to the device using SNMP or another protocol. but it doesn't affect name resolution.
Lisandro Dugarte
Frequent Advisor

Re: SIM Host without IP

OK. Let me explain it.
SIM cannot obtain IP address from Server. SIM says that it's a Server BL20p Proliant but in column IP addresss has nothing. For that, I can't see hardware status (it shows "?"). I tried with Identify but task cannot be completed (obvius... SIM has no IP to obtain data from server).
Last week it was OK, I don't know what happened.
Indeed, the problem was with 3 servers, but with the discovery task SIM could reconfigure 2 of them, but not the third one.
Lisandro Dugarte
Frequent Advisor

Re: SIM Host without IP

Ah... SNMP configuration hasn't been changed.
I really don't know what's happening.
Server can be accessed through network, so, IP configuration is fine.
Rob Buxton
Honored Contributor

Re: SIM Host without IP

Interesting...
The only devices I have where the "System Address" column is blank is for our EVA Storage Systems. And they're discovered via another server.
Does the ILO have an IP Address?
It's almost like the server is being discovered via the ILO but HPSIM can't determine the IP address.
Lisandro Dugarte
Frequent Advisor

Re: SIM Host without IP

Yes, Rob. Ilo has System address but Server hasn't. I've just deleted both server and ilo with mxnode -r [node] and tried to discover it again with no luck.
I have no idea what happen.
Rob Buxton
Honored Contributor

Re: SIM Host without IP

Try using nslookup & ping from the HPSIM Server.
You should be able to ping the IP Address.
You should also be able to use nslookup to translate the address to name and then name to address. They should match.
I suspect it's some kind of DNS issue.

Also, with nslookup repeat the tests a few times because if there are multiple dns servers you sometimes get different results.
Lisandro Dugarte
Frequent Advisor

Re: SIM Host without IP

DNS is OK.
The server is our mailserver and it's working well (in production).
Rob Buxton
Honored Contributor
Solution

Re: SIM Host without IP

Mail has different dns requirements to HPSIM.
The tests need to be done from the HPSIM Server.

If it's not dns then I'm not sure what it could be.
I still think the server has been discovered via the ILO. I can't think of another way HPSIM could discover a server without being able to at least identify the IP address.
Lisandro Dugarte
Frequent Advisor

Re: SIM Host without IP

Yes. I can reach the host from HPSIM Server and HP Server from the host.
Configurations are fine.
It's crazy.
Lisandro Dugarte
Frequent Advisor

Re: SIM Host without IP

Fixed.
The problem was with NICs configuration. The host had a bad configuration in bond0 and could´t reach the network correctly (it was working in failover state).
I recommend to our network administrator that check the DNS configuration and he found this problem with the Network adapters config.
Thanks for your help
Lisandro Dugarte
Frequent Advisor

Re: SIM Host without IP

bond0 re-configuration-> delete host-> discovery
Ready!
Thanks Rob