Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

SIM WBEM Subscriptions and ESXi 4.1 issues

Sean Murray_1
Regular Advisor

SIM WBEM Subscriptions and ESXi 4.1 issues

I have read through the threads and found things I have tried but no luck.

I have ONE ESXi system that allowed me to subscribe to WBEM events.
The rest (completely indentical Proliant servers) fail on trying to subscribe.

During system indentification it sees WBEM:

Normal: This system has WBEM protocol support.
Normal: The system support SLP.
Normal: This system has at least one SMI-S CIMOM installed to serve as the
storage proxy to discover storage systems.
Normal: This system has a server CIMOM installed.
* Running WBEM rules based identification...
Normal: Got the system information from the WBEM / WMI providers and it has
a valid WBEM credential.


Then when I try to subscribe to WBEM events it comes back with this:

Create Subscriptions for:

FAILED to create indication subscription.

Cause:Subscriptions are not supported

Recommended Action:Install the HP WBEM providers

OR

FAILED to create indication subscription.

Cause:Subscription infrastructure is not present or corrupted

Recommended Action:Update or reinstall the HP WBEM providers


I'm I missing something?
It seems to see it but doesn't see it.

Thanks
14 REPLIES
Rob Buxton
Honored Contributor

Re: SIM WBEM Subscriptions and ESXi 4.1 issues

I have had fun here as well. Check in amongst the server details, click on server name and under Tools go to Edit System Details (I think that's what it is, at home so cannot verify). Cross check that the settings look the same as one that's working.
In the past I've had to clear all of those and ensure any check boxes that stop the ID task from changing things are unchecked.
The only other thing is to ensure the SIM server can access the server using the credentials spec'd. You could try using server specific credentials.

Re: SIM WBEM Subscriptions and ESXi 4.1 issues

I am having the same problem. I have 50 HP-UX servers discovered in SIM and only one of them is giving this error message. When I run "Identify Systems" in SIM the output looks good but the "Subscribe to WBEM events" fails every time. The information on the "Edit System Properties" page looks good. I don't know what else to try. Everything matches on all 50 servers. Any ideas?
Sean Murray_1
Regular Advisor

Re: SIM WBEM Subscriptions and ESXi 4.1 issues

Sorry for late replies. Traveling.
I have tried checking all the settings and even removing and readding the systems.

Still no luck.
BPE
Esteemed Contributor

Re: SIM WBEM Subscriptions and ESXi 4.1 issues

I saw the same at a customer site.
Try unsubscribe if it finish with success the subscribe should work.

Sean Murray_1
Regular Advisor

Re: SIM WBEM Subscriptions and ESXi 4.1 issues

Tried that. I won't allow me to run the command to unsubscribe.
BPE
Esteemed Contributor

Re: SIM WBEM Subscriptions and ESXi 4.1 issues

Sorry I forgotten to mention that I tried it from the command line mxwbemsub command.
If you had it on an esxi41 Update 1 it could be also a bug or a new feature.
Sean Murray_1
Regular Advisor

Re: SIM WBEM Subscriptions and ESXi 4.1 issues

Well, allowed me to unsubscribe using the CLI, but still cannot subscribe using SIM or the CLI.

Says to install the HP WBEM Providers. Which are.

Even shows the WBEM health indicators and protocol found on the node.

Systems having the issue are indentical to the one that works.
Frustrating.
Brian Proteau
Frequent Advisor

Re: SIM WBEM Subscriptions and ESXi 4.1 issues

I have this working for my ESXi servers but, I was looking for an explanation on subscribing to WBEM and why that's necessary.

It's my own ignorance but, I don't fully understand the need to specifically subscribe to WBEM events.

I suppose I'm wondering why it doesn't automatically subscribe. Why is it a seperate process.

Can anyone provide and insight into this.
David Claypool
Honored Contributor

Re: SIM WBEM Subscriptions and ESXi 4.1 issues

@Brian: It's the functional equivalent to setting SNMP trap destinations on the target; "subscribing" is the method adopted by the DMTF for WBEM.
BPE
Esteemed Contributor

Re: SIM WBEM Subscriptions and ESXi 4.1 issues

@Brian

If you have SIM and IRSA the subscribe to WBEM event is optional. The subscription is automatically done by WBES (part of Insight Remote Support) if you have specified country code contact site product number serial number before. But this automatic subscription is only used for the HW failure alarming to HP.

If you have IRSA installed you will see a service event of your HW failure in your SIM.
If you subscribe WBEM events to SIM you will also get a "SNMP trap" like event inside SIM.

Because nobody normally checks the WEBES log for successful subscription I recommend the SIM WBEM Event subscription. If your HP WBEM providers are not correct installed you will see an error as mention above.
jason liu_2
Advisor

Re: SIM WBEM Subscriptions and ESXi 4.1 issues

Hi I'm having the same problem for ESXi4.1 and SIM 6.3. Did anyone find any fix for this? Thanks.
Udo Hillenbrand
Frequent Advisor

Re: SIM WBEM Subscriptions and ESXi 4.1 issues

Hello,

I am having  the same problem.

Have anyone a solution?

 

Create Subscriptions for:
...

FAILED to create indication subscription.

Cause: Subscriptions are not supported

Recommended Action: Install the HP WBEM providers

 

The providers are active and I can call the provider with the link in the sim.

 

best regards

hillenbrand

 

shocko
Honored Contributor

Re: SIM WBEM Subscriptions and ESXi 4.1 issues

I notice in your discovery that it's also detecting SMI-S CIM providers:

 

"This system has at least one SMI-S CIMOOM installed to serve as the
storage proxy to discover storage systems. "

 

This means there are 2 or more WBEM providers probably listening on different ports. Have you specified the appropriate system credentials with port number on the system credentials page?

If my post was helpful please award me Kudos! or Points :)
fari23
Occasional Visitor

Re: SIM WBEM Subscriptions and ESXi 4.1 issues

were you able to resolve this issue?