Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

SMI-S Pegasus service stops

SOLVED
Go to solution
S-tog a s
Frequent Advisor

SMI-S Pegasus service stops

Hi Forum,

I'm running the following on my W2k3 appliance server.

EVA Provider=5.0
Pegasus=2.5.0.34

The appliance is working fine expect that the Pegasus CIM Object Manager service stops once in a while.

The Problem is that HPSIM isn't populated with the SAN data when the autodiscovery run each Sunday because the Pegasus service wans't running.

The only error I can find is the following Event ID: 7034 The Pegasus CIM Object Manager service terminated unexpectedly. It has done this 1 time(s).

I'd like to upgrade to Command View 6 but I'm told that the SMI-S isn't ready just yet.

Any suggestions!?!
Claus Bohm
13 REPLIES
Rob Buxton
Honored Contributor
Solution

Re: SMI-S Pegasus service stops

Only to get hold of CV EVA 6.
I was having a number of problems with CV EVA 5, including one where the Pegasus server on the CV EVA Server would restart whenever a connection was made to it. And no SAN Data could be collected.
CV EVA 6 installed simply and I now get complete data collection. It seems pretty stabled as well.
S-tog a s
Frequent Advisor

Re: SMI-S Pegasus service stops

Hi Rob,

I'm now running:

EVA Provider=6.0
Pegasus=2.5.1.19

but if I run a Datacollection on the SAN I get the following error:
An error occurred connecting to this system with the WBEM protocol. Check the system configuration.

If I run the discovery test I get the following:
C:\Program Files\HP\Systems Insight Manager>wbemdisco SERVERNAME 5989 root/pg_int
erop UID PWD
HOST = Servername
PORT = 5989
NAMESP = root/pg_interop
USER = UID
PASSWD = *****
Connect to Servername in namespace root/pg_interop with SSL=true

Enumerating instances of CIM_RegisteredProfile...

Profile.RegisteredName=Array
Profile.RegisteredVersion=1.1.0
ProviderVersion=6.0
Profile.HPVersion=EVA6.0-RC6
SubProfile.RegisteredName=Array:Software
SubProfile.RegisteredName=Array:Pool Manipulation Capabilities and Settings
SubProfile.RegisteredName=Array:Job control
SubProfile.RegisteredName=Array:Physical Package Package
SubProfile.RegisteredName=Array:Backend Ports
SubProfile.RegisteredName=Array:Masking and Mapping
SubProfile.RegisteredName=Array:Block Services
SubProfile.RegisteredName=Array:Disk Drive Lite
SubProfile.RegisteredName=Array:FC Target Port
SubProfile.RegisteredName=Array:Fibre Channel Initiator Port
SubProfile.RegisteredName=Array:LUN Creation
SubProfile.RegisteredName=Array:Copy Services
SubProfile.RegisteredName=Array:Access Point
SubProfile.RegisteredName=Array:Location
SubProfile.RegisteredName=Array:Multiple Computer System
SubProfile.RegisteredName=Array:Block Server Performance
Profile.RegisteredName=Server
Profile.RegisteredVersion=1.1.0
ProviderVersion=
Profile.HPVersion=
Press any key to continue . . .

----------

Any suggestions since yours are working fine!?! as I mentioned I heard that the SMI-S wasn't ready in CV6...is that not true? or do I need an update...

Best reg,
-Claus Bohm-
Rob Buxton
Honored Contributor

Re: SMI-S Pegasus service stops

I've the following WBEM set ups.
WBEM enabled in the Global settings.
For the Server hosting CV EVA I use the server specific WBEM Settings and have the Global ones plus a second set of credentials that match the one that works in the wbemdisco command which just for good measure have the port number entered as well.
Then you need to run a Discovery, I just create a new Discovery task and include the CV EVA Server.
I seem to recall I may have deleted the old EVA from HPSIM before rerunning the Discovery task.
S-tog a s
Frequent Advisor

Re: SMI-S Pegasus service stops

Hi Rob,

I've removed the appliance and SAN entry from SIM.

made a new discovery, datacollection, identify and SW polling of the appliance box.

I got back the appliance box but not the SAN.

So I made a discovery of the SAN but it doesn't have any connection with the appliance box so running a datacollection result in a "The device does not have any supported instrumentation."...which isn't good...

Best reg,
-Claus Bohm-
Rob Buxton
Honored Contributor

Re: SMI-S Pegasus service stops

The SAN should be discovered through the appliance.
I've abandoned SMA's and just have CV EVA and all of the associated products installed on a Server. So from HPSIM click on the server name for the appliance, then the Tools & Links tab and select System Protocol settings and update the wbem to use server specific properties. If you use wbem globally, enter those in 1, and then enter the wbem for cv eva. I've used the default administrator and also entered the 5989 port number.

Then do a Discovery of the appliance. The discovery process should pick up the EVA.
S-tog a s
Frequent Advisor

Re: SMI-S Pegasus service stops

Hi Rob,

It just doesn't work. I can telnet to 5989 from the HPSIM server and looks good.

I still get the following read out which doesn't look good to me...

------------------

Running the C:\Program Files\HP\Systems Insight Manager>wbemdisco SERVERNAME 5989 root/pg_int
erop UID PWD
HOST = Servername
PORT = 5989
NAMESP = root/pg_interop
USER = UID
PASSWD = *****
Connect to Servername in namespace root/pg_interop with SSL=true

Enumerating instances of CIM_RegisteredProfile...

Profile.RegisteredName=Array
Profile.RegisteredVersion=1.1.0
ProviderVersion=6.0
Profile.HPVersion=EVA6.0-RC6
SubProfile.RegisteredName=Array:Software
SubProfile.RegisteredName=Array:Pool Manipulation Capabilities and Settings
SubProfile.RegisteredName=Array:Job control
SubProfile.RegisteredName=Array:Physical Package Package
SubProfile.RegisteredName=Array:Backend Ports
SubProfile.RegisteredName=Array:Masking and Mapping
SubProfile.RegisteredName=Array:Block Services
SubProfile.RegisteredName=Array:Disk Drive Lite
SubProfile.RegisteredName=Array:FC Target Port
SubProfile.RegisteredName=Array:Fibre Channel Initiator Port
SubProfile.RegisteredName=Array:LUN Creation
SubProfile.RegisteredName=Array:Copy Services
SubProfile.RegisteredName=Array:Access Point
SubProfile.RegisteredName=Array:Location
SubProfile.RegisteredName=Array:Multiple Computer System
SubProfile.RegisteredName=Array:Block Server Performance
Profile.RegisteredName=Server
Profile.RegisteredVersion=1.1.0
ProviderVersion=
Profile.HPVersion=
Press any key to continue . . .

----------
S-tog a s
Frequent Advisor

Re: SMI-S Pegasus service stops

This is a read out from when it was working with CV5 - as you can see the difference is that it can see the namespaces for the SA...

C:\Program Files\HP\Systems Insight Manager>wbemauthcheck s-tog-s55 5989 root/pg
_interop UID PWD v 5

C:\Program Files\HP\Systems Insight Manager>j2re\bin\java.exe -Dorg.snia.wbem.ci
mom.properties=./WbemTools.properties -classpath .;./lib/dc.jar;./lib/mx.jar;./l
ib/cimclient.jar;./lib/xerces.jar;./lib/wbemutil.jar -mx400m -ms400m WbemAutho
rizationCheck s-tog-s55 5989 root/pg_interop UID PWD v 5


TESTING CREDENTINALS VIA MxWBEMConnect::checkAuthorization() ....


Testing with
host: s-tog-s55
port: 5989
protocol: https
namespce: root/pg_interop
verbosity: 5
user: UID
password: *******

Checking authorization in device namespaces for s-tog-s55 under ns=root/pg_in
terop for user=UID
Trying to connect to CIMOM at: s-tog-s55 under ns=root/pg_interop for user=UID
SUCCESS


Found the following device namespaces:
root/PG_Internal
root/cimv2
root/eva



Checking Authorization in namespace: CIMNameSpace=root/PG_Internal [host s-tog-s
55]
CIMException retrieving instance of CIM_ComputerSystem.

Checking Authorization in namespace: CIMNameSpace=root/cimv2 [host s-tog-s55]
SUCCESS

Checking Authorization in namespace: CIMNameSpace=root/eva [host s-tog-s55]
CIMException retrieving instance of CIM_ComputerSystem.
Authorization Check Succeeded for: s-tog-s55 under ns=root/pg_interop for user=
UID

AUTHORIZATION CHECK PASSED


C:\Program Files\HP\Systems Insight Manager>pause
Press any key to continue . . .

C:\Program Files\HP\Systems Insight Manager>popd

C:\Program Files\HP\Systems Insight Manager>endlocal

C:\Program Files\HP\Systems Insight Manager>wbemdisco s-tog-s55 5989 root/pg_int
erop UID PWD
HOST = s-tog-s55
PORT = 5989
NAMESP = root/pg_interop
USER = UID
PASSWD = *****
Connect to s-tog-s55 in namespace root/pg_interop with SSL=true

Enumerating instances of CIM_RegisteredProfile...

Profile.RegisteredName=Array
Profile.RegisteredVersion=1.1.0
ProviderVersion=5.0
Profile.HPVersion=EVA5.0-Dev28
SubProfile.RegisteredName=SNIA:Software
SubProfile.RegisteredName=SNIA:Pool Manipulation Capabilities and Settings
SubProfile.RegisteredName=SNIA:Job control
SubProfile.RegisteredName=SNIA:Physical Package Package
SubProfile.RegisteredName=SNIA:Backend Ports
SubProfile.RegisteredName=SNIA:Masking and Mapping
SubProfile.RegisteredName=SNIA:Disk Drive Lite
SubProfile.RegisteredName=SNIA:FC Target Port
SubProfile.RegisteredName=SNIA:Fibre Channel Initiator Port
SubProfile.RegisteredName=SNIA:LUN Creation
SubProfile.RegisteredName=SNIA:Copy Services
SubProfile.RegisteredName=SNIA:Access Point
SubProfile.RegisteredName=SNIA:Location
SubProfile.RegisteredName=SNIA:Multiple Computer System
SubProfile.RegisteredName=SNIA:Block Server Performance
HPEVA_StorageSystem.CreationClassName="HPEVA_StorageSystem",Name="5000
1FE15003
FDD0"
NameSpace = root/EVA
Vendor=HP
Name=EVA
IdentifyingNumber=50001FE15003FDD0
Profile.RegisteredName=Server
Profile.RegisteredVersion=1.1.0
ProviderVersion=
Profile.HPVersion=
Press any key to continue . . .
S-tog a s
Frequent Advisor

Re: SMI-S Pegasus service stops

this is the entry I'm missing...
...
HPEVA_StorageSystem.CreationClassName="HPEVA_StorageSystem",Name="5000
1FE15003
FDD0"
NameSpace = root/EVA
Vendor=HP
Name=EVA
IdentifyingNumber=50001FE15003FDD0
Rob Buxton
Honored Contributor

Re: SMI-S Pegasus service stops

Claus,

I did my CV EVA 6.0 installation on a new Server that had no previous CV EVA installations.
Did you do an upgrade from 5?

The section you're reporting as missing I do get in my wbemdisco command using 6.0.
S-tog a s
Frequent Advisor

Re: SMI-S Pegasus service stops

Hi Rob,

That's correct upgrade from v5.

Best reg,
-Claus Bohm-
Rob Buxton
Honored Contributor

Re: SMI-S Pegasus service stops

Another option may be to remove CV EVA and all associated products completely and then install CV 6 fresh.

A pain, but I never had any luck with CV 5 and SMI-S and this new install of CV 6 has been pretty solid here.
S-tog a s
Frequent Advisor

Re: SMI-S Pegasus service stops

I'll have a go...
Rob Buxton
Honored Contributor

Re: SMI-S Pegasus service stops

Claus,
Possibly a bit late, but see the very end of this thread.
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1043880