Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

SNMP Problem with linux systems

Janezic Milan
Occasional Advisor

SNMP Problem with linux systems

We have a Probelm with our linux systems. Remote Support doesn't show any linux systems. Also the System Event Analyzer (which i think uses the same communicaton process) doesn't show any linux systems.
We have installed the newest Insight Control Management DVD (with SIM 5.2) and installed the latest remote support updates (RSP, WEBES etc).
It seems like my linux systems doesn't correctly communicate with SNMP. When i try to send a test trap over the "System Management Homepage" with one of the linux servers, nothing happens. When i make this with a Windows Server, SIM gets a Warning Notification and in OSEM it's also visible.
PSP 7.92 is installed on the linux machines.
Everything else works fine (the linux machines are visible and correctly collected in SIM).
I tried "/etc/init.d/hpasm reconfigure" to configure the snmp, but with no success.
I'm not so into linux machines, probably someone has some wise advices ;)
14 REPLIES
mcgim
Occasional Advisor

Re: SNMP Problem with linux systems

To check that snmp is running try
service snmpd status
should return something like
snmpd (pid 13644) is running...

Check you have traps setup ok. In /etc/snmp/snmpd.conf there should be a line
trapsink hpsimservername

To see what protocols the hpsim server can connect to your linux system with look at the server's system page. I get a line
Management Protocols HTTP:, SMH:2.0, SNMP:1.0, SSH:SSH-1.99-OpenSSH_3.6.1p2

Hope this helps
Mark
Change_happens
Honored Contributor

Re: SNMP Problem with linux systems

apart from what mcgim said, You need to check if community string is set to be correct in snmpd.conf

rocommunity should be public and rwcommunity should be private.
if u wanna specify trap to be sent to SIM server you can specify it here.

Hope this help.
Janezic Milan
Occasional Advisor

Re: SNMP Problem with linux systems

thanks for the fast response.
Snmpd service is running.
The Protocol is also in the information list: (Management Protocols HTTP:, SMH:2.0, SNMP:1.0, SSH:SSH-2.0-OpenSSH_4.3). The snmpd Config file looks like these:

dlmod cmaX /usr/lib64/libcmaX64.so
rwcommunity private 127.0.0.1
rocommunity public 127.0.0.1
rwcommunity private ip-of-the-hpsim-server
rocommunity public ip-of-the-hpsim-server
trapcommunity public
trapsink 192.168.90.1 public
trapsink hpsimservername

Still when i do an test trap nothing happens.
We have Oracle Linux (based on redhat) installed.
Change_happens
Honored Contributor

Re: SNMP Problem with linux systems

Hi yes. see ur comunity strings are for 127.0.0.1 means only for that system so remove 127.0.0.1 it will be all fine.

Thanks,Ajay
Change_happens
Honored Contributor

Re: SNMP Problem with linux systems

do same comunity strig to SMH snmp setting also from where u r trying ur test trap.
Janezic Milan
Occasional Advisor

Re: SNMP Problem with linux systems

hi, thanks.
But it didn't solve anything. Still I don't receive the test trap. When I do a
/etc/init.d/hpasm reconfigure i get a message in SIM:
(SNMP) Server Operational (6025)
The server is operational again. The server has previously been shutdown by the Automatic Server Recovery (ASR) feature and has just become operational again.

So it looks like SNMP is working, Probably there is a Problem with the System Homepage from the Server?

Change_happens
Honored Contributor

Re: SNMP Problem with linux systems

hope u did restart SNMP services and then hpasm services after changing the snmpd.conf file?

dont reconfigure it may reset that file(snmpd.conf) again. just restart.
Change_happens
Honored Contributor

Re: SNMP Problem with linux systems

Is that worked?
Janezic Milan
Occasional Advisor

Re: SNMP Problem with linux systems

hi, sorry i was not at the office in the last days.
nope, didn't work. I've restarted smpd and hpsam service.
Change_happens
Honored Contributor

Re: SNMP Problem with linux systems

Remove trapsink 192.168.90.1 public from snmpd.conf.
and restart both service.
Janezic Milan
Occasional Advisor

Re: SNMP Problem with linux systems

didn't help either...
should i see the test trap in the /var/log/messages file? When I look at it i don't see anything which could be send log...looks like that:

May 9 10:07:32 db-prod snmpd[31359]: Connection from UDP: [127.0.0.1]:14323
May 9 10:07:36 db-prod last message repeated 4 times
May 9 10:07:37 db-prod snmpd[31359]: Connection from UDP: [127.0.0.1]:14329
May 9 10:07:37 db-prod snmpd[31359]: Received SNMP packet(s) from UDP: [127.0.0.1]:14329
May 9 10:07:37 db-prod snmpd[31359]: Connection from UDP: [127.0.0.1]:14329
May 9 10:08:08 db-prod last message repeated 81 times

Change_happens
Honored Contributor

Re: SNMP Problem with linux systems

think u will see all ur test trap in SIM All events page?
Rob Buxton
Honored Contributor

Re: SNMP Problem with linux systems

If you're using a name in the trapsink line you might want to change that to the IP address of the HPSIM Server.
In this thread there's a view of the snmpd.conf file used in VMware ESX that has a linux console. See:
http://forums11.itrc.hp.com/service/forums/questionanswer.do?admit=109447626+1210469360080+28353475&threadId=1174194
Janezic Milan
Occasional Advisor

Re: SNMP Problem with linux systems

sorry guys, i had some other problems to solve. Now i'm back on this one. First thanks for your help. I've found a big mistake made by me.
The Tool snmptrap wasn't installed on the server!
So I've installed it and tried again. Nothing happend. So I made again a hpasm reconfigure, this took me a step farther.
Now when i make a test trap, the trap gets out and gets picked up in the OSEM. I see that also in the /var/log/messages logfile:
May 19 16:34:33 db-prod snmpd[22225]: Received TERM or STOP signal... shutting down...
May 19 16:34:33 db-prod snmpd[27857]: mibII/mta_sendmail.c:open_sendmailst: could not guess version of statistics file "/var/log/mail/statistics"
May 19 16:34:33 db-prod snmpd[27857]: cmaX: listening for subagents on port 25375
May 19 16:34:33 db-prod snmpd[27857]: cmaX: sent ColdStarts on ports 25376 to 25393
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 1 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 2 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 3 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 5 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 6 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 8 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 9 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 10 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 11 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 14 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 15 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 16 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 21 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: NET-SNMP version 5.3.1
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 22 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 23 handler has disconnected
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 1 will be sent on port 25376 to hp Advanced Server Management_Peer
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 2 will be sent on port 25376 to hp Advanced Server Management_Peer
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 3 will be sent on port 25376 to hp Advanced Server Management_Peer
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 5 will be sent on port 25376 to hp Advanced Server Management_Peer
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 6 will be sent on port 25376 to hp Advanced Server Management_Peer
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 8 will be sent on port 25376 to hp Advanced Server Management_Peer
May 19 16:34:33 db-prod snmpd[27857]: cmaX: subMIB 9 will be sent on port 25376 to hp Advanced Server Management_Peer
.....
...

but OSEM gets a problem and stops the delivery (Remote delivery down). When i look under Notifications the status of the GenericTrap is "stalled". So how can i solve this? with a windows server everthing works fine!

Also strange is when i repair the agent with HPSIM (Configure or Repair Agent...under Configure), the System Manamgent Homepage loses all the data and even doesn't recognize the System Model (just NULL). Then when i try a testrap nothing happens. So i have to make a hpasm reconfigure to correct it.