Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

SNMP Traps are all listed as 'ColdStart'

Jonathan Daniels
Occasional Contributor

SNMP Traps are all listed as 'ColdStart'

Hi all,

We have an application that uses SNMP version 2 in its MIB. What I want to do is send traps against that MIB to HP Insight Manager version 5 (both manager and client are on RedHat Enterprise Linux 3). However if I send traps via SNMP v1, they all come through as coldstarts, even though our MIB is registered with the Insight Manager. If I attempt to send them via SNMP v2c, nothing arrives at all.

Here are the commands I am using to send traps:

SNMP v1:

snmptrap -v 1 -c myrocommunity manager_host_ip MY-MIB::traps.mytrap.0 localhost i 300 ''

SNMP v2c:

snmptrap -v 2c -c myrocommunity manager_host_ip '' MY-MIB::mytrap

Neither of these comamnds gives an error - that is, they all exit normally.

Any thoughts, workarounds etc? Need more info?

Many thanks,
Jon Daniels

3 REPLIES
Rob Bavcevich
Valued Contributor

Re: SNMP Traps are all listed as 'ColdStart'

hey - did you ever get this one sorted out ?
we have the same issue.

thanks,
rob.
Jonathan Daniels
Occasional Contributor

Re: SNMP Traps are all listed as 'ColdStart'

We eventually moved to another system - OS: RHEL4 U3, SNMP: v2, and the NMS we now use is a NetBoss, so I never did get this resolved in the environment I describe :(

You may want to verify the community string matches in the HP-SIM and the snmp agent config and the registered MIB. Ensure that all your traps are listed in the .cfg file

Cheers,
Jon
Rob Bavcevich
Valued Contributor

Re: SNMP Traps are all listed as 'ColdStart'

hey - we sorted out what the issue with these coldstarts (with the help of HP):

If you install from the 8.10 media, the management server gets the 8.10 agent.
The 8.10 agent is stuffed.

You need to patch the management server so that the agent distribution files are at least 8.14, then the important part: deploy the newly patched agent to the management server.

this solves the coldstart issue - if u ever come across it again 8).

Thanks,
rob.