Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

SNMP Traps not receiving

Seth Horila
Advisor

SNMP Traps not receiving

I have set up SIM 5.1 on a server and have imported the APC Powernet389 MIB into SIM (mxcompile, mxmib). However, i am not receiving trap notifications from the APC UPSes when I perform a test send from the APC management network card. I have verified community strings and the IP address of the receiver. I have also checked the firewall settings of the OS. I also used a free trap receiver program and that program successfully received the test trap. Any leads?

Thanks
4 REPLIES
Rob Buxton
Honored Contributor

Re: SNMP Traps not receiving

Is the APC discovered and visible in HPSIM? Has it been identified.
Check that the events are not just turning up as informational, if you click on the device name (or IP Address if it's not got a resolved name) you can then click on the Events tab to see any events associated with that device.

You may also want to check that you're allowing generic unregistered traps just in case they're not being picked up by the mib.
Seth Horila
Advisor

Re: SNMP Traps not receiving

The APC unit appears in SIM. I can view the events, the only item in there is the discovery notification. I have also allowed unregistered traps. I am not sure what else might be causing the issue. I could try deregistering and reregistering the APC MIB. But either way it should receive the SNMP trap in some form in the events given the unregistered setting.
Seth Horila
Advisor

Re: SNMP Traps not receiving

Solved. I had installed my trap receiver program awhile back and the service was running and prevented SIM from picking up the trap. All is now working!
Seth Horila
Advisor

Re: SNMP Traps not receiving

See message above