HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

SNMP traps not showing in Insight Manager 6

 
Campy
Occasional Advisor

SNMP traps not showing in Insight Manager 6

Since I've updated to version 6.0 traps stop showing up in the events table. Restarting the Insight service will usually fix this for a short time, very short. I test this by restarting the SNMP service on a server managed by Insight, the cold start traps never show. Restart the Insight service and bounce the SNMP service on the managed server and they show. A short time later, same test, they don't show along with any other traps. Anyone else?
11 REPLIES
OlivierV
Trusted Contributor

Re: SNMP traps not showing in Insight Manager 6

Hi Campy.

Can you verify the traps are handled : Options/Events/SNMP Trap setting.
The 'Cold start' trap (sent when SNMP is restarted) is managed by the snmpv2 mib if MIBs 8.40 is installed, rfc1215 if not.

Regards.
Campy
Occasional Advisor

Re: SNMP traps not showing in Insight Manager 6

Yes - they are set up to be handled and emailed via automatic event handler to the admins of the systems.
Torben Holm
Advisor

Re: SNMP traps not showing in Insight Manager 6

I have the same problem. But try wait an hour, then they might show up..

Torben
Brian Hahne
Regular Advisor

Re: SNMP traps not showing in Insight Manager 6

Had the same problem myself... sometimes they work, sometimes not.
Thought an upgrade to 6.1 would fix that...

Torben Holm
Advisor

Re: SNMP traps not showing in Insight Manager 6

It seems that the faulty part is the SNMP traps. Every time i start SIM it has problem starting the SNMP Trap service...But if i change to WBEM event subscription it goes better but not perfect.
Campy
Occasional Advisor

Re: SNMP traps not showing in Insight Manager 6

Just updated to version 6.1, hopefully that helps.
I did get the following error in the application log after reboot :

"Event filter with query "select * from HP_AlertIndication" could not be (re)activated in namespace "//./root/CIMV2" because of error 0x80041010. Events may not be delivered through this filter until the problem is corrected."
Campy
Occasional Advisor

Re: SNMP traps not showing in Insight Manager 6

Version 6.1 apears to have corrected the trap issue, been running since update and still showing traps. Looks like there may be a memory leak now though, mxdomainmgr likes to take all the memory over time. It was using 1.5Gb when it decided to die.
Nicolai Rasmussen
Regular Advisor

Re: SNMP traps not showing in Insight Manager 6

I'm running 6.0 and I don't have any TRAP issues. However, it appears that there's also a memory leak in 6.0.
Campy
Occasional Advisor

Re: SNMP traps not showing in Insight Manager 6

6.1 fixed my trap issue but it also appears to have a memory leak.

Re: SNMP traps not showing in Insight Manager 6

Hi Campy,

Also my HP SIM stopped showing any snmp traps after I upgraded it to v6.0. Yesterday I upgraded to v6.1 and my problem remains. I can still not see any SNMP traps in my HP SIM :-(.

Adila
elstermetering
Occasional Advisor

Re: SNMP traps not showing in Insight Manager 6

I had this problem a couple of weeks back. After much wailing and gnashing of teeth, I turned on the 'accept unregistered events' option and discovered that my Foundry wireless controller was constantly sending traps. (They were showing as unregistered because I was having trouble compiling the MIBs)

As soon as I removed my SIM server as trap destination on the Foundry kit, suddenly traps from all my servers etc started coming through again.

So effectively I was DOS'ing my own SIM server! That said, the amount of traps being sent shouldn't have been enough to mess up the server in this way (I think it was about 1 every 30 seconds) but stopping them fixed the problem nonetheless.