HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

Snmp traps sent on wrong interface

 
Radu Serbanescu
Occasional Visitor

Snmp traps sent on wrong interface

i have installed on integrity servers (rx2620 using sles9 ) the hp management agents (hpima) and configured snmp to send traps to an osem host. the server has 5 interfaces (eth0 -> eth4), from which eth0 is for heart-beat (used in cluster) and the other 4 are in bonding (2 bonds with 2 intf each). routes are configured correctly (default gw goes on bond0, which is made of eth1 + eth3).

the traps are sent from the first interface available (eth0), instead of going from bond0. i have searched the snmp docs and haven't found any answer on how to bound the trap sending address on a specific interface.

cat /proc/net/dev shows lo0, eth0, ..., eth4, in that order.

is there any possibility to force traps go out via bond0 ?

any idea will be welcomed.

thanks,

radu serbanescu
2 REPLIES
Aaron Edens
Occasional Visitor

Re: Snmp traps sent on wrong interface

Radu,

I assume that you are using some type of Unix. I am using Windows so I am not sure that the management agents behave the same way.

However you might try the "IP Binding" option if it exists in the Unix management agents. In the "IP Binding" page you can bind the agents to a network or specific IP address. I used for example:

192.168.1.10/32 or 192.168.1.10/255.255.255.255

This caused in my case the agents, and therefore the traps, to only enter/exit via one IP address on one NIC.

Hope it helps.

Radu Serbanescu
Occasional Visitor

Re: Snmp traps sent on wrong interface

hi aaron,

i'm using suse linux enterprise server 9 (sles9) on hp itanium servers rx2600, rx4640.

there is no option in the config file (in this case, snmpd.conf) where i can force binding traps sent to a specific interface.

thank you,

radu