Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

System Management Homepage not working

SOLVED
Go to solution
lichtsteiner
Occasional Advisor

System Management Homepage not working

Hi

I have installed the ProLiant Support Pack without getting any error during installation. I installed it on a clean RedHat 4 server. After installation, I'm able to access the System Management Homepage on port 2381, but no data is shown (see attachment).

My environment:
- Redhat EL 4 (x86_64)
- iLO 2 Firmware Version: 1.50 03/12/2008
- ProLiant Support Pack: psp-8.00.rhel4.x86_64.en.tar.gz

Any idea?

Thanks a lot
Patric
11 REPLIES
sandeep_raman
Honored Contributor

Re: System Management Homepage not working

hi,

* uname -a
* cat /etc/redhat-release
* cat /etc/snmp/snmpd.conf

paste the above outputs

regards,

/srh
CpqLucas
Occasional Contributor

Re: System Management Homepage not working

Hi,

I have the same sitution, but with WSS 2003R2, the difference is that before to show the same information, I'd receive a timeout error. The last PSP installed on the server is 7.91.

Can you help me too?

Regards
lichtsteiner
Occasional Advisor

Re: System Management Homepage not working

Thanks a lot for your answer!

#uname -a
Linux lxtwi080.apgsga.ch 2.6.9-67.ELsmp #1 SMP Wed Nov 7 13:56:44 EST 2007 x86_64 x86_64 x86_64 GNU/Linux

#cat /etc/snmp/snmp.conf
.> see attachment

#cat /etc/redhat-release
Red Hat Enterprise Linux AS release 4 (Nahant Update 6)

I don't get a timeout error message like 'CpqLucas'.

Patric
Graeme Bray
Regular Advisor

Re: System Management Homepage not working

This came out from HP today. Does it help either of you?

Advisory: HP System Management Homepage (SMH) Version 2.1.11.197 (Available On ProLiant Support Pack (PSP) Version 8.00) May Report the Error: "Page Cannot Be Displayed" On a ProLiant Server
HP System Management Homepage (SMH) Version 2.1.11.197 (available on ProLiant Support Pack (PSP) Version 8.00) may report the error: Page Cannot be Displayed on a ProLiant server. This occurs after the following has been performed:
Log into SMH.
Log out of SMH.
Log out of Windows Server 2003.
Log into Windows Server 2003.
Start SMH (the error report will then be displayed).
Any HP ProLiant server running HP System Management Homepage (SMH) Version 2.1.11.197 or ProLiant Support Pack (PSP) Version 8.00 and Windows Server 2003.
In order to prevent the error report and to ensure that SMH will start successfully, upgrade the SMH to Version 2.1.12.201 (or later), available as follows:
Click on the following URL:
http://welcome.hp.com/country/us/en/support.html?pageDisplay=drivers
Under Select a product category, select Servers .
Select ProLiant/tc Series and HP BladeSystem Servers .
Select the desired ProLiant series.
Select the appropriate operating system.
Select the category Software - System Management .
Select the HP System Management Homepage for Windows Version 2.1.12.201 (or later) and click the "Download" button.
OR
As a workaround when using a version of the SMH prior to version 2.1.12.201, perform the following to view the SMH page after logging in:
Click on Start.
Navigate to Administrative Tools.
Select Service.
Select HP SMH.
Right-click to select restart, or navigate to the left panel and select restart .
sandeep_raman
Honored Contributor

Re: System Management Homepage not working

1. add the below lines to snmpd.conf file after dlmod cmaX /usr/lib64/libcmaX64.so:

rwcommunity private 127.0.0.1
rocommunity public 127.0.0.1
trapcommunity public
trapsink localhost public

2. restart below services

* /etc/init.d/snmpd restart
* /etc/init.d/hpsmhd restart
* /etc/init.d/hpasm restart

3. private and public community strings may vary if set to something else. so if you have a working smh, [windows/linux] check if the strings are private and public. if not edit the entries to match the other working system

regards,

/srh
lichtsteiner
Occasional Advisor

Re: System Management Homepage not working

srh, thanks a lot for your answer.

I tried the suggested modifications in snmp.conf, but I didn't have success.

I also tried to copy a snmp.conf from a working installation (also Redhat Linux), but with the same result.

Do you have another suggestion?

Patric

@Graeme Bray: Unfortunately this does not exactly describe my problem. I do not get a "Page Cannot Be Displayed" error.
sandeep_raman
Honored Contributor

Re: System Management Homepage not working

reinstall snmp.restart snmp, smh and hpasm services

/srh
lichtsteiner
Occasional Advisor

Re: System Management Homepage not working

Sorry, but reinstalling didn't help (removed RPM and reinstalled it).

Do you know any log files that could help me?

Thanks
Patric
sandeep_raman
Honored Contributor
Solution

Re: System Management Homepage not working

ok wait a minute, do a

/etc/init.d/hpasm reconfigure

and answer the questionnaire presented to you :)). the last one is

Do you wish to disable hpsmh support (y/n)?

type no which is the default and see if it helps.

if the situation is no different, post

rpm -qa |grep hp
log:
/var/spool/opt/hp/hpsmh/logs/error_log
/var/log/hppldu.log

/srh
lichtsteiner
Occasional Advisor

Re: System Management Homepage not working

That was the hint I needed!

In the logfile you mentioned, I found the error message:
../../webapp-data/webagent/csginkgo: error while loading shared libraries: libstdc++.so.6: cannot open shared object file
: No such file or directory
I installed the corresponding RPM and now everything works.

Thanks a lot for not giving up and answering all my questions!

Patric
lichtsteiner
Occasional Advisor

Re: System Management Homepage not working

Checked the log file /var/spool/opt/hp/hpsmh/logs/error_log, where I found an error message that a so File is missing.