HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Server Management - Systems Insight Manager
cancel
Showing results for 
Search instead for 
Did you mean: 

TCP/IP not enabled error

 
Sam Moayedi
Occasional Advisor

TCP/IP not enabled error

Hello All,
Installation of SIM 5.2 on HP server with WIN 2003R2 X64 with SP1 and SQL sever 2005 SP2
fails with error "TCP/IP Protocol is not enabled for specific database server. Please use the SVRNETCN.exe to enable the TCP/IP protocol"
I run SVRNETCN.exe and it is empty (General and Network Libraries tab) as shown in attached file but configuration management shows TCP/IP has been enabled.
Where else do I need to check?
Thanks for your help
7 REPLIES
V Deepak Kumar
Regular Advisor

Re: TCP/IP not enabled error

Make sure TCP/IP library is present from the libraries tab.
Performance is compulsion and not an option if my existence is to be justified.
Sam Moayedi
Occasional Advisor

Re: TCP/IP not enabled error

Thanks Kumar for the quick response but as I mentioned Libraries is empty how can I add them
Is SQL 2005 still using SVRNETCN or not
Thanks
V Deepak Kumar
Regular Advisor

Re: TCP/IP not enabled error

Best way would be to reinstall.
Stop SQL Services
If thats not an option
Download all the network libs mentioned in the attached image with the version shown and download them to the SQL INstall directory. Dump them into this "C:\Program Files\Microsoft SQL Server\MSSQL\Binn"

Start SQL Services
A nice article on "http://msdn2.microsoft.com/en-us/library/aa174500(SQL.80).aspx"

Enable TCP/IP and Named Pipes from SVRNETCN.
Hope this helps.
Thanks
Deepak
Performance is compulsion and not an option if my existence is to be justified.
V Deepak Kumar
Regular Advisor

Re: TCP/IP not enabled error

Forgot to attach the image.
If reinstall is not an option try the steps mentioned earlier.
Thanks
Deepak

[If my solution works assign me points]
Performance is compulsion and not an option if my existence is to be justified.
Sam Moayedi
Occasional Advisor

Re: TCP/IP not enabled error

Hello Kumar
Are you running SQL 2005, is it the same in 2005?
Sam Moayedi
Occasional Advisor

Re: TCP/IP not enabled error

I contacted Microsofr and this is their response regarding SVRNETCN.exe
"That tool is for SQL Server 2000, not 2005. For 2005, you use the "SQL Server Configuration
Manager".
So How am I going to install SIM on SQL server 2005 since it is checking SVRNETCN.exe to verify network libraries and they are blank in SQL server 2005
Thanks for your help
Change_happens
Honored Contributor

Re: TCP/IP not enabled error

yes 2005 uses "Server Configuration
Manager" so in this u have to . SQL 2005 uses diff port may be that is disabled in ur PC.
or u can add that library in Alias section of manager.
Type cliconfg in RUN and see Alias add it there. or Just enable port it or see below:
whole information:
http://support.microsoft.com/kb/839269